[Enseignement] Problème de fonctionnement du module Xcos de Scilab avec compilateur mingw en administrateur ou utilisateur du domaine du réseau informatique

classic Classic list List threaded Threaded
2 messages Options
naze patrick naze patrick
Reply | Threaded
Open this post in threaded view
|

[Enseignement] Problème de fonctionnement du module Xcos de Scilab avec compilateur mingw en administrateur ou utilisateur du domaine du réseau informatique

 Bonjour,

 

Je m’appelle Patrick NAZE et je suis professeur en CPGE MPSI/MP au lycée militaire d’Autun.

Nous sommes en train d’installer Scilab version 5.4.1 et ses modules complémentaires dans une salle d’informatique dont les postes sont équipés de Windows XP 32 bits.

Je vous précise que tous les postes informatiques du lycée sont sur un réseau pédagogique où les professeurs et les étudiants se connectent avec nom d’utilisateur et mot de passe.

 

Voici la configuration Scilab installée :

-          Scilab version 5.4.1

-          gcc_4.5.2-32.exe

-          mingw_0.9.3-1.bin.windows.zip

-          coselica_0.6.2-1.bin.zip

-          SIMM_0.3-1.bin.zi

-          CPGE_1.5.1-1.bin.zip

 

L’installation est ensuite testée avec les fichiers suivants : test_chauffage.sce et Chauffage3.zcos.

 

Pour tester l’installation, nous avons commencé par installer sur un poste en administrateur local de la machine dans l’ordre, le compilateur  gcc (on reboote juste après), Scilab, mingw, coselica, SMM et enfin CPGE. L’installation Scilab  est réussie sans problème, les modules se sont bien installés et sont bien reconnus au lancement de Scilab et le fichier test fonctionne correctement.

Tout va bien !

 

En revanche, si maintenant on se met en administrateur ou utilisateur du domaine (sur le réseau), Scilab fonctionne correctement mais le fichier test « test_chauffage.sce » plante. En fait, il ne peut pas lancer le fichier « Chauffage3 .zcos ». En creusant sur internet, nous avons vu que nous ne sommes pas les seuls à avoir eu ce problème.

Apparemment, il y aurait un problème de droits qui ne permettrait pas au compilateur gcc de prendre en charge le fichier « Chauffage3.zcos ».

 

Je vous rappelle qu’en administrateur local de la machine, Scilab et son module Coselica avec le compilateur gcc fonctionnent correctement.

 

Pourriez-vous nous aider à résoudre ce problème car nous sommes obligés de travailler en mode utilisateur sur un domaine avec nos étudiants. Je pense que dans les autres lycées, les postes informatiques sont également en réseau et ce problème a dû déjà être soulevé voire résolu.

 

Je vous transmets en pièce jointe les fichiers « test_chauffage.sce » et « Chauffage3.zcos » utilisés pour nos tests d’installation.

Nous restons à votre disposition pour tout renseignement complémentaires.

 

Je vous remercie de votre soutien.

 

Patrick NAZE

Professeur CPGE MPSI/MP

Lycée Militaire d’Autun

 

Port : 06 15 56 25 25

[hidden email]

 


_______________________________________________
enseignement mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/enseignement
Jean Matthieu LEURENT Jean Matthieu LEURENT
Reply | Threaded
Open this post in threaded view
|

Re: [Enseignement] Problème de fonctionnement du module Xcos de Scilab avec compilateur mingw en administrateur ou utilisateur du domaine du réseau informatique

Bonsoir.
J'ai eu des problèmes similaires de droits des utilisateurs insuffisants que j'ai résolu avec Microsoft visual C++. Scilab a besoin d'un compilateur mais n'est pas regardant sur l'auteur du compilateur. En plus des 2 solutions proposées (MinGw et gcc (un seul suffit)), la solution Microsoft fonctionne aussi. Il se trouve que d'autres logiciels sont peu tolérant pour le choix du compilateur et le compilateur microsoft est le plus souvent accepté dans le monde windows (surprenant!).

Ecrire "VS2010Express1.iso" dans un moteur de recherche pour trouver le fichier à charger. La solution fonctionne très bien pour en 32 bits. En 64 bits, il existe aussi une solution mais c'est plus compliqué à l'installation.

ATTENTION: les versions antérieur à 2010 ne fonctionnent pas et empêchent  le plus souvent la bonne prise en compte des versions 2010 et plus en cas de cohabitation.

En souhaitant que vos problèmes trouvent solutions,
Jean-Matthieu Leurent




Le Lundi 25 novembre 2013 14h37, naze patrick <[hidden email]> a écrit :
 Bonjour,
 
Je m’appelle Patrick NAZE et je suis professeur en CPGE MPSI/MP au lycée militaire d’Autun.
Nous sommes en train d’installer Scilab version 5.4.1 et ses modules complémentaires dans une salle d’informatique dont les postes sont équipés de Windows XP 32 bits.
Je vous précise que tous les postes informatiques du lycée sont sur un réseau pédagogique où les professeurs et les étudiants se connectent avec nom d’utilisateur et mot de passe.
 
Voici la configuration Scilab installée :
-          Scilab version 5.4.1
-          gcc_4.5.2-32.exe
-          mingw_0.9.3-1.bin.windows.zip
-          coselica_0.6.2-1.bin.zip
-          SIMM_0.3-1.bin.zi
-          CPGE_1.5.1-1.bin.zip
 
L’installation est ensuite testée avec les fichiers suivants : test_chauffage.sce et Chauffage3.zcos.
 
Pour tester l’installation, nous avons commencé par installer sur un poste en administrateur local de la machine dans l’ordre, le compilateur  gcc (on reboote juste après), Scilab, mingw, coselica, SMM et enfin CPGE. L’installation Scilab  est réussie sans problème, les modules se sont bien installés et sont bien reconnus au lancement de Scilab et le fichier test fonctionne correctement.
Tout va bien !
 
En revanche, si maintenant on se met en administrateur ou utilisateur du domaine (sur le réseau), Scilab fonctionne correctement mais le fichier test « test_chauffage.sce » plante. En fait, il ne peut pas lancer le fichier « Chauffage3 .zcos ». En creusant sur internet, nous avons vu que nous ne sommes pas les seuls à avoir eu ce problème.
Apparemment, il y aurait un problème de droits qui ne permettrait pas au compilateur gcc de prendre en charge le fichier « Chauffage3.zcos ».
 
Je vous rappelle qu’en administrateur local de la machine, Scilab et son module Coselica avec le compilateur gcc fonctionnent correctement.
 
Pourriez-vous nous aider à résoudre ce problème car nous sommes obligés de travailler en mode utilisateur sur un domaine avec nos étudiants. Je pense que dans les autres lycées, les postes informatiques sont également en réseau et ce problème a dû déjà être soulevé voire résolu.
 
Je vous transmets en pièce jointe les fichiers « test_chauffage.sce » et « Chauffage3.zcos » utilisés pour nos tests d’installation.
Nous restons à votre disposition pour tout renseignement complémentaires.
 
Je vous remercie de votre soutien.
 
Patrick NAZE
Professeur CPGE MPSI/MP
Lycée Militaire d’Autun
 
Port : 06 15 56 25 25
 

_______________________________________________
enseignement mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/enseignement


_______________________________________________
enseignement mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/enseignement