Issue Launching Scilab Master After Successful Compilation

classic Classic list List threaded Threaded
1 message Options
Tan Chin Luh Tan Chin Luh
Reply | Threaded
Open this post in threaded view
|

Issue Launching Scilab Master After Successful Compilation

Hi, 

Greeting. I am trying to compile Scilab under Ubuntu 18.04 and the compilation was successful, however, when I tried to launch Scilab java and scilab-adv-cli, i get following error:

Could not access to the Main Scilab Class:
Exception in thread "main" java.lang.ExceptionInInitializerError
    at org.scilab.modules.localization.Messages.gettext(Unknown Source)
    at org.scilab.modules.commons.xml.XConfiguration.<clinit>(Unknown Source)
    at org.scilab.modules.core.Scilab.<clinit>(Unknown Source)
Caused by: java.lang.NullPointerException
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1847)
    at java.lang.Runtime.loadLibrary0(Runtime.java:871)
    at java.lang.System.loadLibrary(System.java:1124)
    at org.scilab.modules.localization.MessagesJNI.<clinit>(Unknown Source)
    ... 3 more

I aware there are some very recent updates to the gcc-9 and also the ant, so I briefly list down the last success launch and compile of the Scilab.

Before the thirdparty dependencies update:

--> Scilab was compiled and launched successfully with gcc-8, g++-8, openjdk-8 , by using the source form the git.scilab.org, and the dependency from the ttps://github.com/scilab/scilab-prerequirements

After the thirdparty dependencies update:

--> Scilab was compiled successfully but fail to launch with gcc-9, g++-9, openjdk-8 , by using the source form the git.scilab.org, and the dependency from the ttps://github.com/scilab/scilab-prerequirements

I've also tried clean installation but the same issue happened.

Please advice.

Thanks.

Regards,
Chin Luh


_______________________________________________
dev mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/dev