Quantcast

Re: GUI Builder 4.0.1 for Scilab 6.0

classic Classic list List threaded Threaded
1 message Options
Frieder Nikolaisen Frieder Nikolaisen
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GUI Builder 4.0.1 for Scilab 6.0

I restarted the project with the GUI Builder 3.0 for Scilab 5.5. To now, it runs normal. I attach the working file.

I do not understand the trouble. I had other problems yesterday, with both versions. Hopefully it runs now stable.

 

Am 2017-05-04 09:13, schrieb Frieder Nikolaisen:

Dear Community,

I am using the GUI Builder again (last time Oktobre 2016), now with Scilab 6.0.0.

I started to Design the interface, generated the GUI. Had the GUI run and wanted to reload it. But:

 
--> guibuilder
operation -: Warning adding a matrix with the empty matrix will give an empty matrix result.
operation +: Warning adding a matrix with the empty matrix will give an empty matrix result.
at line    60 of function guigetfile        
at line     4 of function openfile          
at line     9 of function open_existing_gui

':': Wrong type for argument 1: Real scalar expected.

 

And with the old version I am used to (but its still desigend with Scilab 6):

START GUI Builder 3.0 for Scilab 5.5
    Load macros
    Load help
    Type "guibuilder" to start the GUI

 
-->guibuilder
  !--error 21
ungültiger Index.
at line       8 of function openfile called by :  
at line       9 of function open_existing_gui called by :  
= gcbo; end;gcbo = getcallbackobject(118);open_existing_gui(handles);if exists("%oldgcbo") then gcbo = %oldgcbo; else clear gcbo; end
while executing a callback

 

The file is attached. 

Scilab 5.5 and 6 open the programm with save and run. But not with the Builder.

Whats wrong?

Best regards

Frieder

 

 

 

 

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

Simulation_v2.6.sce (12K) Download Attachment
Loading...