Running scilab 5.0.3 using an older version of glibc

classic Classic list List threaded Threaded
5 messages Options
Kevin Cristobal Kevin Cristobal
Reply | Threaded
Open this post in threaded view
|

Running scilab 5.0.3 using an older version of glibc

Hi,

I was able to run scilab 4.1.2 in my centOS pc. However, when I attempted to run scilab 5.0.3, this message comes out:


[root@medgrid scilab-5.0.3]# ./bin/scilab
[root@medgrid scilab-5.0.3]# /root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libgfortran.so.3)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscishell.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscilocalization.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscicore.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libblas.so.3gf)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libmex.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscielementary_functions.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscifileio.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscigraphics.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscigraphic_export.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscirenderer.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscigui.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libsciio.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscitclsci.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscicompletion.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscihistory_manager.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscidynamic_link.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscioutput_stream.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscisound.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscimetanet.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscispreadsheet.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscistring.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libsciumfpack.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libsciscicos_blocks.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libmx.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libmat.so.5)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libstdc++.so.6)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libtk8.5.so)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libtcl8.5.so)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libmatio.so.0)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libz.so.1)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libpcre.so.0)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libfftw3.so.3)
/root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libscisundials.so.0)



Unfortunately, I need that version of scilab for a program I'm transferring from a Windows PC to a Linux PC (because it has something 4.1.2 doesn't have regarding java). So what I need to know is that if there's a way to get scilab 5.x to run on glibc 2.3.

Regards
Kevin


sylvestre sylvestre
Reply | Threaded
Open this post in threaded view
|

Re: Running scilab 5.0.3 using an older version of glibc

Le jeudi 05 février 2009 à 03:00 -0800, Kevin Cristobal a écrit :
> Hi,
>
> I was able to run scilab 4.1.2 in my centOS pc. However, when I
> attempted to run scilab 5.0.3, this message comes out:
>
>
> [root@medgrid scilab-5.0.3]# ./bin/scilab
> [root@medgrid
> scilab-5.0.3]# /root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libgfortran.so.3)

Normally, we fixed this bug in the nightly build (both master & 5.1).
This bug is due to a symbol added by the compiler (stack-protector)
which is only defined in the glibc version >= 2.4.

Sylvestre



Kevin Cristobal Kevin Cristobal
Reply | Threaded
Open this post in threaded view
|

Re: Running scilab 5.0.3 using an older version of glibc

I tried running the nightly builds, but they displayed the same errors. Any other solutions?


From: Sylvestre Ledru <[hidden email]>
To: [hidden email]
Sent: Thursday, February 5, 2009 7:07:27 PM
Subject: Re: [scilab-Users] Running scilab 5.0.3 using an older version of glibc

Le jeudi 05 février 2009 à 03:00 -0800, Kevin Cristobal a écrit :
> Hi,
>
> I was able to run scilab 4.1.2 in my centOS pc. However, when I
> attempted to run scilab 5.0.3, this message comes out:
>
>
> [root@medgrid scilab-5.0.3]# ./bin/scilab
> [root@medgrid
> scilab-5.0.3]# /root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libgfortran.so.3)

Normally, we fixed this bug in the nightly build (both master & 5.1).
This bug is due to a symbol added by the compiler (stack-protector)
which is only defined in the glibc version >= 2.4.

Sylvestre



sylvestre sylvestre
Reply | Threaded
Open this post in threaded view
|

Re: Running scilab 5.0.3 using an older version of glibc

Le vendredi 06 février 2009 à 01:14 -0800, Kevin Cristobal a écrit :
> I tried running the nightly builds, but they displayed the same
> errors. Any other solutions?
64 or 32 bits ?


>
>
> ______________________________________________________________________
> From: Sylvestre Ledru <[hidden email]>
> To: [hidden email]
> Sent: Thursday, February 5, 2009 7:07:27 PM
> Subject: Re: [scilab-Users] Running scilab 5.0.3 using an older
> version of glibc
>
> Le jeudi 05 février 2009 à 03:00 -0800, Kevin Cristobal a écrit :
> > Hi,
> >
> > I was able to run scilab 4.1.2 in my centOS pc. However, when I
> > attempted to run scilab 5.0.3, this message comes out:
> >
> >
> > [root@medgrid scilab-5.0.3]# ./bin/scilab
> > [root@medgrid
> >
> scilab-5.0.3]# /root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libgfortran.so.3)
>
> Normally, we fixed this bug in the nightly build (both master & 5.1).
> This bug is due to a symbol added by the compiler (stack-protector)
> which is only defined in the glibc version >= 2.4.
>
> Sylvestre
>
>
>
>


Kevin Cristobal Kevin Cristobal
Reply | Threaded
Open this post in threaded view
|

Re: Running scilab 5.0.3 using an older version of glibc

32-bit


From: Sylvestre Ledru <[hidden email]>
To: [hidden email]
Sent: Friday, February 6, 2009 5:30:34 PM
Subject: Re: [scilab-Users] Running scilab 5.0.3 using an older version of glibc

Le vendredi 06 février 2009 à 01:14 -0800, Kevin Cristobal a écrit :
> I tried running the nightly builds, but they displayed the same
> errors. Any other solutions?
64 or 32 bits ?


>
>
> ______________________________________________________________________
> From: Sylvestre Ledru <[hidden email]>
> To: [hidden email]
> Sent: Thursday, February 5, 2009 7:07:27 PM
> Subject: Re: [scilab-Users] Running scilab 5.0.3 using an older
> version of glibc
>
> Le jeudi 05 février 2009 à 03:00 -0800, Kevin Cristobal a écrit :
> > Hi,
> >
> > I was able to run scilab 4.1.2 in my centOS pc. However, when I
> > attempted to run scilab 5.0.3, this message comes out:
> >
> >
> > [root@medgrid scilab-5.0.3]# ./bin/scilab
> > [root@medgrid
> >
> scilab-5.0.3]# /root/scilab/scilab-5.0.3/bin/scilab-bin: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /root/scilab/scilab-5.0.3/lib/scilab/libgfortran.so.3)
>
> Normally, we fixed this bug in the nightly build (both master & 5.1).
> This bug is due to a symbol added by the compiler (stack-protector)
> which is only defined in the glibc version >= 2.4.
>
> Sylvestre
>
>
>
>