SIVP-0.5.3 fails install on Scilab 5.3.3

classic Classic list List threaded Threaded
4 messages Options
Berns Buenaobra Berns Buenaobra
Reply | Threaded
Open this post in threaded view
|

SIVP-0.5.3 fails install on Scilab 5.3.3

Hello all:

For some reason if I install the prior version of SIVP which is 0.5.2 using the line invocation on an offline mode using cd SCI/contrib/sivp-0.5.2 then followed by  exec('builder.sce') all went well with no errors unlike when I tried to install the latest version of SIVP-0.5.3 I have the following errors:

!common.c                                                                                          !
!                                                                                                  !
!c:\program files\scilab-5.3.3\contrib\sivp-0.5.3\sci_gateway\c\common.h(43) : fatal error C1083: C!
!     annot open include file: 'cxcore.h': Invalid argument                                        !
!                                                                                                  !
!NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\VC\bin\cl.EXE"' : return!
!      code '0x2'                                                                                  !
!                                                                                                  !
!Stop.                                                                                             !
 !--error 10000
ilib_compile: Error while executing Makelib.mak.
at line      76 of function ilib_compile called by : 
at line     107 of function ilib_build called by : 
at line     133 of function tbx_build_gateway called by : 
inter_ldflags ,                    inter_cflags  )
at line      98 of exec file called by :   

at line      13 of function tbx_builder called by : 
at line      49 of function tbx_builder_gateway_lang called by : 
tbx_builder_gateway_lang(languages, sci_gateway_dir);
at line       6 of exec file called by :   

at line      13 of function tbx_builder called by : 
at line      32 of function tbx_builder_gateway called by : 
tbx_builder_gateway(toolbox_dir);
at line      34 of exec file called by :   
exec('builder.sce')
======================================================================

What can be wrong with the update?

Regards,

Berns B.
gareste gareste
Reply | Threaded
Open this post in threaded view
|

Re: SIVP-0.5.3 fails install on Scilab 5.3.3

Hi,

The common.h file does not see your file cxcore.h, which should be in the thirdparty folder.
Why don't you use the binary version provided by the portal atoms, and install it using atomsInstall("SIVP") ? Do you have to compile it yourself?

Simon

On 18/01/2012 05:55, Berns Buenaobra wrote:
Hello all:

For some reason if I install the prior version of SIVP which is 0.5.2 using the line invocation on an offline mode using cd SCI/contrib/sivp-0.5.2 then followed by  exec('builder.sce') all went well with no errors unlike when I tried to install the latest version of SIVP-0.5.3 I have the following errors:

!common.c                                                                                          !
!                                                                                                  !
!c:\program files\scilab-5.3.3\contrib\sivp-0.5.3\sci_gateway\c\common.h(43) : fatal error C1083: C!
!     annot open include file: 'cxcore.h': Invalid argument                                        !
!                                                                                                  !
!NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\VC\bin\cl.EXE"' : return!
!      code '0x2'                                                                                  !
!                                                                                                  !
!Stop.                                                                                             !
 !--error 10000
ilib_compile: Error while executing Makelib.mak.
at line      76 of function ilib_compile called by : 
at line     107 of function ilib_build called by : 
at line     133 of function tbx_build_gateway called by : 
inter_ldflags ,                    inter_cflags  )
at line      98 of exec file called by :   

at line      13 of function tbx_builder called by : 
at line      49 of function tbx_builder_gateway_lang called by : 
tbx_builder_gateway_lang(languages, sci_gateway_dir);
at line       6 of exec file called by :   

at line      13 of function tbx_builder called by : 
at line      32 of function tbx_builder_gateway called by : 
tbx_builder_gateway(toolbox_dir);
at line      34 of exec file called by :   
exec('builder.sce')
======================================================================

What can be wrong with the update?

Regards,

Berns B.

-- 
--
Simon Gareste
Support & Development Engineer
Consortium Scilab-DIGITEO
Berns Buenaobra Berns Buenaobra
Reply | Threaded
Open this post in threaded view
|

Re: SIVP-0.5.3 fails install on Scilab 5.3.3

Hi Simon:

Thanks for the reply. ATOMS is the way to go less painfully alright
however, I resorted to an offline installation due to network
constraints in the university lab I worked with.

I will use a wireless USB modem instead to do it and access the
binaries to work for me.

Question is still why it works with the previous SIVP and not with the latest?

Regards,

Berns B.



On 1/19/12, Simon GARESTE <[hidden email]> wrote:

> Hi,
>
> The common.h file does not see your file cxcore.h, which should be in
> the thirdparty folder.
> Why don't you use the binary version provided by the portal atoms
> <http://www.atoms.scilab.org/toolboxes/SIVP>, and install it using
> atomsInstall("SIVP") ? Do you have to compile it yourself?
>
> Simon
>
> On 18/01/2012 05:55, Berns Buenaobra wrote:
>> Hello all:
>>
>> For some reason if I install the prior version of SIVP which is 0.5.2
>> using the line invocation on an offline mode using cd
>> SCI/contrib/sivp-0.5.2 then followed by  exec('builder.sce') all went
>> well with no errors unlike when I tried to install the latest version
>> of SIVP-0.5.3 I have the following errors:
>>
>> !common.c
>>
>> !
>> !
>>
>> !
>> !c:\program
>> files\scilab-5.3.3\contrib\sivp-0.5.3\sci_gateway\c\common.h(43) :
>> fatal error C1083: C!
>> !     annot open include file: 'cxcore.h': Invalid
>> argument                                        !
>> !
>>
>> !
>> !NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio
>> 9.0\VC\bin\cl.EXE"' : return!
>> !      code
>> '0x2'
>>
>> !
>> !
>>
>> !
>> !Stop.
>>
>> !
>>  !--error 10000
>> ilib_compile: Error while executing Makelib.mak.
>> at line      76 of function ilib_compile called by :
>> at line     107 of function ilib_build called by :
>> at line     133 of function tbx_build_gateway called by :
>> inter_ldflags ,                    inter_cflags  )
>> at line      98 of exec file called by :
>>
>> at line      13 of function tbx_builder called by :
>> at line      49 of function tbx_builder_gateway_lang called by :
>> tbx_builder_gateway_lang(languages, sci_gateway_dir);
>> at line       6 of exec file called by :
>>
>> at line      13 of function tbx_builder called by :
>> at line      32 of function tbx_builder_gateway called by :
>> tbx_builder_gateway(toolbox_dir);
>> at line      34 of exec file called by :
>> exec('builder.sce')
>> ======================================================================
>>
>> What can be wrong with the update?
>>
>> Regards,
>>
>> Berns B.
>
> --
> --
> Simon Gareste
> Support&  Development Engineer
> Consortium Scilab-DIGITEO
>
>


--
==========================================
Bernardino Jerez Buenaobra
Motion Control Engineer
FW/Motion Control Laboratory
Lexmark Research and Development Corporation (LRDC)
6F Lexmark Plaza 2
Samar Loop corner Panay Road,
Cebu Business Park, Cebu City,
6000 Philippines
Direct number: +6332 234 8763
Mobile: +639162911607
email:[hidden email]
Skype ID: poormanphysics

"Res Imus Motus..."(We set things in motion)
==========================================

--
To unsubscribe from this mailing-list, please send an empty mail to
[hidden email]
To check the archives of this mailing list, see
http://mailinglists.scilab.org/

gareste gareste
Reply | Threaded
Open this post in threaded view
|

Re: SIVP-0.5.3 fails install on Scilab 5.3.3

Hi Berns,

When I look on the website, I can't see a 0.5.2 version of the toolbox,
so where did you get it from? I can't compare the versions and find a
reason if I don't have something to compare it to.
Which arch are you on, 32 or 64? Where do you get your versions from,
since it does not seem to be from Internet at your work? What is your
exact process for installing the toolboxes?

Regards,
Simon


On 19/01/2012 00:57, Berns Buenaobra wrote:

> Hi Simon:
>
> Thanks for the reply. ATOMS is the way to go less painfully alright
> however, I resorted to an offline installation due to network
> constraints in the university lab I worked with.
>
> I will use a wireless USB modem instead to do it and access the
> binaries to work for me.
>
> Question is still why it works with the previous SIVP and not with the latest?
>
> Regards,
>
> Berns B.
>
>
>
> On 1/19/12, Simon GARESTE<[hidden email]>  wrote:
>> Hi,
>>
>> The common.h file does not see your file cxcore.h, which should be in
>> the thirdparty folder.
>> Why don't you use the binary version provided by the portal atoms
>> <http://www.atoms.scilab.org/toolboxes/SIVP>, and install it using
>> atomsInstall("SIVP") ? Do you have to compile it yourself?
>>
>> Simon
>>
>> On 18/01/2012 05:55, Berns Buenaobra wrote:
>>> Hello all:
>>>
>>> For some reason if I install the prior version of SIVP which is 0.5.2
>>> using the line invocation on an offline mode using cd
>>> SCI/contrib/sivp-0.5.2 then followed by  exec('builder.sce') all went
>>> well with no errors unlike when I tried to install the latest version
>>> of SIVP-0.5.3 I have the following errors:
>>>
>>> !common.c
>>>
>>> !
>>> !
>>>
>>> !
>>> !c:\program
>>> files\scilab-5.3.3\contrib\sivp-0.5.3\sci_gateway\c\common.h(43) :
>>> fatal error C1083: C!
>>> !     annot open include file: 'cxcore.h': Invalid
>>> argument                                        !
>>> !
>>>
>>> !
>>> !NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio
>>> 9.0\VC\bin\cl.EXE"' : return!
>>> !      code
>>> '0x2'
>>>
>>> !
>>> !
>>>
>>> !
>>> !Stop.
>>>
>>> !
>>>   !--error 10000
>>> ilib_compile: Error while executing Makelib.mak.
>>> at line      76 of function ilib_compile called by :
>>> at line     107 of function ilib_build called by :
>>> at line     133 of function tbx_build_gateway called by :
>>> inter_ldflags ,                    inter_cflags  )
>>> at line      98 of exec file called by :
>>>
>>> at line      13 of function tbx_builder called by :
>>> at line      49 of function tbx_builder_gateway_lang called by :
>>> tbx_builder_gateway_lang(languages, sci_gateway_dir);
>>> at line       6 of exec file called by :
>>>
>>> at line      13 of function tbx_builder called by :
>>> at line      32 of function tbx_builder_gateway called by :
>>> tbx_builder_gateway(toolbox_dir);
>>> at line      34 of exec file called by :
>>> exec('builder.sce')
>>> ======================================================================
>>>
>>> What can be wrong with the update?
>>>
>>> Regards,
>>>
>>> Berns B.
>> --
>> --
>> Simon Gareste
>> Support&   Development Engineer
>> Consortium Scilab-DIGITEO
>>
>>
>

--
--
Simon Gareste
Support&  Development Engineer
Consortium Scilab-DIGITEO


--
To unsubscribe from this mailing-list, please send an empty mail to
[hidden email]
To check the archives of this mailing list, see
http://mailinglists.scilab.org/