Scilab 5.4.0

classic Classic list List threaded Threaded
3 messages Options
Sylvestre Ledru-4 Sylvestre Ledru-4
Reply | Threaded
Open this post in threaded view
|

Scilab 5.4.0

Hello,

As you are probably aware, we are working on the 5.4.0.

We released one alpha and, for now, two beta.
Even if we believe the 5.4.0 will be the best release of Scilab and the
quality is already very good, we will probably release a third beta.

Anyway, to prepare Scilab 5.4.0 upload in your respective packaging
system, here is the list of packages changes

1) Scirenderer - http://forge.scilab.org/index.php/p/scirenderer/
This is a new library for 2D/3D rendering. Depending on jogl 2.0, we
developped this library in a generic way.
The current nightly is using 0.5.6 but this is likely to change in the
close future.

This a very easy library to package:
"ant jar" => the jar is all we need.

We are also producing some javadoc which can be provided to potential
the dev users.


2) arpack-ng - http://forge.scilab.org/index.php/p/arpack-ng/
Since arpack upstream was dead, with Octave and Debian, we took over the
maintenance and forked this library.

The minimal version expected in Scilab is the release 3.1.0.


3) Flexdock - http://forge.scilab.org/index.php/p/flexdock/
Same as arpack, Scilab Enterprises is now the main maintainer of this
library.
Scilab expects the version 1.2.0.

As scirenderer, it is a trivial library... especially since we dropped
the useless JNI code.


4) jgraphx
Because of the various upstream internal changes which breaks the ABI,
we are still using the version 1.8.0.3. Tests shows that new releases
should be ok but no guarantees.

As usual, don't hesitate if you have any questions.

Cheers,
Sylvestre
Sylvestre Ledru-4 Sylvestre Ledru-4
Reply | Threaded
Open this post in threaded view
|

Re: Scilab 5.4.0

On 09/08/2012 10:56, Sylvestre Ledru wrote:

> Hello,
>
> As you are probably aware, we are working on the 5.4.0.
>
> We released one alpha and, for now, two beta.
> Even if we believe the 5.4.0 will be the best release of Scilab and
> the quality is already very good, we will probably release a third beta.
>
> Anyway, to prepare Scilab 5.4.0 upload in your respective packaging
> system, here is the list of packages changes
Another excellent news!

We have been able to drop the java hdf dependency (it was used by Xcos).
Therefor, the beta 3 of Scilab won't need this dependency!

Sylvestre

Sylvestre Ledru-4 Sylvestre Ledru-4
Reply | Threaded
Open this post in threaded view
|

Re: [distributor] Scilab 5.4.0

In reply to this post by Sylvestre Ledru-4
Le 09/08/2012 10:56, Sylvestre Ledru a écrit :
> Hello,
>
> As you are probably aware, we are working on the 5.4.0.
Here, we are, we just released it! (well, yesterday).

Basically, we updated jlatexmath to version 1.0 (just minor bugs fixes)
and scirenderer to version 1.0.2 (idem, minor stuff).

If you already packaged the beta releases, no important changes.

For example, Scilab works fine with HDF 1.8.9 or jogl2 rc10.

Cheers,
S

_______________________________________________
distributor mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/distributor