Scilab 6.1 in Raspberry Pi

classic Classic list List threaded Threaded
2 messages Options
Tan Chin Luh Tan Chin Luh
Reply | Threaded
Open this post in threaded view
|

Scilab 6.1 in Raspberry Pi

Hi Scilab developers, 

Ever since Raspberry Pi 4 released with extra RAM of 2G and 4G version, Scilab could be run quite smoothly under Ubuntu Server RaspPi version. (In fact, the speed is quite acceptable even in Raspberry Pi 3). Even it is still having some bugs, the binary provided by the Ubuntu repository could just run after apt-get in Raspberry Pi. (Scilab 6.01 / 6.02 under current LTS 18.04 and 19.10 respectively). 

Since the release of Scilab 6.1 is quite new, it is only available in unstable release, or we need to recompile from scratch (no-gui). However, even the scilab-cli could launch with both method, I encounter the following crash whenever Scilab 6.1 (scilab-cli) start to echo character '0' on the screen

________________________
ubuntu@ubuntu:~/scilab_master/scilab/bin$ ./scilab-cli
Scilab branch-master (Mar  7 2020, 02:45:45)

--> a = 1;

--> b = 0;

--> a
a  =

   1.

--> b
b  =

terminate called after throwing an instance of 'std::length_error'
  what():  basic_string::_M_replace_aux
A fatal error has been detected by Scilab.
Please check your user-defined functions (or external module ones) should they appear in the stack trace.
Otherwise you can report a bug on http://bugzilla.scilab.org/ with:
* a sample code which reproduces the issue
* the result of [a, b] = getdebuginfo()
* the following information:
[ubuntu:24308] Signal: Aborted (6)
[ubuntu:24308] Signal code:  (-6)

Call stack:
   1: 0x324d8  <raise>                          (/lib/aarch64-linux-gnu/libc.so.6)
End of stack

_________________________________

Anyone has any idea on what likely causing the problem?


More details:

-->  [a, b] = getdebuginfo()
a  =

  "Total memory:    1892552"
  "Used memory:    1137908"
  "Free memory:     754644"
  "Shared memory:          0"
  "Buffers memory:      53452"
  "Cached memory:     813852"
  "Used -/+ buffers/cache:     270604"
  "Free -/+ buffers/cache:    1621948"
  "Total swap:          0"
  "Used swap:          0"
  "Free swap:          0"
  "SCI: /home/ubuntu/scilab_master/scilab"
  "SCIHOME: /home/ubuntu/.Scilab/scilab-branch-master"
  "TMPDIR: /tmp/SCI_TMP_24419_wVkgKB"
b  =

  "Scilab Version: scilab-branch-master"
  "Compilation date: Mar  7 2020"
  "Compilation time: 02:45:44"
  "Compileur version: 8.3.0"
  "XML version: 2.9.4"
  "Compiler Architecture: X64"


compiled using gcc version 8, openjdk-8, jogl2 2.3.2 with the patch from changes 17530. 


Thanks in advance. 

Regards,
Chin Luh





_______________________________________________
dev mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/dev
Tan Chin Luh Tan Chin Luh
Reply | Threaded
Open this post in threaded view
|

Re: Scilab 6.1 in Raspberry Pi

the proposed solution at :


thanks.

rgds,
Chin Luh


---- On Sat, 07 Mar 2020 14:30:01 +0800 Chin Luh Tan <[hidden email]> wrote ----

Hi Scilab developers, 

Ever since Raspberry Pi 4 released with extra RAM of 2G and 4G version, Scilab could be run quite smoothly under Ubuntu Server RaspPi version. (In fact, the speed is quite acceptable even in Raspberry Pi 3). Even it is still having some bugs, the binary provided by the Ubuntu repository could just run after apt-get in Raspberry Pi. (Scilab 6.01 / 6.02 under current LTS 18.04 and 19.10 respectively). 

Since the release of Scilab 6.1 is quite new, it is only available in unstable release, or we need to recompile from scratch (no-gui). However, even the scilab-cli could launch with both method, I encounter the following crash whenever Scilab 6.1 (scilab-cli) start to echo character '0' on the screen

________________________
ubuntu@ubuntu:~/scilab_master/scilab/bin$ ./scilab-cli
Scilab branch-master (Mar  7 2020, 02:45:45)

--> a = 1;

--> b = 0;

--> a
a  =

   1.

--> b
b  =

terminate called after throwing an instance of 'std::length_error'
  what():  basic_string::_M_replace_aux
A fatal error has been detected by Scilab.
Please check your user-defined functions (or external module ones) should they appear in the stack trace.
Otherwise you can report a bug on http://bugzilla.scilab.org/ with:
* a sample code which reproduces the issue
* the result of [a, b] = getdebuginfo()
* the following information:
[ubuntu:24308] Signal: Aborted (6)
[ubuntu:24308] Signal code:  (-6)

Call stack:
   1: 0x324d8  <raise>                          (/lib/aarch64-linux-gnu/libc.so.6)
End of stack

_________________________________

Anyone has any idea on what likely causing the problem?


More details:

-->  [a, b] = getdebuginfo()
a  =

  "Total memory:    1892552"
  "Used memory:    1137908"
  "Free memory:     754644"
  "Shared memory:          0"
  "Buffers memory:      53452"
  "Cached memory:     813852"
  "Used -/+ buffers/cache:     270604"
  "Free -/+ buffers/cache:    1621948"
  "Total swap:          0"
  "Used swap:          0"
  "Free swap:          0"
  "SCI: /home/ubuntu/scilab_master/scilab"
  "SCIHOME: /home/ubuntu/.Scilab/scilab-branch-master"
  "TMPDIR: /tmp/SCI_TMP_24419_wVkgKB"
b  =

  "Scilab Version: scilab-branch-master"
  "Compilation date: Mar  7 2020"
  "Compilation time: 02:45:44"
  "Compileur version: 8.3.0"
  "XML version: 2.9.4"
  "Compiler Architecture: X64"


compiled using gcc version 8, openjdk-8, jogl2 2.3.2 with the patch from changes 17530. 


Thanks in advance. 

Regards,
Chin Luh




_______________________________________________
dev mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/dev



_______________________________________________
dev mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/dev