Scilab Query: Related to stacksize

classic Classic list List threaded Threaded
18 messages Options
Nirav Thakkar Nirav Thakkar
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Scilab Query: Related to stacksize

Hi ,
 
Good evening. I am a Scilab user and need help.
 
I am using, y = grand(10^6,90,'nor,0,1) to generate 90 columns and 1 million rows of normal distributed Random variables with mean =0 and std=1.
 
But I am getting following error: O=grand(10^6,90,'nor',0,1);
                                              !--error 17
                                            Rand: stack size exceeded (Use stacksize function to increase it). 
 
I used stacksize('max') but its not solving the problem.
 
Please help me in this regard. Thanks
 
Nirav B Thakkar
India

GOBILLOT Gilles 116128 GOBILLOT Gilles 116128
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Scilab Query: Related to stacksize

Try :
stacksize(1e8)
y = grand(10^6,90,'nor',0,1);

regards,

Gilles 

 


De : Nirav Thakkar [mailto:[hidden email]]
Envoyé : vendredi 18 novembre 2011 11:11
À : [hidden email]
Objet : [scilab-Users] Scilab Query: Related to stacksize

Hi ,
 
Good evening. I am a Scilab user and need help.
 
I am using, y = grand(10^6,90,'nor,0,1) to generate 90 columns and 1 million rows of normal distributed Random variables with mean =0 and std=1.
 
But I am getting following error: O=grand(10^6,90,'nor',0,1);
                                              !--error 17
                                            Rand: stack size exceeded (Use stacksize function to increase it). 
 
I used stacksize('max') but its not solving the problem.
 
Please help me in this regard. Thanks
 
Nirav B Thakkar
India

Brian_Hult Brian_Hult
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Scilab Query: Related to stacksize

In reply to this post by Nirav Thakkar
Return Receipt
                                                                           
   Your       RE: [scilab-Users] Scilab Query: Related to stacksize        
   document:                                                              
                                                                           
   was        Brian Hult/Billerica/Cabot                                  
   received                                                                
   by:                                                                    
                                                                           
   at:        11/18/2011 07:19:52 AM                                      
                                                                           




Antoine Monmayrant Antoine Monmayrant
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Scilab Query: Related to stacksize

In reply to this post by Nirav Thakkar
Le 18/11/2011 11:10, Nirav Thakkar a écrit :

> Hi ,
>
> Good evening. I am a Scilab user and need help.
>
> I am using, y = grand(10^6,90,'nor,0,1) to generate 90 columns and 1
> million rows of normal distributed Random variables with mean =0 and std=1.
>
> But I am getting following error: O=grand(10^6,90,'nor',0,1);
>                                                !--error 17
>                                              Rand: stack size exceeded (Use
> stacksize function to increase it).
>
> I used stacksize('max') but its not solving the problem.
>
> Please help me in this regard. Thanks
>
> Nirav B Thakkar
> India
>
How much RAM do you have on your computer?
On mine, I need to crank up stacksize to 1e8 to calculate O, which eats
up almost 1GB of RAM!
You may not have enough RAM...

Antoine

Maso Ricci Maso Ricci
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

I do really need help with an editor error

Hi all,

please help me... I was working in Scilab 5.3.3 and I had this error
when I tried to launch the editor:


[Fatal Error] scinotesConfiguration.xml:1:1: Content is not allowed in
prolog.
Could not load file:
C:\DOCUME~1\Maso\DATIAP~1\Scilab\scilab-5.3.3/scinotesConfiguration.xml
[Fatal Error] scinotesConfiguration.xml:1:1: Content is not allowed in
prolog.
Could not load file:
C:\DOCUME~1\Maso\DATIAP~1\Scilab\scilab-5.3.3/scinotesConfiguration.xml
java.lang.reflect.InvocationTargetException
     at java.awt.EventQueue.invokeAndWait(Unknown Source)
     at javax.swing.SwingUtilities.invokeAndWait(Unknown Source)
     at org.scilab.modules.scinotes.SciNotes.scinotes(Unknown Source)
Caused by: java.lang.NullPointerException
     at
org.scilab.modules.scinotes.utils.ConfigSciNotesManager.checkVersion(Unknown
Source)
     at
org.scilab.modules.scinotes.utils.ConfigSciNotesManager.createUserCopy(Unknown
Source)
     at org.scilab.modules.scinotes.SciNotes.createEditor(Unknown Source)
     at org.scilab.modules.scinotes.SciNotes.launchSciNotes(Unknown Source)
     at org.scilab.modules.scinotes.SciNotes$2.run(Unknown Source)
     at java.awt.event.InvocationEvent.dispatch(Unknown Source)
     at java.awt.EventQueue.dispatchEvent(Unknown Source)
     at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
     at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
     at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
     at java.awt.EventDispatchThread.run(Unknown Source)
Warning !!!
Scilab has found a critical error (Unknown exception)
with "editor" function.
Save your data and restart Scilab.

--
----------------------------------------
Maso RICCI PhD
Dipartimento Farmaco Chimico Tecnologico
Università degli Studi di Siena
Via Aldo Moro,2
Siena

phone: +390577234367
email: [hidden email]
----------------------------------------

calixte calixte
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I do really need help with an editor error

Hi Maso,

Could you attach your file
C:\DOCUME~1\Maso\DATIAP~1\Scilab\scilab-5.3.3/scinotesConfiguration.xm ?
and after that just remove it should fix the problem (but I need to have
the file to debug)

Regards

Calixte


On 18/11/2011 14:09, Maso RICCI wrote:

> Hi all,
>
> please help me... I was working in Scilab 5.3.3 and I had this error
> when I tried to launch the editor:
>
>
> [Fatal Error] scinotesConfiguration.xml:1:1: Content is not allowed in
> prolog.
> Could not load file:
> C:\DOCUME~1\Maso\DATIAP~1\Scilab\scilab-5.3.3/scinotesConfiguration.xml
> [Fatal Error] scinotesConfiguration.xml:1:1: Content is not allowed in
> prolog.
> Could not load file:
> C:\DOCUME~1\Maso\DATIAP~1\Scilab\scilab-5.3.3/scinotesConfiguration.xml
> java.lang.reflect.InvocationTargetException
>     at java.awt.EventQueue.invokeAndWait(Unknown Source)
>     at javax.swing.SwingUtilities.invokeAndWait(Unknown Source)
>     at org.scilab.modules.scinotes.SciNotes.scinotes(Unknown Source)
> Caused by: java.lang.NullPointerException
>     at
> org.scilab.modules.scinotes.utils.ConfigSciNotesManager.checkVersion(Unknown
> Source)
>     at
> org.scilab.modules.scinotes.utils.ConfigSciNotesManager.createUserCopy(Unknown
> Source)
>     at org.scilab.modules.scinotes.SciNotes.createEditor(Unknown Source)
>     at org.scilab.modules.scinotes.SciNotes.launchSciNotes(Unknown
> Source)
>     at org.scilab.modules.scinotes.SciNotes$2.run(Unknown Source)
>     at java.awt.event.InvocationEvent.dispatch(Unknown Source)
>     at java.awt.EventQueue.dispatchEvent(Unknown Source)
>     at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown
> Source)
>     at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
>     at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown
> Source)
>     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
>     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
>     at java.awt.EventDispatchThread.run(Unknown Source)
> Warning !!!
> Scilab has found a critical error (Unknown exception)
> with "editor" function.
> Save your data and restart Scilab.
>

Maso Ricci Maso Ricci
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I do really need help with an editor error

In reply to this post by Maso Ricci
ok ... maybe I solved: I deleted the scinotesConfiguration.xml (which
was an empty file) and the editor started again ...

let me run same script now



Il 18/11/2011 14.09, Maso RICCI ha scritto:

> Hi all,
>
> please help me... I was working in Scilab 5.3.3 and I had this error
> when I tried to launch the editor:
>
>
> [Fatal Error] scinotesConfiguration.xml:1:1: Content is not allowed in
> prolog.
> Could not load file:
> C:\DOCUME~1\Maso\DATIAP~1\Scilab\scilab-5.3.3/scinotesConfiguration.xml
> [Fatal Error] scinotesConfiguration.xml:1:1: Content is not allowed in
> prolog.
> Could not load file:
> C:\DOCUME~1\Maso\DATIAP~1\Scilab\scilab-5.3.3/scinotesConfiguration.xml
> java.lang.reflect.InvocationTargetException
>     at java.awt.EventQueue.invokeAndWait(Unknown Source)
>     at javax.swing.SwingUtilities.invokeAndWait(Unknown Source)
>     at org.scilab.modules.scinotes.SciNotes.scinotes(Unknown Source)
> Caused by: java.lang.NullPointerException
>     at
> org.scilab.modules.scinotes.utils.ConfigSciNotesManager.checkVersion(Unknown
> Source)
>     at
> org.scilab.modules.scinotes.utils.ConfigSciNotesManager.createUserCopy(Unknown
> Source)
>     at org.scilab.modules.scinotes.SciNotes.createEditor(Unknown Source)
>     at org.scilab.modules.scinotes.SciNotes.launchSciNotes(Unknown
> Source)
>     at org.scilab.modules.scinotes.SciNotes$2.run(Unknown Source)
>     at java.awt.event.InvocationEvent.dispatch(Unknown Source)
>     at java.awt.EventQueue.dispatchEvent(Unknown Source)
>     at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown
> Source)
>     at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
>     at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown
> Source)
>     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
>     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
>     at java.awt.EventDispatchThread.run(Unknown Source)
> Warning !!!
> Scilab has found a critical error (Unknown exception)
> with "editor" function.
> Save your data and restart Scilab.
>

--
----------------------------------------
Maso RICCI PhD
Dipartimento Farmaco Chimico Tecnologico
Università degli Studi di Siena
Via Aldo Moro,2
Siena

phone: +390577234367
email: [hidden email]
----------------------------------------

Stéphane Mottelet-2 Stéphane Mottelet-2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Scilab version working with OSX 10.7.2 ?

In reply to this post by Nirav Thakkar
Hi all,

I cannot found a working version of Scilab with OSX 10.7.2 (on a
MacPro). I tried the nightly build, but lauching with the icon does not
work and on the command line I got :

macmottelet-gi-0:~ mottelet$
/Applications/scilab-master-1322152505.app/Contents/MacOS/bin/scilab
/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
JavaVM: requested Java version (1.5) not available. Using Java at
"/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home" instead.
         ___________________________________________
                   scilab-master-1322152505

                 Consortium Scilab (DIGITEO)
               Copyright (c) 1989-2011 (INRIA)
               Copyright (c) 1989-2007 (ENPC)
         ___________________________________________


Initialisation :
   Chargement de l'environnement de travail

-->
                                   !--error 42

Oups. Une erreur fatale a été détectée par Scilab.
Cette instance va s'arrêter très prochainement.
Merci d'envoyer un rapport de bug pour http://bugzilla.scilab.org/ avec
l'information suivante :
[macmottelet-gi-0:01811] Failing at address: 0x0
  Fin de la pile




S.
sylvestre sylvestre
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Scilab version working with OSX 10.7.2 ?

Le vendredi 25 novembre 2011 à 13:23 +0100, Stéphane Mottelet a écrit :
> Hi all,

> Oups. Une erreur fatale a été détectée par Scilab.
> Cette instance va s'arrêter très prochainement.
> Merci d'envoyer un rapport de bug pour http://bugzilla.scilab.org/ avec
> l'information suivante :
> [macmottelet-gi-0:01811] Failing at address: 0x0
>   Fin de la pile
Sorry about that.
Could you do the following ?
sudo dtruss -f /path/to/bin/scilab-cli 2> trace.log

and upload somewhere the log file ?

Thanks
Sylvestre


Stéphane Mottelet-2 Stéphane Mottelet-2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Scilab version working with OSX 10.7.2 ?

here it is.

S.

Le 26/11/11 16:36, Sylvestre Ledru a écrit :

> Le vendredi 25 novembre 2011 à 13:23 +0100, Stéphane Mottelet a écrit :
>> Hi all,
>> Oups. Une erreur fatale a été détectée par Scilab.
>> Cette instance va s'arrêter très prochainement.
>> Merci d'envoyer un rapport de bug pour http://bugzilla.scilab.org/ avec
>> l'information suivante :
>> [macmottelet-gi-0:01811] Failing at address: 0x0
>>    Fin de la pile
> Sorry about that.
> Could you do the following ?
> sudo dtruss -f /path/to/bin/scilab-cli 2>  trace.log
>
> and upload somewhere the log file ?
>
> Thanks
> Sylvestre
>
>


trace.log (95K) Download Attachment
sylvestre sylvestre
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Scilab version working with OSX 10.7.2 ?

Merci Stéphane.
Clearly, the problem is here:

dyld: Library not loaded: /usr/lib/libncurses.5.dylib
  Referenced
from: /Applications/scilab-master-1322152505.app/Contents/MacOS/bin/scilab-bin
  Reason: no suitable image found.  Did find:
        /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
        /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture


Could you try to rename it ?
mv /usr/lib/libncurses.5.dylib /usr/lib/libncursestmp.5.dylib

I guess it is a system that you upgraded and not a brand new one?

Sylvestre
PS: your email address is missing an "a".

Le mardi 29 novembre 2011 à 13:25 +0100, Stéphane Mottelet a écrit :

> here it is.
>
> S.
>
> Le 26/11/11 16:36, Sylvestre Ledru a écrit :
> > Le vendredi 25 novembre 2011 à 13:23 +0100, Stéphane Mottelet a écrit :
> >> Hi all,
> >> Oups. Une erreur fatale a été détectée par Scilab.
> >> Cette instance va s'arrêter très prochainement.
> >> Merci d'envoyer un rapport de bug pour http://bugzilla.scilab.org/ avec
> >> l'information suivante :
> >> [macmottelet-gi-0:01811] Failing at address: 0x0
> >>    Fin de la pile
> > Sorry about that.
> > Could you do the following ?
> > sudo dtruss -f /path/to/bin/scilab-cli 2>  trace.log
> >
> > and upload somewhere the log file ?
> >
> > Thanks
> > Sylvestre
> >
> >
>


sylvestre sylvestre
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Scilab version working with OSX 10.7.2 ?

Le mardi 29 novembre 2011 à 15:49 +0100, Stéphane Mottelet a écrit :

> Le 29/11/11 15:26, Sylvestre Ledru a écrit :
> > Merci Stéphane.
> > Clearly, the problem is here:
> >
> > dyld: Library not loaded: /usr/lib/libncurses.5.dylib
> >    Referenced
> > from: /Applications/scilab-master-1322152505.app/Contents/MacOS/bin/scilab-bin
> >    Reason: no suitable image found.  Did find:
> > /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
> > /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
> >
> >
> > Could you try to rename it ?
> > mv /usr/lib/libncurses.5.dylib /usr/lib/libncursestmp.5.dylib
> still fails,
Stéphane, could you try with the latest nightly build ? [1]
We fixed some recent packaging issues which should remove the problem
you had (and also, as a side effect, make Scilab run on 10.5).

Thanks,
Sylvestre
[1]
http://www.scilab.org/communities/developer_zone/scilab_versions/development_version/nightly_builds/branch_master


mottelet mottelet
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Scilab version working with OSX 10.7.2 ?

Le 07/12/11 10:22, Sylvestre Ledru a écrit :

> Le mardi 29 novembre 2011 à 15:49 +0100, Stéphane Mottelet a écrit :
>> Le 29/11/11 15:26, Sylvestre Ledru a écrit :
>>> Merci Stéphane.
>>> Clearly, the problem is here:
>>>
>>> dyld: Library not loaded: /usr/lib/libncurses.5.dylib
>>>     Referenced
>>> from: /Applications/scilab-master-1322152505.app/Contents/MacOS/bin/scilab-bin
>>>     Reason: no suitable image found.  Did find:
>>> /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
>>> /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
>>>
>>>
>>> Could you try to rename it ?
>>> mv /usr/lib/libncurses.5.dylib /usr/lib/libncursestmp.5.dylib
>> still fails,
> Stéphane, could you try with the latest nightly build ? [1]
> We fixed some recent packaging issues which should remove the problem
> you had (and also, as a side effect, make Scilab run on 10.5).
>
> Thanks,
> Sylvestre
> [1]
> http://www.scilab.org/communities/developer_zone/scilab_versions/development_version/nightly_builds/branch_master
>
>
Hello Sylvestre,

the nightly build works like a charm, thanks !

S.
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Where have Atoms modules gone ?

Hello,

with the nightly build, under Mac OSX, I only see a small subset of
atoms modules :

-->atomsList
  ANN_Toolbox - ANN Toolbox
       apifun - Check input arguments in macros.
     coselica - Standard Open Modelica Blocks
         CPGE - CPGE dedicated Xcos blocks
   guibuilder - A Graphic User Interface Builder
maple2scilab - maple2scilab
module_lycee - Scilab pour les lycées
    optkelley - Scilab software for Iterative Methods for Optimization
    scicobyla - An interface to the COBYLA optimization method.
     scilab2c - Translate Scilab code into C code
       serial - A toolbox for communication over a Serial Port in Scilab
      stixbox - Statistics toolbox
      texmacs - texmacs


Where are the others ?

S.
sylvestre sylvestre
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Where have Atoms modules gone ?

Le mercredi 07 décembre 2011 à 15:09 +0100, Stéphane Mottelet a écrit :

> Hello,
>
> with the nightly build, under Mac OSX, I only see a small subset of
> atoms modules :
>
> -->atomsList
>   ANN_Toolbox - ANN Toolbox
>        apifun - Check input arguments in macros.
>      coselica - Standard Open Modelica Blocks
>          CPGE - CPGE dedicated Xcos blocks
>    guibuilder - A Graphic User Interface Builder
> maple2scilab - maple2scilab
> module_lycee - Scilab pour les lycées
>     optkelley - Scilab software for Iterative Methods for Optimization
>     scicobyla - An interface to the COBYLA optimization method.
>      scilab2c - Translate Scilab code into C code
>        serial - A toolbox for communication over a Serial Port in Scilab
>       stixbox - Statistics toolbox
>       texmacs - texmacs
>
>
> Where are the others ?
Because we created a new ATOMS repository for Scilab 5.4.
We had to do it because the version 5.4 of Scilab under Windows is now
built with the latest version of Visual Studio, causing binary
incompatibilities for modules. For Windows, we have to rebuild all
binary Scilab modules.

Now, for your problem, we are going to see if we can share the same
repository between 5.3 & 5.4 under Mac OS X & Linux.

Sylvestre



Antoine Monmayrant Antoine Monmayrant
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Scilab version working with OSX 10.7.2 ?

In reply to this post by sylvestre
Le 07/12/11 10:22, Sylvestre Ledru a écrit :

> Le mardi 29 novembre 2011 à 15:49 +0100, Stéphane Mottelet a écrit :
>> Le 29/11/11 15:26, Sylvestre Ledru a écrit :
>>> Merci Stéphane.
>>> Clearly, the problem is here:
>>>
>>> dyld: Library not loaded: /usr/lib/libncurses.5.dylib
>>>     Referenced
>>> from: /Applications/scilab-master-1322152505.app/Contents/MacOS/bin/scilab-bin
>>>     Reason: no suitable image found.  Did find:
>>> /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
>>> /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
>>>
>>>
>>> Could you try to rename it ?
>>> mv /usr/lib/libncurses.5.dylib /usr/lib/libncursestmp.5.dylib
>> still fails,
> Stéphane, could you try with the latest nightly build ? [1]
> We fixed some recent packaging issues which should remove the problem
> you had (and also, as a side effect, make Scilab run on 10.5).
>
> Thanks,
> Sylvestre
> [1]
> http://www.scilab.org/communities/developer_zone/scilab_versions/development_version/nightly_builds/branch_master
>
>
I tried it under 10.5.8 and it does not work:

/Applications/scilab-master-1323188973.app/Contents/MacOS/bin/scilab
true
Erreur lors de la création de la Machine Virtuelle Java : Erreur de
version JNI
Options :
0: -Djava.library.path=
1:
-Djava.class.path=/Applications/scilab-master-1323188973.app/Contents/MacOS/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar
2:
-Djava.util.logging.config.file=/Applications/scilab-master-1323188973.app/Contents/MacOS/share/scilab/etc/logging.properties
3: -Djava.compiler=JIT
4: -Xmx256m
5: -Dapple.laf.useScreenMenuBar=true

Scilab ne peut pas ouvrir la bibliothèque JVM.

As for Java settings, I am using Java SE 6 64bits (1.6.0_26-b03-384).
The most recent version of scilab that works on this computer is 5.2.2.
If you have any suggestion, I'll be happy to try it.

Cheers,

Antoine


sylvestre sylvestre
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Scilab version working with OSX 10.7.2 ?

Le mercredi 07 décembre 2011 à 21:15 +0100, Antoine Monmayrant a écrit :

> Le 07/12/11 10:22, Sylvestre Ledru a écrit :
> > Le mardi 29 novembre 2011 à 15:49 +0100, Stéphane Mottelet a écrit :
> >> Le 29/11/11 15:26, Sylvestre Ledru a écrit :
> >>> Merci Stéphane.
> >>> Clearly, the problem is here:
> >>>
> >>> dyld: Library not loaded: /usr/lib/libncurses.5.dylib
> >>>     Referenced
> >>> from: /Applications/scilab-master-1322152505.app/Contents/MacOS/bin/scilab-bin
> >>>     Reason: no suitable image found.  Did find:
> >>> /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
> >>> /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
> >>>
> >>>
> >>> Could you try to rename it ?
> >>> mv /usr/lib/libncurses.5.dylib /usr/lib/libncursestmp.5.dylib
> >> still fails,
> > Stéphane, could you try with the latest nightly build ? [1]
> > We fixed some recent packaging issues which should remove the problem
> > you had (and also, as a side effect, make Scilab run on 10.5).
> >
> > Thanks,
> > Sylvestre
> > [1]
> > http://www.scilab.org/communities/developer_zone/scilab_versions/development_version/nightly_builds/branch_master
> >
> >
> I tried it under 10.5.8 and it does not work:
>
> /Applications/scilab-master-1323188973.app/Contents/MacOS/bin/scilab
> true
> Erreur lors de la création de la Machine Virtuelle Java : Erreur de
> version JNI
> Options :
> 0: -Djava.library.path=
> 1:
> -Djava.class.path=/Applications/scilab-master-1323188973.app/Contents/MacOS/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar
> 2:
> -Djava.util.logging.config.file=/Applications/scilab-master-1323188973.app/Contents/MacOS/share/scilab/etc/logging.properties
> 3: -Djava.compiler=JIT
> 4: -Xmx256m
> 5: -Dapple.laf.useScreenMenuBar=true
>
> Scilab ne peut pas ouvrir la bibliothèque JVM.
>
> As for Java settings, I am using Java SE 6 64bits (1.6.0_26-b03-384).
> The most recent version of scilab that works on this computer is 5.2.2.
> If you have any suggestion, I'll be happy to try it.
Didn't you get a window warning on startup ?

In java settings, you have to explicitly disable all Java 5 version
(only increasing 1.6 priority is not enough)

Sylvestre


Antoine Monmayrant Antoine Monmayrant
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Scilab version working with OSX 10.7.2 ?

Le 07/12/11 21:59, Sylvestre Ledru a écrit :

> Le mercredi 07 décembre 2011 à 21:15 +0100, Antoine Monmayrant a écrit :
>> Le 07/12/11 10:22, Sylvestre Ledru a écrit :
>>> Le mardi 29 novembre 2011 à 15:49 +0100, Stéphane Mottelet a écrit :
>>>> Le 29/11/11 15:26, Sylvestre Ledru a écrit :
>>>>> Merci Stéphane.
>>>>> Clearly, the problem is here:
>>>>>
>>>>> dyld: Library not loaded: /usr/lib/libncurses.5.dylib
>>>>>      Referenced
>>>>> from: /Applications/scilab-master-1322152505.app/Contents/MacOS/bin/scilab-bin
>>>>>      Reason: no suitable image found.  Did find:
>>>>> /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
>>>>> /usr/lib/libncurses.5.dylib: mach-o, but wrong architecture
>>>>>
>>>>>
>>>>> Could you try to rename it ?
>>>>> mv /usr/lib/libncurses.5.dylib /usr/lib/libncursestmp.5.dylib
>>>> still fails,
>>> Stéphane, could you try with the latest nightly build ? [1]
>>> We fixed some recent packaging issues which should remove the problem
>>> you had (and also, as a side effect, make Scilab run on 10.5).
>>>
>>> Thanks,
>>> Sylvestre
>>> [1]
>>> http://www.scilab.org/communities/developer_zone/scilab_versions/development_version/nightly_builds/branch_master
>>>
>>>
>> I tried it under 10.5.8 and it does not work:
>>
>> /Applications/scilab-master-1323188973.app/Contents/MacOS/bin/scilab
>> true
>> Erreur lors de la création de la Machine Virtuelle Java : Erreur de
>> version JNI
>> Options :
>> 0: -Djava.library.path=
>> 1:
>> -Djava.class.path=/Applications/scilab-master-1323188973.app/Contents/MacOS/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar
>> 2:
>> -Djava.util.logging.config.file=/Applications/scilab-master-1323188973.app/Contents/MacOS/share/scilab/etc/logging.properties
>> 3: -Djava.compiler=JIT
>> 4: -Xmx256m
>> 5: -Dapple.laf.useScreenMenuBar=true
>>
>> Scilab ne peut pas ouvrir la bibliothèque JVM.
>>
>> As for Java settings, I am using Java SE 6 64bits (1.6.0_26-b03-384).
>> The most recent version of scilab that works on this computer is 5.2.2.
>> If you have any suggestion, I'll be happy to try it.
> Didn't you get a window warning on startup ?
Yes I did.
>
> In java settings, you have to explicitly disable all Java 5 version
> (only increasing 1.6 priority is not enough)
That is what I did as explained in some comments in bugzilla.
(I disabled all (ie 1.5.0 64 bits, 1.5.0 32 bits and 1.4.2 32 bits) but
for the 1.6 64bits that I put at the top of the list)
>
> Sylvestre
>
>
>
Loading...