[Scilab-users] ATOMS does not work on macOS Mojave 10.14.6 - is it a bug? Входящие x IEEE x

classic Classic list List threaded Threaded
1 message Options
nikolay nikolay
Reply | Threaded
Open this post in threaded view
|

[Scilab-users] ATOMS does not work on macOS Mojave 10.14.6 - is it a bug? Входящие x IEEE x

Dear community!

I have strange behavior of ATOMS in Scilab 6.0.2 (downloaded from official link - http://www.utc.fr/~mottelet/scilab/download/6.0.2/scilab-6.0.2-x86_64.dmg ) on macOS Mojave 10.14.6.
The ATOMS does not work on Scilab which normally launched from Applications menu of from launcher (in normal traditional GUI way).

I got the following screenshot if I simply open Application -> "Module Manager - ATOMS" ends with dialog window with message "No ATOMS module is available. Please, check your Internet connection or make sure that your OS is compatible with ATOMS.". See attached screenshot - https://bugzilla.scilab.org/attachment.cgi?id=4987 .

Installation of single package also seems to be failed:

--> atomsInstall('animaGIF')
Scanning repository http://atoms.scilab.org/6.0 ... Done

at line    65 of function atomsDESCRIPTIONread ( /Applications/scilab-6.0.2.app/Contents/MacOS/share/scilab/modules/atoms/macros/atoms_internals/atomsDESCRIPTIONread.sci line 125 )
at line   227 of function atomsDESCRIPTIONget  ( /Applications/scilab-6.0.2.app/Contents/MacOS/share/scilab/modules/atoms/macros/atoms_internals/atomsDESCRIPTIONget.sci line 246 )
at line    31 of function atomsIsPackage       ( /Applications/scilab-6.0.2.app/Contents/MacOS/share/scilab/modules/atoms/macros/atoms_internals/atomsIsPackage.sci line 47 )
at line    69 of function atomsInstallList     ( /Applications/scilab-6.0.2.app/Contents/MacOS/share/scilab/modules/atoms/macros/atoms_internals/atomsInstallList.sci line 108 )
at line   233 of function atomsInstall         ( /Applications/scilab-6.0.2.app/Contents/MacOS/share/scilab/modules/atoms/macros/atomsInstall.sci line 249 )

regexp: Unknown error.

On next Scilab start the ATOMS module is not installed.
When I launch Scilab from Terminal with
/Applications/scilab-6.0.2.app/Contents/MacOS/bin/scilab-bin

and try to install ATOMS from Scilab Console - I get the following error output in the terminal:

dyld: Library not loaded: /Users/mottelet/git/scilab_dist/Scilab.app/Contents/MacOS/lib/scilab/libscilab-cli.6.dylib Referenced from: /Applications/scilab-6.0.2.app/Contents/MacOS/bin/scilab-bin Reason: image not found Abort trap: 6 logout Saving session... ...copying shared history... ...saving history...truncating history files... ...completed. [Process completed]

I have already reported a bug - https://bugzilla.scilab.org/show_bug.cgi?id=16159 .

Is it just me?
Does anyone have the same problem on macOS Mojave or High Sierra?

--
With best regards,
Ph.D.,
associate professor at MPEI,
IEEE member,
developer of Mathieu functions toolbox for Scilab,
Nikolay Strelkov.

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users