[Scilab-users] ATOMS error (Scilab 6.0.1)

classic Classic list List threaded Threaded
7 messages Options
arctica1963 arctica1963
Reply | Threaded
Open this post in threaded view
|

[Scilab-users] ATOMS error (Scilab 6.0.1)

Hello all,

Just recently been getting this error when running the ATOMS module manager:

"No ATOMS module is available. Please, check your Internet connection or
make sure that your OS is compatible with ATOMS."

I am using version 6.0.1 and know that it was working a while back, so not
sure what has changed. It can clearly get to the repository to update the
database, but then generates an error. Console shows: "Scanning repository
http://atoms.scilab.org/6.0 ... Done"

I also verified this on a separate machine that I only recently updated with
6.0.1, and that gave the same response. Not a big deal as I tend to write
functions as I need them, but seems odd.

Tried deleting the user folder at:
C:\Users\xxxx\AppData\Roaming\Scilab\scilab-6.0.1 but did not help.

Any ideas? It works fine under 5.5.2.

Lester



--
Sent from: http://mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Antoine ELIAS-2 Antoine ELIAS-2
Reply | Threaded
Open this post in threaded view
|

Re: ATOMS error (Scilab 6.0.1)

Hello,

Trouble comes from a bug in mgetl function. (Windows only)
Patch was validated this morning.
From tomorrow you can use nightly build version to avoid this.
http://www.scilab.org/en/development/nightly_builds/branch60

Sorry for inconvenience.
Antoine
Le 21/07/2018 à 11:50, arctica1963 a écrit :
Hello all,

Just recently been getting this error when running the ATOMS module manager:

"No ATOMS module is available. Please, check your Internet connection or
make sure that your OS is compatible with ATOMS."

I am using version 6.0.1 and know that it was working a while back, so not
sure what has changed. It can clearly get to the repository to update the
database, but then generates an error. Console shows: "Scanning repository
http://atoms.scilab.org/6.0 ... Done"

I also verified this on a separate machine that I only recently updated with
6.0.1, and that gave the same response. Not a big deal as I tend to write
functions as I need them, but seems odd. 

Tried deleting the user folder at:
C:\Users\xxxx\AppData\Roaming\Scilab\scilab-6.0.1 but did not help.

Any ideas? It works fine under 5.5.2.

Lester



--
Sent from: http://mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
arctica1963 arctica1963
Reply | Threaded
Open this post in threaded view
|

Re: ATOMS error (Scilab 6.0.1)

Thanks for the update.



--
Sent from: http://mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Clément David-3 Clément David-3
Reply | Threaded
Open this post in threaded view
|

Re: ATOMS error (Scilab 6.0.1)

Hello,

A server-side workaround have been implemented by using CRLF for the TOOLBOXES.gz windows files,
avoiding the mgetl() buggy behavior in 6.0.1

--
Clément

Le dimanche 22 juillet 2018 à 01:49 -0700, arctica1963 a écrit :

> Thanks for the update.
>
>
>
> --
> Sent from: http://mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Samuel GOUGEON Samuel GOUGEON
Reply | Threaded
Open this post in threaded view
|

Re: ATOMS error (Scilab 6.0.1)

Hello Clément,

Thanks for this work-around. It works like a charm for the Scilab 6.0 repository.

However, the 5.5 one now looks out of work: From Scilab 5.5.2, atomsSystemUpdate()  now yields

-->atomsSystemUpdate
Scanning repository http://atoms.scilab.org/5.5 ... Done

 !--error 10000
atomsDESCRIPTIONread: The file "TMPDIR\ATOMS~1\1_TOOLBOXES" is empty.
at line      56 of function atomsDESCRIPTIONread called by : 
at line     227 of function atomsDESCRIPTIONget called by : 
at line      16 of function atomsSystemUpdate called by : 
atomsSystemUpdate

Regards
Samuel

Le 23/07/2018 à 12:00, Clément David a écrit :
Hello,

A server-side workaround have been implemented by using CRLF for the TOOLBOXES.gz windows files,
avoiding the mgetl() buggy behavior in 6.0.1

--
Clément


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Grzegorz Grzegorz
Reply | Threaded
Open this post in threaded view
|

Re: ATOMS error (Scilab 6.0.1)

Dear Clément,

Is there any work in progress to fix this issue on Scilab 5.5.2? Is there any workaround  for this issue for Scilab 5.5.2 users?
I was trying to install toolbox without internet but without success. The atomsInstall function works only with internet connection ?

Regards Grzegorz


2018-07-27 3:27 GMT+02:00 Samuel Gougeon <[hidden email]>:
Hello Clément,

Thanks for this work-around. It works like a charm for the Scilab 6.0 repository.

However, the 5.5 one now looks out of work: From Scilab 5.5.2, atomsSystemUpdate()  now yields

-->atomsSystemUpdate
Scanning repository http://atoms.scilab.org/5.5 ... Done

 !--error 10000
atomsDESCRIPTIONread: The file "TMPDIR\ATOMS~1\1_TOOLBOXES" is empty.
at line      56 of function atomsDESCRIPTIONread called by : 
at line     227 of function atomsDESCRIPTIONget called by : 
at line      16 of function atomsSystemUpdate called by : 
atomsSystemUpdate

Regards
Samuel


Le 23/07/2018 à 12:00, Clément David a écrit :
Hello,

A server-side workaround have been implemented by using CRLF for the TOOLBOXES.gz windows files,
avoiding the mgetl() buggy behavior in 6.0.1

--
Clément


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Samuel GOUGEON Samuel GOUGEON
Reply | Threaded
Open this post in threaded view
|

Re: ATOMS error (Scilab 6.0.1)

In reply to this post by Clément David-3
Le 23/07/2018 à 12:00, Clément David a écrit :
> Hello,
>
> A server-side workaround have been implemented by using CRLF for the TOOLBOXES.gz windows files,
> avoiding the mgetl() buggy behavior in 6.0.1

The bug still occurs (not always fixed) (for the 6.0.x-branch, build of
yesterday evening):
The ATOMS manager can no longer be used.

In addition, some recent changes have broken the ATOMS archive for
Scilab 5.5.2 (apparently on the server side), as reported by Grzegorz
and in Bugzilla.

Regards
Samuel

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users