Quantcast

[Scilab-users] GUI Builder 4.0.1 for Scilab 6.0

classic Classic list List threaded Threaded
4 messages Options
Frieder Nikolaisen Frieder Nikolaisen
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Scilab-users] GUI Builder 4.0.1 for Scilab 6.0

Dear Community,

I am using the GUI Builder again (last time Oktobre 2016), now with Scilab 6.0.0.

I started to Design the interface, generated the GUI. Had the GUI run and wanted to reload it. But:

 
--> guibuilder
operation -: Warning adding a matrix with the empty matrix will give an empty matrix result.
operation +: Warning adding a matrix with the empty matrix will give an empty matrix result.
at line    60 of function guigetfile        
at line     4 of function openfile          
at line     9 of function open_existing_gui

':': Wrong type for argument 1: Real scalar expected.

 

And with the old version I am used to (but its still desigend with Scilab 6):

START GUI Builder 3.0 for Scilab 5.5
    Load macros
    Load help
    Type "guibuilder" to start the GUI

 
-->guibuilder
  !--error 21
ungültiger Index.
at line       8 of function openfile called by :  
at line       9 of function open_existing_gui called by :  
= gcbo; end;gcbo = getcallbackobject(118);open_existing_gui(handles);if exists("%oldgcbo") then gcbo = %oldgcbo; else clear gcbo; end
while executing a callback

 

The file is attached. 

Scilab 5.5 and 6 open the programm with save and run. But not with the Builder.

Whats wrong?

Best regards

Frieder

 

 

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

Simulation_v1.1.sce (5K) Download Attachment
Antoine Monmayrant-2 Antoine Monmayrant-2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GUI Builder 4.0.1 for Scilab 6.0

Dear Frieder,

In Scilab 6.0 a breaking change was introduced: adding an empty matrix to a constant now gives an empty matrix, not a constant.
This causes a lot of issues with existing codes that relied on the old behaviour.
Apparently, this is the case for GUI Builder that was not properly refactored for Scilab 6.0.
I think you should report this to the maintainer of the module.

Hope it helps,

Antoine


Le 04/05/2017 à 09:13, Frieder Nikolaisen a écrit :

Dear Community,

I am using the GUI Builder again (last time Oktobre 2016), now with Scilab 6.0.0.

I started to Design the interface, generated the GUI. Had the GUI run and wanted to reload it. But:

 
--> guibuilder
operation -: Warning adding a matrix with the empty matrix will give an empty matrix result.
operation +: Warning adding a matrix with the empty matrix will give an empty matrix result.
at line    60 of function guigetfile        
at line     4 of function openfile          
at line     9 of function open_existing_gui

':': Wrong type for argument 1: Real scalar expected.

 

And with the old version I am used to (but its still desigend with Scilab 6):

START GUI Builder 3.0 for Scilab 5.5
    Load macros
    Load help
    Type "guibuilder" to start the GUI

 
-->guibuilder
  !--error 21
ungültiger Index.
at line       8 of function openfile called by :  
at line       9 of function open_existing_gui called by :  
= gcbo; end;gcbo = getcallbackobject(118);open_existing_gui(handles);if exists("%oldgcbo") then gcbo = %oldgcbo; else clear gcbo; end
while executing a callback

 

The file is attached. 

Scilab 5.5 and 6 open the programm with save and run. But not with the Builder.

Whats wrong?

Best regards

Frieder

 

 


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users


-- 
+++++++++++++++++++++++++++++++++++++++++++++++++++++++

 Antoine Monmayrant LAAS - CNRS
 7 avenue du Colonel Roche
 BP 54200
 31031 TOULOUSE Cedex 4
 FRANCE

 Tel:+33 5 61 33 64 59
 
 email : [hidden email]
 permanent email : [hidden email]

+++++++++++++++++++++++++++++++++++++++++++++++++++++++


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Frieder Nikolaisen Frieder Nikolaisen
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GUI Builder 4.0.1 for Scilab 6.0

Dear Antoine,

yes. I stick to Scilab 5.5. I will copy this message to the report.

Cheers

Frieder

Am 2017-05-04 11:55, schrieb [hidden email]:

Dear Frieder,

In Scilab 6.0 a breaking change was introduced: adding an empty matrix to a constant now gives an empty matrix, not a constant.
This causes a lot of issues with existing codes that relied on the old behaviour.
Apparently, this is the case for GUI Builder that was not properly refactored for Scilab 6.0.
I think you should report this to the maintainer of the module.

Hope it helps,

Antoine


Le 04/05/2017 à 09:13, Frieder Nikolaisen a écrit :

Dear Community,

I am using the GUI Builder again (last time Oktobre 2016), now with Scilab 6.0.0.

I started to Design the interface, generated the GUI. Had the GUI run and wanted to reload it. But:

 
--> guibuilder
operation -: Warning adding a matrix with the empty matrix will give an empty matrix result.
operation +: Warning adding a matrix with the empty matrix will give an empty matrix result.
at line    60 of function guigetfile        
at line     4 of function openfile          
at line     9 of function open_existing_gui

':': Wrong type for argument 1: Real scalar expected.

 

And with the old version I am used to (but its still desigend with Scilab 6):

START GUI Builder 3.0 for Scilab 5.5
    Load macros
    Load help
    Type "guibuilder" to start the GUI

 
-->guibuilder
  !--error 21
ungültiger Index.
at line       8 of function openfile called by :  
at line       9 of function open_existing_gui called by :  
= gcbo; end;gcbo = getcallbackobject(118);open_existing_gui(handles);if exists("%oldgcbo") then gcbo = %oldgcbo; else clear gcbo; end
while executing a callback

 

The file is attached. 

Scilab 5.5 and 6 open the programm with save and run. But not with the Builder.

Whats wrong?

Best regards

Frieder

 

 


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

 

-- 
+++++++++++++++++++++++++++++++++++++++++++++++++++++++

 Antoine Monmayrant LAAS - CNRS
 7 avenue du Colonel Roche
 BP 54200
 31031 TOULOUSE Cedex 4
 FRANCE

 Tel:+33 5 61 33 64 59
 
 email : [hidden email]
 permanent email : [hidden email]

+++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

 

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Tan Chin Luh-2 Tan Chin Luh-2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GUI Builder 4.0.1 for Scilab 6.0

Hi,

The issue was caused by the changes in code generation for a better visualization during the GUI start up. If you notice carefully, your Simulation_v1.1.sce will be shown up with all components ready while Simulation_v2.6.sce will show the figure first, and the components would be loaded one by one.

I had overlooked the reloading the generated GUI file in new format. Fixed in ver 4.1.

Currently GUI generated in Scilab 6 is not backward compatible yet, I will find some time to update the version 3 for Scilab 5.5.2.

Thanks.

Regards,
Tan Chin Luh

On 4/5/2017 6:32 PM, Frieder Nikolaisen wrote:

Dear Antoine,

yes. I stick to Scilab 5.5. I will copy this message to the report.

Cheers

Frieder

Am 2017-05-04 11:55, schrieb [hidden email]:

Dear Frieder,

In Scilab 6.0 a breaking change was introduced: adding an empty matrix to a constant now gives an empty matrix, not a constant.
This causes a lot of issues with existing codes that relied on the old behaviour.
Apparently, this is the case for GUI Builder that was not properly refactored for Scilab 6.0.
I think you should report this to the maintainer of the module.

Hope it helps,

Antoine


Le 04/05/2017 à 09:13, Frieder Nikolaisen a écrit :

Dear Community,

I am using the GUI Builder again (last time Oktobre 2016), now with Scilab 6.0.0.

I started to Design the interface, generated the GUI. Had the GUI run and wanted to reload it. But:

 
--> guibuilder
operation -: Warning adding a matrix with the empty matrix will give an empty matrix result.
operation +: Warning adding a matrix with the empty matrix will give an empty matrix result.
at line    60 of function guigetfile        
at line     4 of function openfile          
at line     9 of function open_existing_gui

':': Wrong type for argument 1: Real scalar expected.

 

And with the old version I am used to (but its still desigend with Scilab 6):

START GUI Builder 3.0 for Scilab 5.5
    Load macros
    Load help
    Type "guibuilder" to start the GUI

 
-->guibuilder
  !--error 21
ungültiger Index.
at line       8 of function openfile called by :  
at line       9 of function open_existing_gui called by :  
= gcbo; end;gcbo = getcallbackobject(118);open_existing_gui(handles);if exists("%oldgcbo") then gcbo = %oldgcbo; else clear gcbo; end
while executing a callback

 

The file is attached. 

Scilab 5.5 and 6 open the programm with save and run. But not with the Builder.

Whats wrong?

Best regards

Frieder

 

 


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

 

-- 
+++++++++++++++++++++++++++++++++++++++++++++++++++++++

 Antoine Monmayrant LAAS - CNRS
 7 avenue du Colonel Roche
 BP 54200
 31031 TOULOUSE Cedex 4
 FRANCE

 <a class="moz-txt-link-freetext" href="Tel:+33">Tel:+33 5 61 33 64 59
 
 email : [hidden email]
 permanent email : [hidden email]

+++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

 


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Loading...