[Scilab-users] Perhaps the Time-Frequency Toolbox was never meant for Scilab on a Mac?

classic Classic list List threaded Threaded
1 message Options
Heinz Nabielek Heinz Nabielek
Reply | Threaded
Open this post in threaded view
|

[Scilab-users] Perhaps the Time-Frequency Toolbox was never meant for Scilab on a Mac?



In SciLab 6.0.1 on my iMac, I tried

--> exec /Users/heinznabielek/stftb/builder.sce

and after a lot of hard work, I ended up with lots of error messages. Perhaps this Time-Frequency Toolbox was never meant for Scilab on a Mac?
Heinz



> --> mode(-1);
> Building macros...
> -- Creation of [stftblib] (Macros) --
> genlib: Processing file: altes.sci

......


  ilib_gen_Make: configure : Generate Makefile.
   ilib_gen_Make: Modification of the Makefile in TMPDIR.
   Running the makefile
ilib_compile: An error occurred during the compilation:
In file included from Caf2tfr.c:19:
In file included from /Users/heinznabielek/stftb/sci_gateway/c/tftb.h:19:
/Users/heinznabielek/stftb/sci_gateway/c/kiss_fft.h:8:10: fatal error: 'malloc.h' file not found
#include <malloc.h>
         ^~~~~~~~~~
1 error generated.
make: *** [Caf2tfr.lo] Error 1
ilib_compile: The command was:
make  CFLAGS=" -D__SCILAB_TOOLBOX__ -I/Applications/scilab-6.0.1.app/Contents/MacOS/share/scilab/../../include/scilab/ -I/Applications/scilab-6.0.1.app/Contents/MacOS/share/scilab/../../include/ -I/Users/heinznabielek/stftb/sci_gateway/c/ -Dkiss_fft_scalar=double " CXXFLAGS=" -D__SCILAB_TOOLBOX__ -I/Applications/scilab-6.0.1.app/Contents/MacOS/share/scilab/../../include/scilab/ -I/Applications/scilab-6.0.1.app/Contents/MacOS/share/scilab/../../include/ -I/Users/heinznabielek/stftb/sci_gateway/c/ -Dkiss_fft_scalar=double " FFLAGS="-I/Applications/scilab-6.0.1.app/Contents/MacOS/share/scilab/../../include/scilab/ "
Generating loader_gateway.sce...
Generating cleaner_gateway.sce...
Link failed for dynamic library '/Users/heinznabielek/stftb/sci_gateway/c//libstftb_c.dylib'.
An error occurred: dlopen(/Users/heinznabielek/stftb/sci_gateway/c//libstftb_c.dylib, 10): image not found
Link failed for dynamic library '/Users/heinznabielek/stftb/sci_gateway/c//libstftb_c.dylib'.
An error occurred: dlopen(/Users/heinznabielek/stftb/sci_gateway/c//libstftb_c.dylib, 10): image not found
at line    43 of executed file /Users/heinznabielek/stftb/sci_gateway/c/loader.sce
at line    20 of executed file /Users/heinznabielek/stftb/sci_gateway/loader_gateway.sce
at line    38 of executed file /Users/heinznabielek/stftb/builder.sce

addinter: The shared archive was not loaded: (null)

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users