[Scilab-users] Scilab 6 crashes all the time

classic Classic list List threaded Threaded
6 messages Options
Claus Futtrup Claus Futtrup
Reply | Threaded
Open this post in threaded view
|

[Scilab-users] Scilab 6 crashes all the time

Dear Scilabers

I'm running Scilab 6 on a Win7 machine, 64 bit, 4 GB RAM.

Scilab crashes all the time, randomly, many times every day. Sometimes when I have a fresh start and execute a script it happens first time + second time - then third time Scilab is started, the script runs fine.

Sometimes Scilab crashes when I work in the console, it can be any command, even "help contourf" or something like that.

Somtimes Scilab crashes when I am fiddling with a plot and e.g. changing axis properties.

The response I get from Win7 everytime is: Scilab 6.0.0 (GUI) stopped working. Then the program can be closed.

What is the problem / solution to the problem?

Best regards,
Claus

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Antoine Monmayrant Antoine Monmayrant
Reply | Threaded
Open this post in threaded view
|

Re: Scilab 6 crashes all the time

Hi Claus,

It might be related to graphic drivers.
Did you try to run scilab in console mode (scilab -nogui or something like that)?
Can you for example take one of the scripts that randomly crashes and run it repeatedly in console mode¹ and see if it works reliably?
If it works, your problem comes from graphic drivers and then you can try to update or downgrade your drivers.

Hope it helps,

Antoine


¹ For graphics, you can use "driver()" to plot everything directly to a file

Le 28/01/2018 à 12:11, Claus Futtrup a écrit :
Dear Scilabers

I'm running Scilab 6 on a Win7 machine, 64 bit, 4 GB RAM.

Scilab crashes all the time, randomly, many times every day. Sometimes when I have a fresh start and execute a script it happens first time + second time - then third time Scilab is started, the script runs fine.

Sometimes Scilab crashes when I work in the console, it can be any command, even "help contourf" or something like that.

Somtimes Scilab crashes when I am fiddling with a plot and e.g. changing axis properties.

The response I get from Win7 everytime is: Scilab 6.0.0 (GUI) stopped working. Then the program can be closed.

What is the problem / solution to the problem?

Best regards,
Claus


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Claus Futtrup Claus Futtrup
Reply | Threaded
Open this post in threaded view
|

Re: Scilab 6 crashes all the time

Hi Antoine

Thanks for reminding me. Thinking back in time, I realize this has been treated on the mailing list before, so you're probably right. I have only now started to use my work PC for working with Scilab, so that's why I have the problem now ... :-)

Best regards,
Claus


On Sun, Jan 28, 2018 at 6:58 PM, antoine monmayrant <[hidden email]> wrote:
Hi Claus,

It might be related to graphic drivers.
Did you try to run scilab in console mode (scilab -nogui or something like that)?
Can you for example take one of the scripts that randomly crashes and run it repeatedly in console mode¹ and see if it works reliably?
If it works, your problem comes from graphic drivers and then you can try to update or downgrade your drivers.

Hope it helps,

Antoine


¹ For graphics, you can use "driver()" to plot everything directly to a file


Le 28/01/2018 à 12:11, Claus Futtrup a écrit :
Dear Scilabers

I'm running Scilab 6 on a Win7 machine, 64 bit, 4 GB RAM.

Scilab crashes all the time, randomly, many times every day. Sometimes when I have a fresh start and execute a script it happens first time + second time - then third time Scilab is started, the script runs fine.

Sometimes Scilab crashes when I work in the console, it can be any command, even "help contourf" or something like that.

Somtimes Scilab crashes when I am fiddling with a plot and e.g. changing axis properties.

The response I get from Win7 everytime is: Scilab 6.0.0 (GUI) stopped working. Then the program can be closed.

What is the problem / solution to the problem?

Best regards,
Claus


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Samuel GOUGEON Samuel GOUGEON
Reply | Threaded
Open this post in threaded view
|

Re: Scilab 6 crashes all the time

In reply to this post by Claus Futtrup
Hello Claus,

Thank you for telling things as they are. I experiment the same
situation now for 2 years, on Windows 7 64 bits. It got a bit better
with the official 6.0.0 release than with the nightly built a few days
before the release, but it is still very unstable. With the pending
6.0.1 as well (or bad).

I noticed that crashes are somewhat systematic when a bunch of
instructions are echoed in the console (copy/pasting, or exec with echo
from Scinotes), while executing the same instructions in a script in
silent mode more often passes without crashing.

As far as i remember, after the awful 5.4.0 first version that yielded
and sent an ocean of Java exceptions in the console, you succeeded in
convincing the OP team to display exceptions elsewhere. In the hard
meanwhile, i can say that Scilab was abandoned in some high schools of
engineering for teaching, because it was just an unsustainable
situation, and system administrators have many things to do out of
testing how to overcome such aberration. This was an excellent publicity
for Matlab (if it needed some), and a very efficient way to ruin efforts
to highlight Scilab vs other comparable softwares.

Let's bet that you will be heard again :)

Regards
Samuel

Le 28/01/2018 à 12:11, Claus Futtrup a écrit :

> Dear Scilabers
>
> I'm running Scilab 6 on a Win7 machine, 64 bit, 4 GB RAM.
>
> Scilab crashes all the time, randomly, many times every day. Sometimes
> when I have a fresh start and execute a script it happens first time +
> second time - then third time Scilab is started, the script runs fine.
>
> Sometimes Scilab crashes when I work in the console, it can be any
> command, even "help contourf" or something like that.
>
> Somtimes Scilab crashes when I am fiddling with a plot and
> e.g. changing axis properties.
>
> The response I get from Win7 everytime is: Scilab 6.0.0 (GUI) stopped
> working. Then the program can be closed.
>
> What is the problem / solution to the problem?
>
> Best regards,
> Claus

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Samuel GOUGEON Samuel GOUGEON
Reply | Threaded
Open this post in threaded view
|

Re: Scilab 6 crashes all the time

In reply to this post by Antoine Monmayrant
Le 28/01/2018 à 18:58, antoine monmayrant a écrit :
>
> It might be related to graphic drivers.

On the same PC, after the excellent 5.5.2 release that still run in a
very stable way, the only thing that changed is Scilab.

However, i must notice that old Scilab version before 5.3.3 (except the
4.1.2, still stable) are now crashing on the same PC where they used to
run correctly, as soon as a graphical instruction is used. And all that
always with the same graphic driver.

My 2 cents: I would rather think that changes in/with the JVM are likely
involved.

Samuel

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Claus Futtrup Claus Futtrup
Reply | Threaded
Open this post in threaded view
|

Re: Scilab 6 crashes all the time

Hi Samuel

I've used Scilab 5.5 for a long time on my private PC, a Lenovo W530 with 8 Gb RAM and NVidia Graphics (Optimus). Lately my old PC died, so I'm using a work-PC now, which is weak and basically designed for websurfing and Microsoft Word documents ... not power-use.

You could be right it's not a Graphics driver ... I mean, how much Graphics is involved in an instruction in the Scilab console? ... Only a little bit.

To me it happens suddenly and quite randomly, as if Scilab doesn't clean up, or the machine runs out of RAM (either DRAM or VRAM). My gut feeling is the crashing is worse if another program is running in parallel (e.g. a web browser).

Best regards,
Claus

On Sun, Jan 28, 2018 at 10:23 PM, Samuel Gougeon <[hidden email]> wrote:
Le 28/01/2018 à 18:58, antoine monmayrant a écrit :

It might be related to graphic drivers.

On the same PC, after the excellent 5.5.2 release that still run in a very stable way, the only thing that changed is Scilab.

However, i must notice that old Scilab version before 5.3.3 (except the 4.1.2, still stable) are now crashing on the same PC where they used to run correctly, as soon as a graphical instruction is used. And all that always with the same graphic driver.

My 2 cents: I would rather think that changes in/with the JVM are likely involved.

Samuel


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users