[Scilab-users] Scilab/xcos 6.0.0 - Superblock and port naming issues

classic Classic list List threaded Threaded
10 messages Options
Yves Rambi Yves Rambi
Reply | Threaded
Open this post in threaded view
|

[Scilab-users] Scilab/xcos 6.0.0 - Superblock and port naming issues

This post was updated on .
Hello,
I am using Scilab on both OS
- MS Windows (6.0.0)
- Linux (5.5.0)

For the Windows version I have following issues with Xcos:
*Issue 1: Wrong port number*
- I create a Superblock
- In the Superblock I add an input or an output port
- An error message appears stating "Evaluation porblem: Wrong port number"
and the number of the  new port doesnt increment but stays by "1" (It's the
same for outputs)
<http://mailinglists.scilab.org/file/t497169/Superblock_Port_Insert_Failure_2.png

*Issue 2: Port/Block name disappear*
- When I give a port a name through "format" ...(Strg+F2) and close the
window the port names don't appear in the upper level
<http://mailinglists.scilab.org/file/t497169/Superblock_Port_Naming.png

<http://mailinglists.scilab.org/file/t497169/Superblock_After_Port_Naming.png


Both issues don't appear on Linux version (5.5.0).

Is there a workaround or are there some special settings I miss here?


For information about the used Windows OS and Scilab SW:

Scilab 6.0.0 (64 bit)
Windows 7 Professional/SP1 /64 Bit
Processor i5-4300M CPU 2.60 GHz


--
Sent from: http://mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
_______________________________________________
users mailing list
users@lists.scilab.org
http://lists.scilab.org/mailman/listinfo/users
Paul Bignier Paul Bignier
Reply | Threaded
Open this post in threaded view
|

Re: Scilab/xcos 6.0.0 - Superblock and port naming issues


Hello Yves,

Could you please report this issue to our Bugzilla?

You may also try with our latest nightly builds.

Thanks a lot for your contribution!

Regards,

Paul



Paul BIGNIER
Development engineer
-----------------------------------------------------------
ESI Group - Scilab
99 rue des Solets - 94513 Rungis, France
Phone: +33.1.41.73.58.77
https://scilab.io
https://esi-group.com




From: users <[hidden email]> on behalf of Yves Rambi <[hidden email]>
Sent: Tuesday, October 3, 2017 10:22 AM
To: [hidden email]
Subject: [Scilab-users] Scilab/xcos 6.0.0 - Superblock and port naming issues
 
Hello,
I am using Scilab on both OS
- MS Windows (6.0.0)
- Linux (5.5.0)

For the Windows version I have following issues with Xcos:
*Issue 1: Wrong port number*
- I create a Superblock
- In the Superblock I add an input or an output port
- An error message appears stating "Evaluation porblem: Wrong port number"
and the number of the  new port doesnt increment but stays by "1" (It's the
same for outputs)
<http://mailinglists.scilab.org/file/t497169/Superblock_Port_Insert_Failure_2.png>

*Issue 2: Port/Block name disappear*
- When I give a port a name through "format" ...(Strg+F2) and close the
window the port names don't appear in the upper level
<http://mailinglists.scilab.org/file/t497169/Superblock_Port_Naming.png>

<http://mailinglists.scilab.org/file/t497169/Superblock_After_Port_Naming.png>


Both issues don't appear on Linux version (5.5.0).

Is there a workaround or are there some special settings I miss here?



--
Sent from: http://mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Yves Rambi Yves Rambi
Reply | Threaded
Open this post in threaded view
|

Re: Scilab/xcos 6.0.0 - Superblock and port naming issues

Hello Paul,
I submitted both issues to Bugzilla.

For the nightly builds, the links seem to be dead. I always get "Error 404"
by clicking on the target links to the *.exe file.

Regards,

Yves



--
Sent from: http://mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Heinz Nabielek Heinz Nabielek
Reply | Threaded
Open this post in threaded view
|

[Scilab-users] do not manage to show text labels along the x-axis

Monte-Carlo simulating blood types in Austria was easy in Scilab, but I do not manage to show text labels along the x-axis. Text would be:
blood=['0+' 'A+' 'B+' 'AB+' '0-' 'A-' 'B-' 'AB-']
and the diagram should look similar to my attached EXCEL.

Heinz



// SciLab code for Monte-Carlo simulating blood types in Austria
p=[0.3 0.37 0.12 0.05 0.06 0.07 0.02 0.01];
blood=['0+' 'A+' 'B+' 'AB+' '0-' 'A-' 'B-' 'AB-']

P=cumsum(p);P=[0 P];np=length(p);nj=5;C = zeros(np,nj);
N=12; X = grand(nj,N,'def');
for i=1:np
    C(i,:) = sum((X>=P(i) & X<P(i+1)),2)';
end
C

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
jbaudais jbaudais
Reply | Threaded
Open this post in threaded view
|

Re: do not manage to show text labels along the x-axis

Hello,


Le 04/10/2017 à 11:16, Heinz Nabielek a écrit :
> Monte-Carlo simulating blood types in Austria was easy in Scilab, but I do not manage to show text labels along the x-axis. Text would be:
> blood=['0+' 'A+' 'B+' 'AB+' '0-' 'A-' 'B-' 'AB-']
> and the diagram should look similar to my attached EXCEL.

To change the axes labels (and location) see "axes properties". For exemple

x=1:8;
p=[0.3 0.37 0.12 0.05 0.06 0.07 0.02 0.01];
blood=['0+' 'A+' 'B+' 'AB+' '0-' 'A-' 'B-' 'AB-'];
scf(0);clf(0),plot(x,p,'-*b')
f=gca();
f.x_ticks=tlist(["ticks" "locations", "labels"],x,blood);


Jean-Yves
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Christophe Dang Ngoc Chan Christophe Dang Ngoc Chan
Reply | Threaded
Open this post in threaded view
|

Re: {EXT} do not manage to show text labels along the x-axis

In reply to this post by Heinz Nabielek
Hello,

> De : Heinz Nabielek
> Envoyé : mercredi 4 octobre 2017 11:16
>
> I do not manage to show text labels along the x-axis.

Please try:

// **********

plot(1:np, p, "-d");

h=gca();

foo = h.x_ticks;

foo(2) = (1:np)';

foo(3) = blood';

h.x_ticks=foo;

// **********

Explanation:
gca() retrieves the handle tha point to the axes,
you can then modify the x_ticks data
but the size of the second and third parts must always be consistent,
the reason why you have to use a foo variable.

HTH

--
Christophe Dang Ngoc Chan
Mechanical calculation engineer
This e-mail may contain confidential and/or privileged information. If you are not the intended recipient (or have received this e-mail in error), please notify the sender immediately and destroy this e-mail. Any unauthorized copying, disclosure or distribution of the material in this e-mail is strictly forbidden.
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Heinz Nabielek Heinz Nabielek
Reply | Threaded
Open this post in threaded view
|

Re: do not manage to show text labels along the x-axis

In reply to this post by jbaudais
Neat. Thanks a lot. Heinz

On 04.10.2017, at 11:37, Jean-Yves Baudais wrote:

Hello,


Le 04/10/2017 à 11:16, Heinz Nabielek a écrit :
Monte-Carlo simulating blood types in Austria was easy in Scilab, but I do not manage to show text labels along the x-axis. Text would be:
blood=['0+' 'A+' 'B+' 'AB+' '0-' 'A-' 'B-' 'AB-']
and the diagram should look similar to my attached EXCEL.

To change the axes labels (and location) see "axes properties". For exemple

x=1:8;
p=[0.3 0.37 0.12 0.05 0.06 0.07 0.02 0.01];
blood=['0+' 'A+' 'B+' 'AB+' '0-' 'A-' 'B-' 'AB-'];
scf(0);clf(0),plot(x,p,'-*b')
f=gca();
f.x_ticks=tlist(["ticks" "locations", "labels"],x,blood);


Jean-Yves
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Paul Bignier Paul Bignier
Reply | Threaded
Open this post in threaded view
|

Re: Scilab/xcos 6.0.0 - Superblock and port naming issues

In reply to this post by Yves Rambi


We're having trouble at the moment uploading the nightly builds, you may find some uploaded versions at http://downloadarea.scilab.org

Regards,

Paul


Paul BIGNIER
Development engineer
-----------------------------------------------------------
ESI Group - Scilab
99 rue des Solets - 94513 Rungis, France
Phone: +33.1.41.73.58.77
https://scilab.io
https://esi-group.com




From: users <[hidden email]> on behalf of Yves Rambi <[hidden email]>
Sent: Wednesday, October 4, 2017 9:25 AM
To: [hidden email]
Subject: Re: [Scilab-users] Scilab/xcos 6.0.0 - Superblock and port naming issues
 
Hello Paul,
I submitted both issues to Bugzilla.

For the nightly builds, the links seem to be dead. I always get "Error 404"
by clicking on the target links to the *.exe file.

Regards,

Yves



--
Sent from: http://mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Samuel GOUGEON Samuel GOUGEON
Reply | Threaded
Open this post in threaded view
|

Re: Scilab/xcos 6.0.0 - Superblock and port naming issues

Le 04/10/2017 à 12:58, Paul Bignier a écrit :


We're having trouble at the moment uploading the nightly builds, you may find some uploaded versions at http://downloadarea.scilab.org




We often forget how priviledged we are :)


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
W.Schulz W.Schulz
Reply | Threaded
Open this post in threaded view
|

Re: Scilab/xcos 6.0.0 - Superblock and port naming issues

Hello,

is there any possibility to get a current nightly build somewhere?

Best regards

Wolfgang

 

Von: users [mailto:[hidden email]] Im Auftrag von Samuel Gougeon
Gesendet: Mittwoch, 4. Oktober 2017 18:33
An: Users mailing list for Scilab
Betreff: Re: [Scilab-users] Scilab/xcos 6.0.0 - Superblock and port naming issues

 

Le 04/10/2017 à 12:58, Paul Bignier a écrit :

 

We're having trouble at the moment uploading the nightly builds, you may find some uploaded versions at http://downloadarea.scilab.org




We often forget how priviledged we are :)


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users