[Scilab-users] Xcos Editor in Scilab 6.1.0 breaks diagrams

classic Classic list List threaded Threaded
7 messages Options
Perrichon Perrichon
Reply | Threaded
Open this post in threaded view
|

[Scilab-users] Xcos Editor in Scilab 6.1.0 breaks diagrams

Hello,

 

Xcos Editor in Scilab  6.1.0 breaks  diagrams. Number of failure is big.

Must I understand I’ve to rewrite all my projects in Scilab 6.1.0.

 

Here is an example (with  several minus zooms)

The big box in simply a MUX in the standard Palette, normaly drawn at the bottom of this diagram

 

Must I write a bugzilla ?

 

Best regards

 

 

 

 


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Perrichon Perrichon
Reply | Threaded
Open this post in threaded view
|

Re: Xcos Editor in Scilab 6.1.0 breaks diagrams

Hello

I correctly rewrite the MUX box dans the zcos.

Then I go out off Scilab, come in a new time and go to my folio.

Now I obtain :

What to do ?

 

 

De : users <[hidden email]> De la part de Perrichon
Envoyé : jeudi 27 février 2020 19:35
À : 'Users mailing list for Scilab' <[hidden email]>
Objet : [Scilab-users] Xcos Editor in Scilab 6.1.0 breaks diagrams

 

Hello,

 

Xcos Editor in Scilab  6.1.0 breaks  diagrams. Number of failure is big.

Must I understand I’ve to rewrite all my projects in Scilab 6.1.0.

 

Here is an example (with  several minus zooms)

The big box in simply a MUX in the standard Palette, normaly drawn at the bottom of this diagram

 

Must I write a bugzilla ?

 

Best regards

 

 

 

 


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Samuel GOUGEON Samuel GOUGEON
Reply | Threaded
Open this post in threaded view
|

Re: Xcos Editor in Scilab 6.1.0 breaks diagrams

Le 27/02/2020 à 19:56, Perrichon a écrit :

Hello

I correctly rewrite the MUX box dans the zcos.

Then I go out off Scilab, come in a new time and go to my folio.

Now I obtain :

What to do ?


Have you tried to use the Format => Link style => Optimal feature?



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Perrichon Perrichon
Reply | Threaded
Open this post in threaded view
|

Re: Xcos Editor in Scilab 6.1.0 breaks diagrams

Hello Samuel

I dont’t find this option

BR

 

 

 

De : users <[hidden email]> De la part de Samuel Gougeon
Envoyé : jeudi 27 février 2020 20:09
À : [hidden email]
Objet : Re: [Scilab-users] Xcos Editor in Scilab 6.1.0 breaks diagrams

 

Le 27/02/2020 à 19:56, Perrichon a écrit :

Hello

I correctly rewrite the MUX box dans the zcos.

Then I go out off Scilab, come in a new time and go to my folio.

Now I obtain :

What to do ?

 

Have you tried to use the Format => Link style => Optimal feature?

 


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
ayrat ayrat
Reply | Threaded
Open this post in threaded view
|

Re: Xcos Editor in Scilab 6.1.0 breaks diagrams

Style de liens...? (First select a line)

Similarly helpful, you can select the conjunct of a line and select 'optimal position'.

Regarding the ugly resized and displaced block, i have no idea...

On Fri, 28 Feb 2020, 08:27 Perrichon, <[hidden email]> wrote:

Hello Samuel

I dont’t find this option

BR

 

 

 

De : users <[hidden email]> De la part de Samuel Gougeon
Envoyé : jeudi 27 février 2020 20:09
À : [hidden email]
Objet : Re: [Scilab-users] Xcos Editor in Scilab 6.1.0 breaks diagrams

 

Le 27/02/2020 à 19:56, Perrichon a écrit :

Hello

I correctly rewrite the MUX box dans the zcos.

Then I go out off Scilab, come in a new time and go to my folio.

Now I obtain :

What to do ?

 

Have you tried to use the Format => Link style => Optimal feature?

 

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

image005.jpg (22K) Download Attachment
Clément David-3 Clément David-3
Reply | Threaded
Open this post in threaded view
|

Re: Xcos Editor in Scilab 6.1.0 breaks diagrams

In reply to this post by Perrichon
Hello Pierre,

Could you please open a Bugzilla report with the attached diagram, Scilab/Xcos 5.5.2 might set some positions incorrectly decoded in Scilab/Xcos 6.1.0 ?

Thanks,

--
Clément

> -----Original Message-----
> From: users <[hidden email]> On Behalf Of Perrichon
> Sent: Thursday, February 27, 2020 7:35 PM
> To: 'Users mailing list for Scilab' <[hidden email]>
> Subject: [Scilab-users] Xcos Editor in Scilab 6.1.0 breaks diagrams
>
> Hello,
>
>
>
> Xcos Editor in Scilab  6.1.0 breaks  diagrams. Number of failure is big.
>
> Must I understand I've to rewrite all my projects in Scilab 6.1.0.
>
>
>
> Here is an example (with  several minus zooms)
>
> The big box in simply a MUX in the standard Palette, normaly drawn at the
> bottom of this diagram
>
>
>
> Must I write a bugzilla ?
>
>
>
> Best regards
>
>
>
>
>
>
>
>
>
>

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Perrichon Perrichon
Reply | Threaded
Open this post in threaded view
|

Re: Xcos Editor in Scilab 6.1.0 breaks diagrams

Hello Clément

This is done
See bugzilla #16343

BR


Before printing, think about ENVIRONMENTAL responsabity


-----Message d'origine-----
De : users <[hidden email]> De la part de Clément David
Envoyé : vendredi 28 février 2020 09:53
À : Users mailing list for Scilab <[hidden email]>
Objet : Re: [Scilab-users] Xcos Editor in Scilab 6.1.0 breaks diagrams

Hello Pierre,

Could you please open a Bugzilla report with the attached diagram,
Scilab/Xcos 5.5.2 might set some positions incorrectly decoded in
Scilab/Xcos 6.1.0 ?

Thanks,

--
Clément

> -----Original Message-----
> From: users <[hidden email]> On Behalf Of Perrichon
> Sent: Thursday, February 27, 2020 7:35 PM
> To: 'Users mailing list for Scilab' <[hidden email]>
> Subject: [Scilab-users] Xcos Editor in Scilab 6.1.0 breaks diagrams
>
> Hello,
>
>
>
> Xcos Editor in Scilab  6.1.0 breaks  diagrams. Number of failure is big.
>
> Must I understand I've to rewrite all my projects in Scilab 6.1.0.
>
>
>
> Here is an example (with  several minus zooms)
>
> The big box in simply a MUX in the standard Palette, normaly drawn at
> the bottom of this diagram
>
>
>
> Must I write a bugzilla ?
>
>
>
> Best regards
>
>
>
>
>
>
>
>
>
>
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

M_ Pierre PERRICHON.vcf (3K) Download Attachment