[Scilab-users] can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

classic Classic list List threaded Threaded
14 messages Options
N.N. N.N.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Scilab-users] can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

Hello,

I got the following message after the install when I want to run scilab.

Scilab cannot create Scilab Java Main_Class.
(We have not been able to find the main Scilab Class.
Check if the Scilab and thirdparty packages area available).

Is there anybody who can help me with this problem.
I thank you very much.

Kind regards.

--
Complex numbers: They are all fun and games until someone loses an i.
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Vincent COUVERT-2 Vincent COUVERT-2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

Hello,

Can you make a copy of your SCIHOME
(http://help.scilab.org/docs/5.5.0/en_US/SCIHOME.html) directory before
removing it and then restart Scilab?

If Scilab starts after this cleanup we will use your SCIHOME copy as a
basis for a bug report.

Regards,

Le 15/04/2014 00:05, N.N. a écrit :

> Hello,
>
> I got the following message after the install when I want to run scilab.
>
> Scilab cannot create Scilab Java Main_Class.
> (We have not been able to find the main Scilab Class.
> Check if the Scilab and thirdparty packages area available).
>
> Is there anybody who can help me with this problem.
> I thank you very much.
>
> Kind regards.
>

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
N.N. N.N.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

I am very sorry but it did not find a subdirectory scihome and

dir scihome.html /s /p did not find any file on my drive C:
and :

C:\Program Files\scilab-5.5.0>DIR >>C:\LISTING.TXT
Access is denied.

gives access denied.

Now I am really in an 'impasse' and I really have no idea what to do !!!
I am unable to send you a listing of my directory structure...
Is it possible that there is a problem with administrator access ?
I really do not know.
Please help me.

Thank you very much Vincent and others.

Alain (Belgium)

On 4/15/14, Vincent COUVERT <[hidden email]> wrote:

> Hello,
>
> Can you make a copy of your SCIHOME
> (http://help.scilab.org/docs/5.5.0/en_US/SCIHOME.html) directory before
> removing it and then restart Scilab?
>
> If Scilab starts after this cleanup we will use your SCIHOME copy as a
> basis for a bug report.
>
> Regards,
>
> Le 15/04/2014 00:05, N.N. a écrit :
>> Hello,
>>
>> I got the following message after the install when I want to run scilab.
>>
>> Scilab cannot create Scilab Java Main_Class.
>> (We have not been able to find the main Scilab Class.
>> Check if the Scilab and thirdparty packages area available).
>>
>> Is there anybody who can help me with this problem.
>> I thank you very much.
>>
>> Kind regards.
>>
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users
>


--
Complex numbers: They are all fun and games until someone loses an i.
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Claus Futtrup Claus Futtrup
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

Hi Alain

It's not scihome, but capital letters SCIHOME, which again is not the
real name of the directory, but a variable.

Start Scilab, in the console window, please type SCIHOME and Scilab
should respond with something like (in my case, Windows 7):

-->SCIHOME
  SCIHOME  =

  C:\Users\xxxxx\AppData\Roaming\Scilab\scilab-5.4.1

Please try this in your system and work your way ...

/Claus

On 15-Apr-14 19:58, N.N. wrote:

> I am very sorry but it did not find a subdirectory scihome and
>
> dir scihome.html /s /p did not find any file on my drive C:
> and :
>
> C:\Program Files\scilab-5.5.0>DIR >>C:\LISTING.TXT
> Access is denied.
>
> gives access denied.
>
> Now I am really in an 'impasse' and I really have no idea what to do !!!
> I am unable to send you a listing of my directory structure...
> Is it possible that there is a problem with administrator access ?
> I really do not know.
> Please help me.
>
> Thank you very much Vincent and others.
>
> Alain (Belgium)
>
> On 4/15/14, Vincent COUVERT <[hidden email]> wrote:
>> Hello,
>>
>> Can you make a copy of your SCIHOME
>> (http://help.scilab.org/docs/5.5.0/en_US/SCIHOME.html) directory before
>> removing it and then restart Scilab?
>>
>> If Scilab starts after this cleanup we will use your SCIHOME copy as a
>> basis for a bug report.
>>
>> Regards,
>>
>> Le 15/04/2014 00:05, N.N. a écrit :
>>> Hello,
>>>
>>> I got the following message after the install when I want to run scilab.
>>>
>>> Scilab cannot create Scilab Java Main_Class.
>>> (We have not been able to find the main Scilab Class.
>>> Check if the Scilab and thirdparty packages area available).
>>>
>>> Is there anybody who can help me with this problem.
>>> I thank you very much.
>>>
>>> Kind regards.
>>>
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.scilab.org/mailman/listinfo/users
>>
>


---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Claus Futtrup Claus Futtrup
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

Hi there

Please reply on the list so others can help you. I'm just a private
person and far from an expert in Scilab.

>What do I have  to do for running Scilab in console mode ?
>I didn't find the executable ?

Are you on a Windows machine (which version?) ... or a Linux machine, or ??

Which version of Scilab have you installed?

I didn't advice you to start Scilab in console mode ... why do you want
to do that?
The Scilab GUI has 4 windows:

1. Left side = File browser
2. Middle = CONSOLE
3. Top right = Variable browser
4. Bottom right = Command History

As you can see, the CONSOLE is there, right in the middle of your GUI.
At least, this is the default setup for Scilab.

I'm not sure what went wrong with your installation, but one advice
would be to remove the installation, then re-download and re-install
(get Scilab 5.5.0).

If you're a very new beginner, consider reading a couple of tutorials,
for example Scilab for beginners (quite new) + Introduction to Scilab
(quite old), available here:
http://www.scilab.org/resources/documentation/tutorials

/Claus

On 16-Apr-14 12:50, N.N. wrote:

> Hello Claus,
>
> I manually created
>
> C:\Users\Qyko\AppData\Roaming\Scilab\scilab-5.4.1
>
> the subdirectory c\xxx\scilab-5.5.0 was created but was empty
> the subdirectory scilab-5.4.1 was empty
>
> The same error report was given when running the prgrm on the desktop
> launch icon.
>
> What do I have  to do for running Scilab in console mode ?
> I didn't find the executable ?
>
> Thank you very much for your help.
>
> On 4/16/14, N.N. <[hidden email]> wrote:
>> On 4/15/14, Claus Futtrup <[hidden email]> wrote:
>>> Hi Alain
>>>
>>> It's not scihome, but capital letters SCIHOME, which again is not the
>>> real name of the directory, but a variable.
>>>
>>> Start Scilab, in the console window, please type SCIHOME and Scilab
>>> should respond with something like (in my case, Windows 7):
>>>
>>> -->SCIHOME
>>>    SCIHOME  =
>>>
>>>    C:\Users\xxxxx\AppData\Roaming\Scilab\scilab-5.4.1
>>>
>>> Please try this in your system and work your way ...
>>>
>>> /Claus
>>>
>>> On 15-Apr-14 19:58, N.N. wrote:
>>>> I am very sorry but it did not find a subdirectory scihome and
>>>>
>>>> dir scihome.html /s /p did not find any file on my drive C:
>>>> and :
>>>>
>>>> C:\Program Files\scilab-5.5.0>DIR >>C:\LISTING.TXT
>>>> Access is denied.
>>>>
>>>> gives access denied.
>>>>
>>>> Now I am really in an 'impasse' and I really have no idea what to do !!!
>>>> I am unable to send you a listing of my directory structure...
>>>> Is it possible that there is a problem with administrator access ?
>>>> I really do not know.
>>>> Please help me.
>>>>
>>>> Thank you very much Vincent and others.
>>>>
>>>> Alain (Belgium)
>>>>
>>>> On 4/15/14, Vincent COUVERT <[hidden email]>
>>>> wrote:
>>>>> Hello,
>>>>>
>>>>> Can you make a copy of your SCIHOME
>>>>> (http://help.scilab.org/docs/5.5.0/en_US/SCIHOME.html) directory before
>>>>> removing it and then restart Scilab?
>>>>>
>>>>> If Scilab starts after this cleanup we will use your SCIHOME copy as a
>>>>> basis for a bug report.
>>>>>
>>>>> Regards,
>>>>>
>>>>> Le 15/04/2014 00:05, N.N. a écrit :
>>>>>> Hello,
>>>>>>
>>>>>> I got the following message after the install when I want to run
>>>>>> scilab.
>>>>>>
>>>>>> Scilab cannot create Scilab Java Main_Class.
>>>>>> (We have not been able to find the main Scilab Class.
>>>>>> Check if the Scilab and thirdparty packages area available).
>>>>>>
>>>>>> Is there anybody who can help me with this problem.
>>>>>> I thank you very much.
>>>>>>
>>>>>> Kind regards.
>>>>>>
>>>>> _______________________________________________
>>>>> users mailing list
>>>>> [hidden email]
>>>>> http://lists.scilab.org/mailman/listinfo/users
>>>>>
>>>
>>> ---
>>> This email is free from viruses and malware because avast! Antivirus
>>> protection is active.
>>> http://www.avast.com
>>>
>>> _______________________________________________
>>> users mailing list
>>> [hidden email]
>>> http://lists.scilab.org/mailman/listinfo/users
>>>
>>
>> --
>> Complex numbers: They are all fun and games until someone loses an i.
>>
>


---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
N.N. N.N.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

In reply to this post by Vincent COUVERT-2
There is one directory created in

 C:\Users\xxxxx\AppData\Roaming\Scilab\scilab-5.5,0

But that directory is totally empty.
I also created manually a subdirectory

C:\Users\xxxxx\AppData\Roaming\Scilab\scilab-5.4.1
But again it is empty.
I have uninstalled Scilbab-5,5,0 three times and
restalled it again.

The windows Icon start with the following commpand line :
"C:\Program Files\scilab-5.5.0\bin\WScilex.exe"

Thank you very much for your help.

On 4/15/14, Vincent COUVERT <[hidden email]> wrote:

> Hello,
>
> Can you make a copy of your SCIHOME
> (http://help.scilab.org/docs/5.5.0/en_US/SCIHOME.html) directory before
> removing it and then restart Scilab?
>
> If Scilab starts after this cleanup we will use your SCIHOME copy as a
> basis for a bug report.
>
> Regards,
>
> Le 15/04/2014 00:05, N.N. a écrit :
>> Hello,
>>
>> I got the following message after the install when I want to run scilab.
>>
>> Scilab cannot create Scilab Java Main_Class.
>> (We have not been able to find the main Scilab Class.
>> Check if the Scilab and thirdparty packages area available).
>>
>> Is there anybody who can help me with this problem.
>> I thank you very much.
>>
>> Kind regards.
>>
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users
>


--
Complex numbers: They are all fun and games until someone loses an i.
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Samuel GOUGEON Samuel GOUGEON
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

Le 16/04/2014 14:16, N.N. a écrit :
There is one directory created in

 C:\Users\xxxxx\AppData\Roaming\Scilab\scilab-5.5,0
really -5.5,0 ? not -5.5.0 ?

you may remove all directories named
C:\Users\xxxxx\AppData\Roaming\Scilab\scilab-5.5.... 

and uninstall any previous Scilab 5.5.0 release.
Then try to instal it on your desktop (from where you have all 
rights to write).
Then run Scilab.
If you have an error before getting the console, you may make a screenshot
of the small window where the error is displayed, and post it here
(please not the whole screen).

HTH
Samuel


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
N.N. N.N.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

Hello Samuel,

Of course it is the subdirectory -5.5.0 !

I removed the directories in
C:\Users\xxxxx\AppData\Roaming\Scilab\
I did an uninstall of the former Scilab 5.5.0 release.
I made a install from my desktop directory to my desktop directory.
I selected full installation and the default math libraries

I always got the following message

Scilab cannot create Scilab Java Main-Class.
(We have not been able to find the main Scilab claas.
Check if the Scilab and thirdparty packages are available.

I am glad to say thank you, to all the people who helps of helped me.

Alain.

On 4/26/14, Samuel Gougeon <[hidden email]> wrote:

> Le 16/04/2014 14:16, N.N. a écrit :
>> There is one directory created in
>>
>>   C:\Users\xxxxx\AppData\Roaming\Scilab\scilab-5.5,0
> really -5.5,0 ? not -5.5.0 ?
>
> you may remove all directories named
>
> C:\Users\xxxxx\AppData\Roaming\Scilab\scilab-5.5....
>
> and uninstall any previous Scilab 5.5.0 release.
> Then try to instal it/on your desktop/  (from where you have all
> rights to write).
> Then run Scilab.
> If you have an error before getting the console, you may make a screenshot
> of the small window where the error is displayed, and post it here
> (please not the whole screen).
>
> HTH
> Samuel
>
>


--
Complex numbers: They are all fun and games until someone loses an i.
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
hairypotter87 hairypotter87
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

In reply to this post by Vincent COUVERT-2
Hello, Can you try to remove your SCIHOME directory (http://help.scilab.org/docs/current/en_US/SCIHOME.html) and then restart Scilab?

Everything is okay after I deleted the whole SCIHOME directory;)
Burak Omer Saracoglu Burak Omer Saracoglu
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Scilab-users] can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

This post has NOT been accepted by the mailing list yet.
In reply to this post by N.N.
Dear All;
I faced with the same problem. Please see the screenview:

I could not understand the problem, but by reading your e-mails I solved like that.
I found the folder
........\AppData\Roaming\Scilab\scilab-5.5.2
I uninstalled the Scilab.
I deleted the Scilab folder under Roaming.
........\AppData\Roaming\Scilab\scilab-5.5.2 deleted
........\AppData\Roaming\Scilab\ deleted
........\AppData\Roaming\
I restarted my operating system.
I reinstalled the Scilab (the version I wanted to).
I started the Scilab.
Now I can work the Scilab again.
Best Regards
Burak Omer Saracoglu
rlandersen rlandersen
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Scilab-users] can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

I have the same problem.
When I try to launch Scilab I get the the same error message described.

I had Scilab 5.5.2 installed and working when the problem started.

I tried uninstalling and installing version 6.00.
Same error.

Even deleting ........\AppData\Roaming\Scilab\
Still does not work.

How can I proceed?



Stefan Du Rietz Stefan Du Rietz
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

I have the same problem. I have uninstalled 6.0 and have then several
times uninstalled Scilab 5.5.2, deleted SCIHOME and reinstalled Scilab
5.5.2, which worked before(!), to no avail ...

/Stefan


On 2017-06-25 19:21, rlandersen wrote:

> I have the same problem.
> When I try to launch Scilab I get the the same error message described.
>
> I had Scilab 5.5.2 installed and working when the problem started.
>
> I tried uninstalling and installing version 6.00.
> Same error.
>
> Even deleting ........\AppData\Roaming\Scilab\
> Still does not work.
>
> How can I proceed?
>
>
>
>
>
>
>
> --
> View this message in context: http://mailinglists.scilab.org/Scilab-users-can-not-create-Scilab-Java-Main-Class-after-installation-of-SL-5-5-0-32-on-windows-7-tp4030309p4036657.html
> Sent from the Scilab users - Mailing Lists Archives mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Stefan Du Rietz Stefan Du Rietz
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

Is there any solution for this with Windows 7 Professional? Or only a
switch to Ubuntu after the kernel has been fixed ... ;-)

Regards
Stefan


On 2017-06-25 23:10, Stefan Du Rietz wrote:

> I have the same problem. I have uninstalled 6.0 and have then several
> times uninstalled Scilab 5.5.2, deleted SCIHOME and reinstalled Scilab
> 5.5.2, which worked before(!), to no avail ...
>
> /Stefan
>
>
> On 2017-06-25 19:21, rlandersen wrote:
>> I have the same problem.
>> When I try to launch Scilab I get the the same error message described.
>>
>> I had Scilab 5.5.2 installed and working when the problem started.
>>
>> I tried uninstalling and installing version 6.00.
>> Same error.
>>
>> Even deleting ........\AppData\Roaming\Scilab\
>> Still does not work.
>>
>> How can I proceed?
>>
>>
>>
>>
>>
>>
>>
>> --
>> View this message in context:
>> http://mailinglists.scilab.org/Scilab-users-can-not-create-Scilab-Java-Main-Class-after-installation-of-SL-5-5-0-32-on-windows-7-tp4030309p4036657.html 
>>
>> Sent from the Scilab users - Mailing Lists Archives mailing list
>> archive at Nabble.com.
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.scilab.org/mailman/listinfo/users
>>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Gary Nelson-3 Gary Nelson-3
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can not create Scilab Java Main_Class after installation of SL 5.5.0.32 on windows 7

Has this been solved? I was about to transfer to Win7 from MacOS, but need to know if that is feasible

Thanks

Gary Nelson

'There are two ways to live your life. One is as though nothing is a miracle. The other is as though everything is a miracle.'
Albert Einstein
(1879-1955)






On Jun 29, 2017, at 1:55 AM, Stefan Du Rietz <[hidden email]> wrote:

Is there any solution for this with Windows 7 Professional? Or only a switch to Ubuntu after the kernel has been fixed ... ;-)

Regards
Stefan


On 2017-06-25 23:10, Stefan Du Rietz wrote:
I have the same problem. I have uninstalled 6.0 and have then several times uninstalled Scilab 5.5.2, deleted SCIHOME and reinstalled Scilab 5.5.2, which worked before(!), to no avail ...
/Stefan
On 2017-06-25 19:21, rlandersen wrote:
I have the same problem.
When I try to launch Scilab I get the the same error message described.

I had Scilab 5.5.2 installed and working when the problem started.

I tried uninstalling and installing version 6.00.
Same error.

Even deleting ........\AppData\Roaming\Scilab\
Still does not work.

How can I proceed?







--
View this message in context: http://mailinglists.scilab.org/Scilab-users-can-not-create-Scilab-Java-Main-Class-after-installation-of-SL-5-5-0-32-on-windows-7-tp4030309p4036657.html
Sent from the Scilab users - Mailing Lists Archives mailing list archive at Nabble.com.
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Loading...