[Scilab-users] lincos instruction : example file pendulum_anim45.zcos is corrupted - Buggzilla 16221

classic Classic list List threaded Threaded
48 messages Options
123
knobs knobs
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any progress in sight?

Hi,

I had worked on CelestLab and different CV packages and compiled them in
Sierra or High Sierra (not sure anymore). IPCV and SciCV. Both are now
readily available... No more need to compile them ;-)

I am not compiling SciLab from scratch. That would be beyond my
capabilities.

I only use Homebrew. No Fink no MacPorts.  So far I am very happy with what
I can find on Homebrew.

There are still issues with ATOMS when start it through the Menu. Starting
scilab through the Terminal window helped populating and downloading the
list of package and categories. After that I can start the ATOMS GUI when
starting SciLab as an app. I can hence confirm Chin Luh Tan's experience.

E.g. CelestLab could be installed through the Menu and the GUI. No issues at
all. After the SciLab restart, I could not install IPCV or other toolboxes
this way. Different messages. Typically it cannot find certain files or the
html links are broken. So maybe it is either the file/directory structure of
the zip file or the link to the zip file does not exist anymore. Thus it
might actually be neither a SciLab nor an ATOMS issue (indirectly maybe).

Then I deleted all leftovers of IPCV in the contrib folder and used
atomsInstall('IPCV'), which put the files in the share/.../contrib folder,
but I realized the folder structure is wrong (not recognised?). I had to
move all files and subdirectories from the .../IPCV/IPCV folder to
.../IPCV/4.1/  Then everything works perfectly.

Very tricky.

BTW, output from getversion() is  "scilab-6.0.2".

W.



--
Sent from: http://mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any progress in sight?



> Le 3 nov. 2019 à 20:48, knobs <[hidden email]> a écrit :
>
> Hi,
>
> I had worked on CelestLab and different CV packages and compiled them in
> Sierra or High Sierra (not sure anymore). IPCV and SciCV. Both are now
> readily available... No more need to compile them ;-)
>
> I am not compiling SciLab from scratch. That would be beyond my
> capabilities.
>
> I only use Homebrew. No Fink no MacPorts.  So far I am very happy with what
> I can find on Homebrew.
>
> There are still issues with ATOMS when start it through the Menu. Starting
> scilab through the Terminal window helped populating and downloading the
> list of package and categories. After that I can start the ATOMS GUI when
> starting SciLab as an app. I can hence confirm Chin Luh Tan's experience.
>
> E.g. CelestLab could be installed through the Menu and the GUI. No issues at
> all. After the SciLab restart, I could not install IPCV or other toolboxes
> this way. Different messages. Typically it cannot find certain files or the
> html links are broken. So maybe it is either the file/directory structure of
> the zip file or the link to the zip file does not exist anymore. Thus it
> might actually be neither a SciLab nor an ATOMS issue (indirectly maybe).
>
> Then I deleted all leftovers of IPCV in the contrib folder and used
> atomsInstall('IPCV'), which put the files in the share/.../contrib folder,
> but I realized the folder structure is wrong (not recognised?). I had to
> move all files and subdirectories from the .../IPCV/IPCV folder to
> .../IPCV/4.1/  Then everything works perfectly.
>
> Very tricky.
>
> BTW, output from getversion() is  "scilab-6.0.2".
>
> W.
>
>
>
> --
> Sent from: https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
> _______________________________________________
> users mailing list
> [hidden email]
> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any progress in sight?

I meant

[version, opts] = getversion()

Le 03/11/2019 à 21:44, Stéphane Mottelet a écrit :

>
>> Le 3 nov. 2019 à 20:48, knobs <[hidden email]> a écrit :
>>
>> Hi,
>>
>> I had worked on CelestLab and different CV packages and compiled them in
>> Sierra or High Sierra (not sure anymore). IPCV and SciCV. Both are now
>> readily available... No more need to compile them ;-)
>>
>> I am not compiling SciLab from scratch. That would be beyond my
>> capabilities.
>>
>> I only use Homebrew. No Fink no MacPorts.  So far I am very happy with what
>> I can find on Homebrew.
>>
>> There are still issues with ATOMS when start it through the Menu. Starting
>> scilab through the Terminal window helped populating and downloading the
>> list of package and categories. After that I can start the ATOMS GUI when
>> starting SciLab as an app. I can hence confirm Chin Luh Tan's experience.
>>
>> E.g. CelestLab could be installed through the Menu and the GUI. No issues at
>> all. After the SciLab restart, I could not install IPCV or other toolboxes
>> this way. Different messages. Typically it cannot find certain files or the
>> html links are broken. So maybe it is either the file/directory structure of
>> the zip file or the link to the zip file does not exist anymore. Thus it
>> might actually be neither a SciLab nor an ATOMS issue (indirectly maybe).
>>
>> Then I deleted all leftovers of IPCV in the contrib folder and used
>> atomsInstall('IPCV'), which put the files in the share/.../contrib folder,
>> but I realized the folder structure is wrong (not recognised?). I had to
>> move all files and subdirectories from the .../IPCV/IPCV folder to
>> .../IPCV/4.1/  Then everything works perfectly.
>>
>> Very tricky.
>>
>> BTW, output from getversion() is  "scilab-6.0.2".
>>
>> W.
>>
>>
>>
>> --
>> Sent from: https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org/mailman/listinfo/users
> _______________________________________________
> users mailing list
> [hidden email]
> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org/mailman/listinfo/users

--
Stéphane Mottelet
Ingénieur de recherche
EA 4297 Transformations Intégrées de la Matière Renouvelable
Département Génie des Procédés Industriels
Sorbonne Universités - Université de Technologie de Compiègne
CS 60319, 60203 Compiègne cedex
Tel : +33(0)344234688
http://www.utc.fr/~mottelet

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Pierre PERRICHON Pierre PERRICHON
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any progress in sight?

Hello
Could you continue your conversion in private ?
Thanks for everybody
P.


Before printing, think about ENVIRONMENTAL responsabity

-----Message d'origine-----
De : users <[hidden email]> De la part de Stéphane Mottelet
Envoyé : dimanche 3 novembre 2019 21:55
À : [hidden email]
Objet : Re: [Scilab-users] Scilab cannot work on macOS 10.15 Catalina: Any progress in sight?

I meant

[version, opts] = getversion()

Le 03/11/2019 à 21:44, Stéphane Mottelet a écrit :

>
>> Le 3 nov. 2019 à 20:48, knobs <[hidden email]> a écrit :
>>
>> Hi,
>>
>> I had worked on CelestLab and different CV packages and compiled them
>> in Sierra or High Sierra (not sure anymore). IPCV and SciCV. Both are
>> now readily available... No more need to compile them ;-)
>>
>> I am not compiling SciLab from scratch. That would be beyond my
>> capabilities.
>>
>> I only use Homebrew. No Fink no MacPorts.  So far I am very happy
>> with what I can find on Homebrew.
>>
>> There are still issues with ATOMS when start it through the Menu.
>> Starting scilab through the Terminal window helped populating and
>> downloading the list of package and categories. After that I can
>> start the ATOMS GUI when starting SciLab as an app. I can hence confirm Chin Luh Tan's experience.
>>
>> E.g. CelestLab could be installed through the Menu and the GUI. No
>> issues at all. After the SciLab restart, I could not install IPCV or
>> other toolboxes this way. Different messages. Typically it cannot
>> find certain files or the html links are broken. So maybe it is
>> either the file/directory structure of the zip file or the link to
>> the zip file does not exist anymore. Thus it might actually be neither a SciLab nor an ATOMS issue (indirectly maybe).
>>
>> Then I deleted all leftovers of IPCV in the contrib folder and used
>> atomsInstall('IPCV'), which put the files in the share/.../contrib
>> folder, but I realized the folder structure is wrong (not
>> recognised?). I had to move all files and subdirectories from the
>> .../IPCV/IPCV folder to .../IPCV/4.1/  Then everything works perfectly.
>>
>> Very tricky.
>>
>> BTW, output from getversion() is  "scilab-6.0.2".
>>
>> W.
>>
>>
>>
>> --
>> Sent from:
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/anti
>> spam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/mailinglists.sci
>> lab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/anti
>> spam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org
>> /mailman/listinfo/users
> _______________________________________________
> users mailing list
> [hidden email]
> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists
> .scilab.org/mailman/listinfo/users
--
Stéphane Mottelet
Ingénieur de recherche
EA 4297 Transformations Intégrées de la Matière Renouvelable Département Génie des Procédés Industriels Sorbonne Universités - Université de Technologie de Compiègne CS 60319, 60203 Compiègne cedex Tel : +33(0)344234688 http://www.utc.fr/~mottelet

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

PERRICHON Pierre.vcf (3K) Download Attachment
Chin Luh Tan Chin Luh Tan
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

Hi Perrichon,

Apologize in advance but I think the this conversation is actually solving quite some issues in MacOS and I felt that it could be helpful to continue in mailing list. However, I've no objection to bring it private as well, please keep me in the loop if it goes private. :)

For MacOS users I think they are couple of issues which has been resolved (or some workaround) by this thread. Base on the conversation, I think we could come out with some guideline which could be helpful:

1. for version before High Sierra (10.13), everything works fine, from scilab 6.0.1 to 6.0.2, and I could confirm that atomsInstall for modules such as IPCV works perfectly on this platform for both 6.0.1 and 6.0.2

2. with Stephen help, using the patch for Java, Scilab 6.0.2 could launch on Catalina (10.15) successfully.

3. Issues with atoms on MacOS arise since Majove (10.14), including Catalina,  the very same module during the installation gives issue, which has been reported here:

4. This prompt us to explore further, and found out that modules with only macros seems ok, but the one with gateway will have this issues.

5. We have to emphasis, the very same module works on Scilab 6.0.2 MacOS High Sierra, It only broke since Majove where the extractions of modules seems to be very very different with previous version of Mac. I would not say it is MacOS or Scilab issue, but obviously it seems to be some changes in MacOS that caused this behavior?

In summary, with Stephen's fix, the Scilab 6.0.2 could now run on MacOS Catalina, while with Willi finding on the modules folders disorganization and how to manually move them around, we could make the modules run as well. I think this is quite a great achievement so far to provide Mac users a workaround for current issues, and let's make it even better in coming release!

Cheers!

Thanks

Regards,
Chin Luh




---- On Mon, 04 Nov 2019 06:54:30 +0800 Perrichon <[hidden email]> wrote ----

Hello
Could you continue your conversion in private ?
Thanks for everybody
P.


Before printing, think about ENVIRONMENTAL responsabity

-----Message d'origine-----
De : users <[hidden email]> De la part de Stéphane Mottelet
Envoyé : dimanche 3 novembre 2019 21:55
À : [hidden email]
Objet : Re: [Scilab-users] Scilab cannot work on macOS 10.15 Catalina: Any progress in sight?

I meant

[version, opts] = getversion()

Le 03/11/2019 à 21:44, Stéphane Mottelet a écrit :

>
>> Le 3 nov. 2019 à 20:48, knobs <[hidden email]> a écrit :
>>
>> Hi,
>>
>> I had worked on CelestLab and different CV packages and compiled them
>> in Sierra or High Sierra (not sure anymore). IPCV and SciCV. Both are
>> now readily available... No more need to compile them ;-)
>>
>> I am not compiling SciLab from scratch. That would be beyond my
>> capabilities.
>>
>> I only use Homebrew. No Fink no MacPorts. So far I am very happy
>> with what I can find on Homebrew.
>>
>> There are still issues with ATOMS when start it through the Menu.
>> Starting scilab through the Terminal window helped populating and
>> downloading the list of package and categories. After that I can
>> start the ATOMS GUI when starting SciLab as an app. I can hence confirm Chin Luh Tan's experience.
>>
>> E.g. CelestLab could be installed through the Menu and the GUI. No
>> issues at all. After the SciLab restart, I could not install IPCV or
>> other toolboxes this way. Different messages. Typically it cannot
>> find certain files or the html links are broken. So maybe it is
>> either the file/directory structure of the zip file or the link to
>> the zip file does not exist anymore. Thus it might actually be neither a SciLab nor an ATOMS issue (indirectly maybe).
>>
>> Then I deleted all leftovers of IPCV in the contrib folder and used
>> atomsInstall('IPCV'), which put the files in the share/.../contrib
>> folder, but I realized the folder structure is wrong (not
>> recognised?). I had to move all files and subdirectories from the
>> .../IPCV/IPCV folder to .../IPCV/4.1/ Then everything works perfectly.
>>
>> Very tricky.
>>
>> BTW, output from getversion() is "scilab-6.0.2".
>>
>> W.
>>
>>
>>
>> --
>> Sent from:
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/anti
>> spam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/mailinglists.sci
>> lab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/anti
>> spam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org
>> /mailman/listinfo/users
> _______________________________________________
> users mailing list
> [hidden email]
> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists
> .scilab.org/mailman/listinfo/users

--
Stéphane Mottelet
Ingénieur de recherche
EA 4297 Transformations Intégrées de la Matière Renouvelable Département Génie des Procédés Industriels Sorbonne Universités - Université de Technologie de Compiègne CS 60319, 60203 Compiègne cedex Tel : +33(0)344234688 http://www.utc.fr/~mottelet

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Pierre PERRICHON Pierre PERRICHON
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

Dear tan

Many thanks  for your poem. It is so romantic.

No sure you speak to the right person

I have no mac at home

 

sincerely yours

 

 

 

 

De : users <[hidden email]> De la part de Chin Luh Tan
Envoyé : lundi 4 novembre 2019 02:09
À : Users mailing list for Scilab <[hidden email]>
Cc : 'Users mailing list for Scilab' <[hidden email]>
Objet : Re: [Scilab-users] Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

 

Hi Perrichon,

 

Apologize in advance but I think the this conversation is actually solving quite some issues in MacOS and I felt that it could be helpful to continue in mailing list. However, I've no objection to bring it private as well, please keep me in the loop if it goes private. :)

 

For MacOS users I think they are couple of issues which has been resolved (or some workaround) by this thread. Base on the conversation, I think we could come out with some guideline which could be helpful:

 

1. for version before High Sierra (10.13), everything works fine, from scilab 6.0.1 to 6.0.2, and I could confirm that atomsInstall for modules such as IPCV works perfectly on this platform for both 6.0.1 and 6.0.2

 

2. with Stephen help, using the patch for Java, Scilab 6.0.2 could launch on Catalina (10.15) successfully.

 

3. Issues with atoms on MacOS arise since Majove (10.14), including Catalina,  the very same module during the installation gives issue, which has been reported here:

 

4. This prompt us to explore further, and found out that modules with only macros seems ok, but the one with gateway will have this issues.

 

5. We have to emphasis, the very same module works on Scilab 6.0.2 MacOS High Sierra, It only broke since Majove where the extractions of modules seems to be very very different with previous version of Mac. I would not say it is MacOS or Scilab issue, but obviously it seems to be some changes in MacOS that caused this behavior?

 

In summary, with Stephen's fix, the Scilab 6.0.2 could now run on MacOS Catalina, while with Willi finding on the modules folders disorganization and how to manually move them around, we could make the modules run as well. I think this is quite a great achievement so far to provide Mac users a workaround for current issues, and let's make it even better in coming release!

 

Cheers!

 

Thanks

 

Regards,

Chin Luh

 

 

 

 

---- On Mon, 04 Nov 2019 06:54:30 +0800 Perrichon <[hidden email]> wrote ----

 

Hello
Could you continue your conversion in private ?
Thanks for everybody
P.


Before printing, think about ENVIRONMENTAL responsabity

-----Message d'origine-----
De : users <[hidden email]> De la part de Stéphane Mottelet
Envoyé : dimanche 3 novembre 2019 21:55
À : [hidden email]
Objet : Re: [Scilab-users] Scilab cannot work on macOS 10.15 Catalina: Any progress in sight?

I meant

[version, opts] = getversion()

Le 03/11/2019 à 21:44, Stéphane Mottelet a écrit :


>
>> Le 3 nov. 2019 à 20:48, knobs <[hidden email]> a écrit :
>>
>> Hi,
>>
>> I had worked on CelestLab and different CV packages and compiled them
>> in Sierra or High Sierra (not sure anymore). IPCV and SciCV. Both are
>> now readily available... No more need to compile them ;-)
>>
>> I am not compiling SciLab from scratch. That would be beyond my
>> capabilities.
>>
>> I only use Homebrew. No Fink no MacPorts. So far I am very happy
>> with what I can find on Homebrew.
>>
>> There are still issues with ATOMS when start it through the Menu.
>> Starting scilab through the Terminal window helped populating and
>> downloading the list of package and categories. After that I can
>> start the ATOMS GUI when starting SciLab as an app. I can hence confirm Chin Luh Tan's experience.
>>
>> E.g. CelestLab could be installed through the Menu and the GUI. No
>> issues at all. After the SciLab restart, I could not install IPCV or
>> other toolboxes this way. Different messages. Typically it cannot
>> find certain files or the html links are broken. So maybe it is
>> either the file/directory structure of the zip file or the link to
>> the zip file does not exist anymore. Thus it might actually be neither a SciLab nor an ATOMS issue (indirectly maybe).
>>
>> Then I deleted all leftovers of IPCV in the contrib folder and used
>> atomsInstall('IPCV'), which put the files in the share/.../contrib
>> folder, but I realized the folder structure is wrong (not
>> recognised?). I had to move all files and subdirectories from the
>> .../IPCV/IPCV folder to .../IPCV/4.1/ Then everything works perfectly.
>>
>> Very tricky.
>>
>> BTW, output from getversion() is "scilab-6.0.2".
>>
>> W.
>>
>>
>>
>> --
>> Sent from:
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/anti
>> spam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/mailinglists.sci
>> lab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/anti
>> spam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org
>> /mailman/listinfo/users
> _______________________________________________
> users mailing list
> [hidden email]
> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists
> .scilab.org/mailman/listinfo/users

--
Stéphane Mottelet
Ingénieur de recherche
EA 4297 Transformations Intégrées de la Matière Renouvelable Département Génie des Procédés Industriels Sorbonne Universités - Université de Technologie de Compiègne CS 60319, 60203 Compiègne cedex Tel : +33(0)344234688 http://www.utc.fr/~mottelet

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

 

 


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

In reply to this post by Chin Luh Tan

Hello,

Concerning the ATOMS problems with 6.0.2 on OSX Catalina (Windows users please stop reading further... ;-)), I have the following error on a freshly installed configuration (dedicated partition on my machine):

Scilab 6.0.2 (Aug 19 2019, 11:47:50)

 

--> atomsList

atomsDownload: The following file hasn't been downloaded:

- URL      : 'http://atoms.scilab.org/6.0/TOOLBOXES/64/macosx.gz'

- Local location : '/private/var/folders/pp/hrld62h917x_ccf55yzn78z00000gn/T/SCI_TMP_1093_DIw7vR/.atoms/1_TOOLBOXES.gz'

WARNING: error: Wrong type for input argument #1: string expected.

Scanning repository http://atoms.scilab.org/6.0 ... Skipped

 

at line   198 of function atomsDESCRIPTIONget ( /Applications/scilab-6.0.2.app/Contents/MacOS/share/scilab/modules/atoms/macros/atoms_internals/atomsDESCRIPTIONget.sci line 217 )

at line    38 of function atomsList           ( /Applications/scilab-6.0.2.app/Contents/MacOS/share/scilab/modules/atoms/macros/atomsList.sci line 54 )

 

All ATOMS repositories scan failed.


In fact the temp folder 

/private/var/folders/pp/hrld62h917x_ccf55yzn78z00000gn/T/SCI_TMP_1093_DIw7vR/.atoms

is empty. This is not a network problem as the following command succeeds:

 

--> getURL http://atoms.scilab.org/6.0/TOOLBOXES/64/macosx.gz 

 ans  =

 

 

 /Users/mottelet/macosx.gz

Samuel do you have an idea ?

S.

Chin Luh Tan <[hidden email]> a écrit :

Hi Perrichon,
 
Apologize in advance but I think the this conversation is actually solving quite some issues in MacOS and I felt that it could be helpful to continue in mailing list. However, I've no objection to bring it private as well, please keep me in the loop if it goes private. :)
 
For MacOS users I think they are couple of issues which has been resolved (or some workaround) by this thread. Base on the conversation, I think we could come out with some guideline which could be helpful:
 
1. for version before High Sierra (10.13), everything works fine, from scilab 6.0.1 to 6.0.2, and I could confirm that atomsInstall for modules such as IPCV works perfectly on this platform for both 6.0.1 and 6.0.2
 
2. with Stephen help, using the patch for Java, Scilab 6.0.2 could launch on Catalina (10.15) successfully.
 
3. Issues with atoms on MacOS arise since Majove (10.14), including Catalina,  the very same module during the installation gives issue, which has been reported here:
 
4. This prompt us to explore further, and found out that modules with only macros seems ok, but the one with gateway will have this issues.
 
5. We have to emphasis, the very same module works on Scilab 6.0.2 MacOS High Sierra, It only broke since Majove where the extractions of modules seems to be very very different with previous version of Mac. I would not say it is MacOS or Scilab issue, but obviously it seems to be some changes in MacOS that caused this behavior?
 
In summary, with Stephen's fix, the Scilab 6.0.2 could now run on MacOS Catalina, while with Willi finding on the modules folders disorganization and how to manually move them around, we could make the modules run as well. I think this is quite a great achievement so far to provide Mac users a workaround for current issues, and let's make it even better in coming release!
 
Cheers!
 
Thanks
 
Regards,
Chin Luh
 
 
 
 
---- On Mon, 04 Nov 2019 06:54:30 +0800 Perrichon <[hidden email]> wrote ----
 
Hello
Could you continue your conversion in private ?
Thanks for everybody
P.


Before printing, think about ENVIRONMENTAL responsabity

-----Message d'origine-----
De : users <[hidden email]> De la part de Stéphane Mottelet
Envoyé : dimanche 3 novembre 2019 21:55
À : [hidden email]
Objet : Re: [Scilab-users] Scilab cannot work on macOS 10.15 Catalina: Any progress in sight?

I meant

[version, opts] = getversion()

Le 03/11/2019 à 21:44, Stéphane Mottelet a écrit :
>
>> Le 3 nov. 2019 à 20:48, knobs <[hidden email]> a écrit :
>>
>> Hi,
>>
>> I had worked on CelestLab and different CV packages and compiled them
>> in Sierra or High Sierra (not sure anymore). IPCV and SciCV. Both are
>> now readily available... No more need to compile them ;-)
>>
>> I am not compiling SciLab from scratch. That would be beyond my
>> capabilities.
>>
>> I only use Homebrew. No Fink no MacPorts. So far I am very happy
>> with what I can find on Homebrew.
>>
>> There are still issues with ATOMS when start it through the Menu.
>> Starting scilab through the Terminal window helped populating and
>> downloading the list of package and categories. After that I can
>> start the ATOMS GUI when starting SciLab as an app. I can hence confirm Chin Luh Tan's experience.
>>
>> E.g. CelestLab could be installed through the Menu and the GUI. No
>> issues at all. After the SciLab restart, I could not install IPCV or
>> other toolboxes this way. Different messages. Typically it cannot
>> find certain files or the html links are broken. So maybe it is
>> either the file/directory structure of the zip file or the link to
>> the zip file does not exist anymore. Thus it might actually be neither a SciLab nor an ATOMS issue (indirectly maybe).
>>
>> Then I deleted all leftovers of IPCV in the contrib folder and used
>> atomsInstall('IPCV'), which put the files in the share/.../contrib
>> folder, but I realized the folder structure is wrong (not
>> recognised?). I had to move all files and subdirectories from the
>> .../IPCV/IPCV folder to .../IPCV/4.1/ Then everything works perfectly.
>>
>> Very tricky.
>>
>> BTW, output from getversion() is "scilab-6.0.2".
>>
>> W.
>>
>>
>>
>> --
>> Sent from:
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/anti
>> spam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/mailinglists.sci
>> lab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/anti
>> spam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org
>> /mailman/listinfo/users
> _______________________________________________
> users mailing list
> [hidden email]
> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists
> .scilab.org/mailman/listinfo/users

--
Stéphane Mottelet
Ingénieur de recherche
EA 4297 Transformations Intégrées de la Matière Renouvelable Département Génie des Procédés Industriels Sorbonne Universités - Université de Technologie de Compiègne CS 60319, 60203 Compiègne cedex Tel : +33(0)344234688 http://www.utc.fr/~mottelet

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
 




_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Heinz Nabielek-3 Heinz Nabielek-3
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

On 04.11.2019, at 12:58, [hidden email] wrote:
>
> atomsList

Never used atoms nor do I know, what they are good for, but my 6.02 in Catalina gives

--> atomsList
                        animaGIF - stand-alone creation of an animated GIF image from images files or from a live figure
                     ANN_Toolbox - Artificial Neural Network toolbox
                          apifun - Check input arguments in macros

Altogether 66 lines.

Is there something that I can check for you?
Heinz

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

Thanks Heinz, this is weird. In fact the problem comes from the libcurl which is bundled with Scilab. I think the lib was bundled for historical reasons (libcurl was likely needed for old OSX versions).

Since the problem occurs for a Catalina clean install, without any additionnal software such as Xcode, developper tools, command line tools (which could eventually install a different curl binary), I think we should remove these libraries from SCI/../../lib/thirdparty/, or at least change the order in the DYLD_LIBRARY_PATH in the bin/scilab script.

S.

Heinz Nabielek <[hidden email]> a écrit :

On 04.11.2019, at 12:58, [hidden email] wrote:

atomsList

Never used atoms nor do I know, what they are good for, but my 6.02 in Catalina gives

--> atomsList
                       animaGIF - stand-alone creation of an animated GIF image from images files or from a live figure
                    ANN_Toolbox - Artificial Neural Network toolbox
                         apifun - Check input arguments in macros

Altogether 66 lines.

Is there something that I can check for you?Heinz




_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Chin Luh Tan Chin Luh Tan
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

hi,

as willi suggested, hv u tried to launch the scilab from terminal and run the command again?

thanks.

rdgs,
CL


---- On Mon, 04 Nov 2019 20:31:24 +0800 <[hidden email]> wrote ----

Thanks Heinz, this is weird. In fact the problem comes from the libcurl which is bundled with Scilab. I think the lib was bundled for historical reasons (libcurl was likely needed for old OSX versions).

Since the problem occurs for a Catalina clean install, without any additionnal software such as Xcode, developper tools, command line tools (which could eventually install a different curl binary), I think we should remove these libraries from SCI/../../lib/thirdparty/, or at least change the order in the DYLD_LIBRARY_PATH in the bin/scilab script.

S.

Heinz Nabielek <[hidden email]> a écrit :

On 04.11.2019, at 12:58, [hidden email] wrote:

atomsList

Never used atoms nor do I know, what they are good for, but my 6.02 in Catalina gives

--> atomsList
                       animaGIF - stand-alone creation of an animated GIF image from images files or from a live figure
                    ANN_Toolbox - Artificial Neural Network toolbox
                         apifun - Check input arguments in macros

Altogether 66 lines.

Is there something that I can check for you?Heinz



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

I made the test from the command line. However, I think the regexp problem (which I didn't have) has a different origin.

S.

Chin Luh Tan <[hidden email]> a écrit :

hi,
 
as willi suggested, hv u tried to launch the scilab from terminal and run the command again?
 
thanks.
 
rdgs,
CL


---- On Mon, 04 Nov 2019 20:31:24 +0800 <[hidden email]> wrote ----

Thanks Heinz, this is weird. In fact the problem comes from the libcurl which is bundled with Scilab. I think the lib was bundled for historical reasons (libcurl was likely needed for old OSX versions).

Since the problem occurs for a Catalina clean install, without any additionnal software such as Xcode, developper tools, command line tools (which could eventually install a different curl binary), I think we should remove these libraries from SCI/../../lib/thirdparty/, or at least change the order in the DYLD_LIBRARY_PATH in the bin/scilab script.

S.

Heinz Nabielek <[hidden email]> a écrit :

On 04.11.2019, at 12:58, [hidden email] wrote:

atomsList

Never used atoms nor do I know, what they are good for, but my 6.02 in Catalina gives

--> atomsList
                       animaGIF - stand-alone creation of an animated GIF image from images files or from a live figure
                    ANN_Toolbox - Artificial Neural Network toolbox
                         apifun - Check input arguments in macros

Altogether 66 lines.

Is there something that I can check for you?Heinz


 

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
 




_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Chin Luh Tan Chin Luh Tan
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

i see, sorry for overlooked the error message. 1 last stupid suggestion, could u also try to launch the scilab with sudo from command line?

rgds,
CL


---- On Mon, 04 Nov 2019 20:42:41 +0800 <[hidden email]> wrote ----

I made the test from the command line. However, I think the regexp problem (which I didn't have) has a different origin.

S.

Chin Luh Tan <[hidden email]> a écrit :

hi,
 
as willi suggested, hv u tried to launch the scilab from terminal and run the command again?
 
thanks.
 
rdgs,
CL


---- On Mon, 04 Nov 2019 20:31:24 +0800 <[hidden email]> wrote ----

Thanks Heinz, this is weird. In fact the problem comes from the libcurl which is bundled with Scilab. I think the lib was bundled for historical reasons (libcurl was likely needed for old OSX versions).

Since the problem occurs for a Catalina clean install, without any additionnal software such as Xcode, developper tools, command line tools (which could eventually install a different curl binary), I think we should remove these libraries from SCI/../../lib/thirdparty/, or at least change the order in the DYLD_LIBRARY_PATH in the bin/scilab script.

S.

Heinz Nabielek <[hidden email]> a écrit :

On 04.11.2019, at 12:58, [hidden email] wrote:

atomsList

Never used atoms nor do I know, what they are good for, but my 6.02 in Catalina gives

--> atomsList
                       animaGIF - stand-alone creation of an animated GIF image from images files or from a live figure
                    ANN_Toolbox - Artificial Neural Network toolbox
                         apifun - Check input arguments in macros

Altogether 66 lines.

Is there something that I can check for you?Heinz


 

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
 



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Samuel GOUGEON Samuel GOUGEON
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

In reply to this post by mottelet
Le 04/11/2019 à 12:58, [hidden email] a écrit :

Hello,

Concerning the ATOMS problems with 6.0.2 on OSX Catalina (Windows users please stop reading further... ;-)), I have the following error on a freshly installed configuration (dedicated partition on my machine):

Scilab 6.0.2 (Aug 19 2019, 11:47:50)

 

--> atomsList

atomsDownload: The following file hasn't been downloaded:

- URL      : 'http://atoms.scilab.org/6.0/TOOLBOXES/64/macosx.gz'

- Local location : '/private/var/folders/pp/hrld62h917x_ccf55yzn78z00000gn/T/SCI_TMP_1093_DIw7vR/.atoms/1_TOOLBOXES.gz'

WARNING: error: Wrong type for input argument #1: string expected.

Scanning repository http://atoms.scilab.org/6.0 ... Skipped

 

at line   198 of function atomsDESCRIPTIONget ( /Applications/scilab-6.0.2.app/Contents/MacOS/share/scilab/modules/atoms/macros/atoms_internals/atomsDESCRIPTIONget.sci line 217 )

at line    38 of function atomsList           ( /Applications/scilab-6.0.2.app/Contents/MacOS/share/scilab/modules/atoms/macros/atomsList.sci line 54 )

 

All ATOMS repositories scan failed.


In fact the temp folder 

/private/var/folders/pp/hrld62h917x_ccf55yzn78z00000gn/T/SCI_TMP_1093_DIw7vR/.atoms

is empty. This is not a network problem as the following command succeeds:

 

--> getURL http://atoms.scilab.org/6.0/TOOLBOXES/64/macosx.gz 

 ans  =

 

 

 /Users/mottelet/macosx.gz

Samuel do you have an idea ?


It is possibly either a file-locking issue (for instance due to a previous error without closing the file, that atoms then tries to overwrite. Possible workaround : quit the session to unlock the file, and retry), or an unzip issue (there were formerly many issues due to the fact that unzipping did not force overwritting ; but that should be completely fixed in 6.0.2).

For some (fortunately very rare) ATOMS modules, the software used by the author to bundle the ATOMS archive of the module is not a standard one, and the ATOMS unzip command is not able to do the job. But it's not the case here.

The regexp error is very likely due to an empty case after failing to get a vector (of packages names or either):

--> regexp([],"hk")
regexp: Wrong type for input argument #1: string expected.

It's hard to debug when an issue is transient or not fully reproducible.
By the way, i have no easy access to a MacOS computer.

For contribution

Samuel


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

Thanks Samuel. So the regexp error can eventually have the same cause (libcurl version mismatch). I have packaged a scilab-6.0.2 without these libraries (and removing the 10.15 warning) for OSX users at the following URL:

http://www.utc.fr/~mottelet/scilab/download/6.0.2/scilab-6.0.2-x86_64-2019-11-04.dmg

CL, Heinz, Willi can you test it ? I recommend temporary renaming/moving your .Scilab/scilab-6.0.2 directory before testing

S.

Samuel Gougeon <[hidden email]> a écrit :

Le 04/11/2019 à 12:58, [hidden email] a écrit :

 

Hello,

Concerning the ATOMS problems with 6.0.2 on OSX Catalina (Windows users please stop reading further... ;-)), I have the following error on a freshly installed configuration (dedicated partition on my machine):

Scilab 6.0.2 (Aug 19 2019, 11:47:50)

 

--> atomsList

atomsDownload: The following file hasn't been downloaded:

- URL      : 'http://atoms.scilab.org/6.0/TOOLBOXES/64/macosx.gz'

- Local location : '/private/var/folders/pp/hrld62h917x_ccf55yzn78z00000gn/T/SCI_TMP_1093_DIw7vR/.atoms/1_TOOLBOXES.gz'

WARNING: error: Wrong type for input argument #1: string expected.

Scanning repository http://atoms.scilab.org/6.0 ... Skipped

 

at line   198 of function atomsDESCRIPTIONget ( /Applications/scilab-6.0.2.app/Contents/MacOS/share/scilab/modules/atoms/macros/atoms_internals/atomsDESCRIPTIONget.sci line 217 )

at line    38 of function atomsList           ( /Applications/scilab-6.0.2.app/Contents/MacOS/share/scilab/modules/atoms/macros/atomsList.sci line 54 )

 

All ATOMS repositories scan failed.


In fact the temp folder 

/private/var/folders/pp/hrld62h917x_ccf55yzn78z00000gn/T/SCI_TMP_1093_DIw7vR/.atoms

is empty. This is not a network problem as the following command succeeds:

 

--> getURL http://atoms.scilab.org/6.0/TOOLBOXES/64/macosx.gz 

 ans  =

 

 

 /Users/mottelet/macosx.gz

Samuel do you have an idea ?

 

It is possibly either a file-locking issue (for instance due to a previous error without closing the file, that atoms then tries to overwrite. Possible workaround : quit the session to unlock the file, and retry), or an unzip issue (there were formerly many issues due to the fact that unzipping did not force overwritting ; but that should be completely fixed in 6.0.2).

For some (fortunately very rare) ATOMS modules, the software used by the author to bundle the ATOMS archive of the module is not a standard one, and the ATOMS unzip command is not able to do the job. But it's not the case here.

The regexp error is very likely due to an empty case after failing to get a vector (of packages names or either):

--> regexp([],"hk")
regexp: Wrong type for input argument #1: string expected.

It's hard to debug when an issue is transient or not fully reproducible.
By the way, i have no easy access to a MacOS computer.

For contribution

Samuel
 




_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Heinz Nabielek-3 Heinz Nabielek-3
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

On 04.11.2019, at 14:55, [hidden email] wrote:
>
> Thanks Samuel. So the regexp error can eventually have the same cause (libcurl version mismatch). I have packaged a scilab-6.0.2 without these libraries (and removing the 10.15 warning) for OSX users at the following URL:
>
> http://www.utc.fr/~mottelet/scilab/download/6.0.2/scilab-6.0.2-x86_64-2019-11-04.dmg
>
> CL, Heinz, Willi can you test it ?

Works to perfection and without this funny warning.


> I recommend temporary renaming/moving your .Scilab/scilab-6.0.2 directory before testing



Thanks. Very helpful. Great suggestion. I would not have thought of it…..

Thanks for your dedication to this work.
Heinz
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

Did you test the Atoms stuff ?

Heinz Nabielek <[hidden email]> a écrit :

On 04.11.2019, at 14:55, [hidden email] wrote:

Thanks Samuel. So the regexp error can eventually have the same cause (libcurl version mismatch). I have packaged a scilab-6.0.2 without these libraries (and removing the 10.15 warning) for OSX users at the following URL:

https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.utc.fr/~mottelet/scilab/download/6.0.2/scilab-6.0.2-x86_64-2019-11-04.dmg

CL, Heinz, Willi can you test it ?

Works to perfection and without this funny warning.

I recommend temporary renaming/moving your .Scilab/scilab-6.0.2 directory before testing

Thanks. Very helpful. Great suggestion. I would not have thought of it…..

Thanks for your dedication to this work.Heinz




_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Chin Luh Tan Chin Luh Tan
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

Hi, 

from my end:

1. The warning for the 10.15 gone. 
2. First launch from the app still give the regexp error when running atomsList, but after running one time from terminal and get it run successfully, I could run it from the app as after all. 
3. atomsInstall for the module with gateway folder still extracted to 2 separate folders which need to be manually move in order for it to run. No issue for macros only module. 

Thanks for the great effort. Is is possible to share the compilation steps? 

rgds,
CL


---- On Mon, 04 Nov 2019 22:40:20 +0800 <[hidden email]> wrote ----

Did you test the Atoms stuff ?

Heinz Nabielek <[hidden email]> a écrit :

On 04.11.2019, at 14:55, [hidden email] wrote:

Thanks Samuel. So the regexp error can eventually have the same cause (libcurl version mismatch). I have packaged a scilab-6.0.2 without these libraries (and removing the 10.15 warning) for OSX users at the following URL:

https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.utc.fr/~mottelet/scilab/download/6.0.2/scilab-6.0.2-x86_64-2019-11-04.dmg

CL, Heinz, Willi can you test it ?

Works to perfection and without this funny warning.

I recommend temporary renaming/moving your .Scilab/scilab-6.0.2 directory before testing

Thanks. Very helpful. Great suggestion. I would not have thought of it…..

Thanks for your dedication to this work.Heinz



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Heinz Nabielek-3 Heinz Nabielek-3
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

In reply to this post by mottelet
all 66 atoms here, as before

Greetings from Heinz

On 04.11.2019, at 15:40, [hidden email] wrote:

Did you test the Atoms stuff ?

Heinz Nabielek <[hidden email]> a écrit :

On 04.11.2019, at 14:55, [hidden email] wrote:

Thanks Samuel. So the regexp error can eventually have the same cause (libcurl version mismatch). I have packaged a scilab-6.0.2 without these libraries (and removing the 10.15 warning) for OSX users at the following URL:

https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.utc.fr/~mottelet/scilab/download/6.0.2/scilab-6.0.2-x86_64-2019-11-04.dmg

CL, Heinz, Willi can you test it ?

Works to perfection and without this funny warning.

I recommend temporary renaming/moving your .Scilab/scilab-6.0.2 directory before testing

Thanks. Very helpful. Great suggestion. I would not have thought of it…..

Thanks for your dedication to this work.Heinz



_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

In reply to this post by Chin Luh Tan

Hello,

I don't have the regexp error. Here is my complete workflow:

1 - Delete the eventual previous Sciab 6.0.2 I had in the /Applications/ folder 
2 - Delete my .Scilab folder
3 - extract the .dmg I downloaded from http://www.utc.fr/~mottelet/scilab/download/6.0.2/scilab-6.0.2-x86_64-2019-11-04.dmg
4 - double click the Scilab icon (with first launch usual but annoying details...)
5 - click the ATOMS gui icon or type atomsList at Scilab prompt

Concerning the problem with IPCV (and maybe other packages with gateways, I only tested IPCV), I did not address it in the above archive. I only modified the scilab script (I will create a commit on codereview.scilab.org) and removed the libcurl.dylib that was shipped in lib/thirdparty folder.

Best,

S.

Chin Luh Tan <[hidden email]> a écrit :

Hi, 
 
from my end:
 
1. The warning for the 10.15 gone. 
2. First launch from the app still give the regexp error when running atomsList, but after running one time from terminal and get it run successfully, I could run it from the app as after all. 
3. atomsInstall for the module with gateway folder still extracted to 2 separate folders which need to be manually move in order for it to run. No issue for macros only module. 
 
Thanks for the great effort. Is is possible to share the compilation steps? 
 
rgds,
CL


---- On Mon, 04 Nov 2019 22:40:20 +0800 <[hidden email]> wrote ----

Did you test the Atoms stuff ?

Heinz Nabielek <[hidden email]> a écrit :

On 04.11.2019, at 14:55, [hidden email] wrote:

Thanks Samuel. So the regexp error can eventually have the same cause (libcurl version mismatch). I have packaged a scilab-6.0.2 without these libraries (and removing the 10.15 warning) for OSX users at the following URL:

https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.utc.fr/~mottelet/scilab/download/6.0.2/scilab-6.0.2-x86_64-2019-11-04.dmg

CL, Heinz, Willi can you test it ?

Works to perfection and without this funny warning.

I recommend temporary renaming/moving your .Scilab/scilab-6.0.2 directory before testing

Thanks. Very helpful. Great suggestion. I would not have thought of it…..

Thanks for your dedication to this work.Heinz


 

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
 




_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|

Re: Scilab cannot work on macOS 10.15 Catalina: Any&nbsp; &nbsp; &nbsp; &nbsp; progress in sight?

Obviously, between points 3 and 4 I moved the Scilab app from the archive in the Appplication folder.

[hidden email] a écrit :

Hello,

I don't have the regexp error. Here is my complete workflow:

1 - Delete the eventual previous Sciab 6.0.2 I had in the /Applications/ folder 
2 - Delete my .Scilab folder
3 - extract the .dmg I downloaded from http://www.utc.fr/~mottelet/scilab/download/6.0.2/scilab-6.0.2-x86_64-2019-11-04.dmg
4 - double click the Scilab icon (with first launch usual but annoying details...)
5 - click the ATOMS gui icon or type atomsList at Scilab prompt

Concerning the problem with IPCV (and maybe other packages with gateways, I only tested IPCV), I did not address it in the above archive. I only modified the scilab script (I will create a commit on codereview.scilab.org) and removed the libcurl.dylib that was shipped in lib/thirdparty folder.

Best,

S.

Chin Luh Tan <[hidden email]> a écrit :

Hi, 
 
from my end:
 
1. The warning for the 10.15 gone. 
2. First launch from the app still give the regexp error when running atomsList, but after running one time from terminal and get it run successfully, I could run it from the app as after all. 
3. atomsInstall for the module with gateway folder still extracted to 2 separate folders which need to be manually move in order for it to run. No issue for macros only module. 
 
Thanks for the great effort. Is is possible to share the compilation steps? 
 
rgds,
CL


---- On Mon, 04 Nov 2019 22:40:20 +0800 <[hidden email]> wrote ----

Did you test the Atoms stuff ?

Heinz Nabielek <[hidden email]> a écrit :

On 04.11.2019, at 14:55, [hidden email] wrote:

Thanks Samuel. So the regexp error can eventually have the same cause (libcurl version mismatch). I have packaged a scilab-6.0.2 without these libraries (and removing the 10.15 warning) for OSX users at the following URL:

https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.utc.fr/~mottelet/scilab/download/6.0.2/scilab-6.0.2-x86_64-2019-11-04.dmg

CL, Heinz, Willi can you test it ?

Works to perfection and without this funny warning.

I recommend temporary renaming/moving your .Scilab/scilab-6.0.2 directory before testing

Thanks. Very helpful. Great suggestion. I would not have thought of it…..

Thanks for your dedication to this work.Heinz


 

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
 


 




_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
123