[Scilab-users] scilab-branch-6.0 crashes when changing block parameters

classic Classic list List threaded Threaded
2 messages Options
Grzegorz Grzegorz
Reply | Threaded
Open this post in threaded view
|

[Scilab-users] scilab-branch-6.0 crashes when changing block parameters

Hello,

I see that we are close to new Scilab release:) Thanks for your great work!

I've installed Scilab from 6.0 branch and having some problems with Xcos. It
may be not an issue since 6.0 branch is still under development. Just
letting you know :)

Build #3904 of Revision f0a2a8124ad40c3d519fc5c8120bf5294fd38811

When I use Xcos and e.g CLSS block, open its parameters and simply confirm
with OK Scilab crashes.

After checking block code I've found that line with graphics object
assignment crashes Scilab.

// code from Xcos block
.....
graphics.exprs = exprs;
*x.graphics = graphics;*
x.model = model;
....

From hs_err_pid11472.log I get

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000050dad1cc, pid=11472,
tid=0x00000000000032ac

Regards Grzegorz





--
Sent from: http://mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Clément David-3 Clément David-3
Reply | Threaded
Open this post in threaded view
|

Re: scilab-branch-6.0 crashes when changing block parameters

Hello Grzegorz,

Correct! There is some invalid read/write and memory leaks while using Xcos. There were some fixes already applied but still some work to do (see [1] for example). I will check your reported issue (double click on CLSS on windows 64) to check what is wrong. Thanks for your investigation, hope we will fix it for the release.

[1]: https://codereview.scilab.org/#/c/20796/

--
Clément

-----Original Message-----
From: users <[hidden email]> On Behalf Of Grzegorz
Sent: Wednesday, February 6, 2019 12:59 PM
To: [hidden email]
Subject: [Scilab-users] scilab-branch-6.0 crashes when changing block parameters

Hello,

I see that we are close to new Scilab release:) Thanks for your great work!

I've installed Scilab from 6.0 branch and having some problems with Xcos. It may be not an issue since 6.0 branch is still under development. Just letting you know :)

Build #3904 of Revision f0a2a8124ad40c3d519fc5c8120bf5294fd38811

When I use Xcos and e.g CLSS block, open its parameters and simply confirm with OK Scilab crashes.

After checking block code I've found that line with graphics object assignment crashes Scilab.

// code from Xcos block
.....
graphics.exprs = exprs;
*x.graphics = graphics;*
x.model = model;
....

From hs_err_pid11472.log I get

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000050dad1cc, pid=11472, tid=0x00000000000032ac

Regards Grzegorz





--
Sent from: http://mailinglists.scilab.org/Scilab-users-Mailing-Lists-Archives-f2602246.html
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users