[Scilab-users] xload doesn't work with accented letters in file names on W10

classic Classic list List threaded Threaded
2 messages Options
Perrichon Perrichon
Reply | Threaded
Open this post in threaded view
|

[Scilab-users] xload doesn't work with accented letters in file names on W10

Hello,

 

We get an error when loading a « scg » file which has accented letters in its file name

 

Here is a script to reproduce this error

 

//---------------------------------------------------------------------------

Rep="TMPDIR\"

chdir(Rep)

 

 

NameFile1=Rep + "Test.scg";

NameFile2=Rep + "Test_xxx.scg";

NameFile3=Rep + "Test_ééé.scg";

 

f=scf(1);

plot2d();

 

xsave(NameFile1,1)

 

[status2, message2] = copyfile(NameFile1, NameFile2)

xload(NameFile2, 10)

 

[status3, message3] = copyfile(NameFile1, NameFile3)

xload(NameFile3, 11)

 

edit_error(%f)

//---------------------------------------------------------------------------

 

ERROR :

--> xload(NameFile3, 11)

at line     5 of function xloadFigure ( C:\Program Files\scilab-6.1.0\modules\graphics\macros\xload.sci line 101 )

at line    33 of function xload       ( C:\Program Files\scilab-6.1.0\modules\graphics\macros\xload.sci line 45 )

 

xload: Given file is not a graphic one.

-->

 

--> edit_error(%f)

ans  =

 

  "Opening file C:\Program Files\scilab-6.1.0\modules\graphics\macros\xload.sci on line 101 of the source file of the function xload"

 

 

Best Regards

Pierre

 

 


_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Antoine Monmayrant Antoine Monmayrant
Reply | Threaded
Open this post in threaded view
|

Re: xload doesn't work with accented letters in file names on W10

Hello Pierre,

Exactly like last time, its seems to be Windows10-specific as your
script does work as expected under Linux.

Antoine

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users