Tcl/Tk and Xlib error building scilab 4.1

classic Classic list List threaded Threaded
2 messages Options
Huub van Niekerk Huub van Niekerk
Reply | Threaded
Open this post in threaded view
|

Tcl/Tk and Xlib error building scilab 4.1

Hi,

Running NetBSD 4.0.1 and using X11/gnome, I'm building scilab-4.1 from
NetBSD pkgsrc-current sources. This is what I get:

/usr/pkgsrc/math/scilab/work/.buildlink/lib/libXaw3d.so: warning: warning:
tmpnam() possibly used unsafely, use mkstemp() or mkdtemp()
making all in examples...
Type "make tests" in examples directory
  to test link and addinter features
making man in man...
Creating html help files
/usr/pkgsrc/math/scilab/work/scilab-4.1/bin/scilab -l eng  -nwni  -e
"xmltohtml([],[],'html-rev.xsl');quit" -args -nouserstartup
Xlib: connection to "unix:0.0" refused by server
Xlib: No protocol specified


Tcl Error  : Tk_Init
 
Xlib: connection to "unix:0.0" refused by server
Xlib: No protocol specified

Error: Can't open display: unix:0.0
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/math/scilab/work/scilab-4.1/man/eng
Creating html help files
/usr/pkgsrc/math/scilab/work/scilab-4.1/bin/scilab -l fr  -nwni  -e
"xmltohtml([],[],'html-rev.xsl');quit" -args -nouserstartup
Xlib: connection to "unix:0.0" refused by server
Xlib: No protocol specified


Tcl Error  : Tk_Init
 
Xlib: connection to "unix:0.0" refused by server
Xlib: No protocol specified

Error: Can't open display: unix:0.0
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/math/scilab/work/scilab-4.1/man/fr
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/math/scilab/work/scilab-4.1/man
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/math/scilab/work/scilab-4.1
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/math/scilab
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/math/scilab
Bloemfontein#

Can somebody please tell me what may be wrong?

Thanks for helping out.



Sylvestre Ledru Sylvestre Ledru
Reply | Threaded
Open this post in threaded view
|

Re: Tcl/Tk and Xlib error building scilab 4.1


> Xlib: connection to "unix:0.0" refused by server
> Xlib: No protocol specified
>
>
> Tcl Error  : Tk_Init
>  
> Xlib: connection to "unix:0.0" refused by server
> Xlib: No protocol specified
>
> Error: Can't open display: unix:0.0
> *** Error code 1
> Can somebody please tell me what may be wrong?
If you are building it through a ssh, add the option -X
If you are building from a specific build environnement, you would have
to patch the code to disable the tk init while building the Scilab
documentation.

Sylvestre