[Users-fr] Compilateur lcc win NON détecté sous Seven et compte utilisateur sous SambaEdu3

classic Classic list List threaded Threaded
5 messages Options
Jacques Manson Jacques Manson
Reply | Threaded
Open this post in threaded view
|

[Users-fr] Compilateur lcc win NON détecté sous Seven et compte utilisateur sous SambaEdu3

Bonsoir,

Je souhaiterai faire utiliser à mes élèves de Sciences de l'ingénieur Scilab 5.5.0, mais à son ouverture un message d'erreur me signale que le compilateur lcc win32 n'est pas détecté. 

Différents essais m'ont amené à remarquer que ce compilateur n'est pas détecté quelque soit la nature du compte utilisé (utilisateur ou administrateur) sous SambaEdu 3, le serveur pédagogique sous linux (Debian) de mon lycée. Il n'est détecté que sur le compte administrateur en local qui a servi a son installation.

Quelqu'un aurait-il  la solution pour son utilisation sur ce réseau pédagogique en tant qu'utilisateur.

Mes ordis sont sous seven sp1 et j'ai respecté la procédure d'installation préconisée :
installation de scilab-5.5.. dans c:\scilab
installation de lccwin32.exe dans c:\scilab\lcc
installation des atoms : lcc-windows/cpge/coselica/simm et arduino

Vous remercie pour votre aide
Jacques Manson
Académie de Caen

_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr
Samuel GOUGEON Samuel GOUGEON
Reply | Threaded
Open this post in threaded view
|

Re: Compilateur lcc win NON détecté sous Seven et compte utilisateur sous SambaEdu3

Bonjour,

Scilab est-il installé en réseau sur un serveur accessible en lecture pour tous les utilisateurs, ou installé / répliqué en local sur chaque ordinateur utilisateur de votre établissement ?
D'après votre message, il semble que ce soit en local sous Windows, mais comme vous évoquez également un serveur sous Linux, la précision peut être utile.

Une installation réseau facilite grandement la maintenance et les mises à jour : vous modifiez Scilab en un seul endroit, et tout le monde en profite sans avoir à repasser sur N ordinateurs...

Samuel

Le 12/12/2014 23:03, Jacques Manson a écrit :
Bonsoir,

Je souhaiterai faire utiliser à mes élèves de Sciences de l'ingénieur Scilab 5.5.0, mais à son ouverture un message d'erreur me signale que le compilateur lcc win32 n'est pas détecté. 

Différents essais m'ont amené à remarquer que ce compilateur n'est pas détecté quelque soit la nature du compte utilisé (utilisateur ou administrateur) sous SambaEdu 3, le serveur pédagogique sous linux (Debian) de mon lycée. Il n'est détecté que sur le compte administrateur en local qui a servi a son installation.

Quelqu'un aurait-il  la solution pour son utilisation sur ce réseau pédagogique en tant qu'utilisateur.

Mes ordis sont sous seven sp1 et j'ai respecté la procédure d'installation préconisée :
installation de scilab-5.5.. dans c:\scilab
installation de lccwin32.exe dans c:\scilab\lcc
installation des atoms : lcc-windows/cpge/coselica/simm et arduino

Vous remercie pour votre aide
Jacques Manson
Académie de Caen


_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr


_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr
Jacques Manson Jacques Manson
Reply | Threaded
Open this post in threaded view
|

Re: Compilateur lcc win NON détecté sous Seven et compte utilisateur sous SambaEdu3

Bonsoir,

Vous remercie pour votre aide.

Pour le moment, je l'ai installé en local sous Seven sur chaque poste de mon labo à partir d'un compte administrateur local. Et le compilateur n'est détecté qu'avec ce compte. Quand les élèves se connectent sur ces machines, Scilab génère un message d'erreur concernant la non détection du compilateur Lcc win32.

Je n'ai pas pensé à une installation réseau, car sur le forum je n'ai rien lu à ce sujet et de plus je ne le gère pas et j'étais acculé .
Y a-t-il une procédure particulière pour une install réseau.
et sauriez-vous en tout cas comment résoudre ce problème d'erreur sur une install poste à poste.

Cordialement
Jacques Manson

Le 13 décembre 2014 14:08, Samuel Gougeon <[hidden email]> a écrit :
Bonjour,

Scilab est-il installé en réseau sur un serveur accessible en lecture pour tous les utilisateurs, ou installé / répliqué en local sur chaque ordinateur utilisateur de votre établissement ?
D'après votre message, il semble que ce soit en local sous Windows, mais comme vous évoquez également un serveur sous Linux, la précision peut être utile.

Une installation réseau facilite grandement la maintenance et les mises à jour : vous modifiez Scilab en un seul endroit, et tout le monde en profite sans avoir à repasser sur N ordinateurs...

Samuel

Le 12/12/2014 23:03, Jacques Manson a écrit :
Bonsoir,

Je souhaiterai faire utiliser à mes élèves de Sciences de l'ingénieur Scilab 5.5.0, mais à son ouverture un message d'erreur me signale que le compilateur lcc win32 n'est pas détecté. 

Différents essais m'ont amené à remarquer que ce compilateur n'est pas détecté quelque soit la nature du compte utilisé (utilisateur ou administrateur) sous SambaEdu 3, le serveur pédagogique sous linux (Debian) de mon lycée. Il n'est détecté que sur le compte administrateur en local qui a servi a son installation.

Quelqu'un aurait-il  la solution pour son utilisation sur ce réseau pédagogique en tant qu'utilisateur.

Mes ordis sont sous seven sp1 et j'ai respecté la procédure d'installation préconisée :
installation de scilab-5.5.. dans c:\scilab
installation de lccwin32.exe dans c:\scilab\lcc
installation des atoms : lcc-windows/cpge/coselica/simm et arduino

Vous remercie pour votre aide
Jacques Manson
Académie de Caen


_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr


_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr


_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr
Samuel GOUGEON Samuel GOUGEON
Reply | Threaded
Open this post in threaded view
|

Re: Compilateur lcc win NON détecté sous Seven et compte utilisateur sous SambaEdu3

Bonjour,

Le 13/12/2014 18:54, Jacques Manson a écrit :
Bonsoir,

Vous remercie pour votre aide.

Pour le moment, je l'ai installé en local sous Seven sur chaque poste de mon labo à partir d'un compte administrateur local. Et le compilateur n'est détecté qu'avec ce compte. Quand les élèves se connectent sur ces machines, Scilab génère un message d'erreur concernant la non détection du compilateur Lcc win32.

Je n'ai pas pensé à une installation réseau, car sur le forum je n'ai rien lu à ce sujet et de plus je ne le gère pas et j'étais acculé .
Y a-t-il une procédure particulière pour une install réseau.


Il y en a autant que de configurations du réseau et de l'hébergement des comptes utilisateurs (seulement en local ou en réseau).
Une des forces de Scilab est qu'il est possible de copier son dossier d'installation là où bon nous semble. Y compris sur un serveur réseau. La copie est alors lançable en l'état (sous réserve de compatibilité entre l'architecture de l'ordinateur "client" et du Scilab lancé, évidemment).
Il peut ensuite y avoir un peu de travail afin que les variables d'environnement de l'OS utilisés par Scilab au démarrage soient bien prises en compte, en particulier pour que SCIHOME ait la valeur souhaitée, ce qui sous Windows peut requérir un lancement via un fichier batch, qui préparera l'environnement de lancement avant de lancer. Quand des applications tierces sont requises et non incluses dans Windows (comme un compilateur), il est normal que des tests et ajustements supplémentaires soient requis. Mais après cela, la vie devient N fois plus simple. Si vous voulez ajouter un module pour tout le monde, vous l'ajoutez sur l'installation réseau et c'est réglé. etc.

Mes ordis sont sous seven sp1 et j'ai respecté la procédure d'installation préconisée :
installation de scilab-5.5.. dans c:\scilab
installation de lccwin32.exe dans c:\scilab\lcc
installation des atoms : lcc-windows/cpge/coselica/simm et arduino

Depuis une session Scilab ouverte sur un compte non admin, vous pouvez utiliser
-->atomsGetLoaded
 ans  =
 
!lcc_windows  0.5-1  allusers  SCI\contrib\lcc_windows\0.5-1  I  !
La liste a autant de lignes que de modules ATOMS chargés.
La ligne  lcc_windows apparait-elle ?
Est-elle en mode allusers ?

Le dossier d'installation de Scilab est-il vraiment le dossier d'installation proposé par défaut pour LCC ?

Les pages ATOMS des versions 0.4.1. et 0.5 de LCC_Win incluent plusieurs témoignages, remarques et références relatifs à des problèmes de détection :
http://atoms.scilab.org/toolboxes/lcc_windows/0.4.1#comments
http://atoms.scilab.org/toolboxes/lcc_windows/0.5#comments

Il y a dans Scilab différentes fonctions de détection "automatique" de compilateur, très compliquées (voir leur code), dont l'efficacité n'est pas systématique.
Il serait sans doute préférable de remplacer toutes celles-ci par une déclaration explicite du compilateur à utiliser, dans les Préférences.
Voir http://bugzilla.scilab.org/show_bug.cgi?id=12355 : N'hésitez-pas à ajouter en commentaire une référence à la présente discussion.

Bon courage
Cordialement
Samuel

PS : lorsque vous obtenez un message d'erreur et que vous demandez de l'aide, c'est toujours une  bonne idée de poster le message intégral et littéral.


_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr
Jacques Manson Jacques Manson
Reply | Threaded
Open this post in threaded view
|

Re: Compilateur lcc win NON détecté sous Seven et compte utilisateur sous SambaEdu3

Bonjour,

J'ai pu faire les manips ce matin, et voici les réponses affichées par scilab :


Depuis une session Scilab ouverte sur un compte non admin, 
Résultat :
-->atomsGetLoaded
ans  =
!lcc_windows  0.5.1-2  allusers  SCI\contrib\lcc_windows\0.5.1-2  I  !
!CPGE         1.5.2-1  allusers  SCI\contrib\CPGE\1.5.2-1         I  !
!coselica     0.6.3-1  allusers  SCI\contrib\coselica\0.6.3-1     I  !
!SIMM         0.4-1    allusers  SCI\contrib\SIMM\0.4-1           I  !
!arduino      1.1-1    allusers  SCI\contrib\arduino\1.1-1        I  !

La ligne  lcc_windows apparait-elle ? OUI
Est-elle en mode allusers ? OUI

Le dossier d'installation de Scilab est-il vraiment le dossier d'installation proposé par défaut pour LCC ?
le dossier d'installation de Scilab est : C:\scilab-5.5.0
et celui de lcc win32 : C:\scilab-5.5.0\lcc

-->lcc_lib_dir = lcc_getScilabLibPath()
 lcc_lib_dir  =
 
 K:\profil\appdata\Scilab\scilab-5.5.0\lcclib  

-->SCIHOME
 SCIHOME  =
 
 K:\profil\appdata\Scilab\scilab-5.5.0

par contre pas de trace dans le profil utilisé de Scilab\scilab-5.5.0\lcclib  dans le dossier  K:\profil\appdata\

"Il peut ensuite y avoir un peu de travail afin que les variables d'environnement de l'OS utilisés par Scilab au démarrage soient bien prises en compte, en particulier pour que SCIHOME ait la valeur souhaitée, ce qui sous Windows peut requérir un lancement via un fichier batch"
Que devrait contenir le fichier batch en question, car je n'en ai aucune idée ?

Cordialement et merci encore, mais je ne vois pas comment résoudre mon problème ?

Jacques Manson

Bonjour,

Le 13/12/2014 18:54, Jacques Manson a écrit :
Bonsoir,

Vous remercie pour votre aide.

Pour le moment, je l'ai installé en local sous Seven sur chaque poste de mon labo à partir d'un compte administrateur local. Et le compilateur n'est détecté qu'avec ce compte. Quand les élèves se connectent sur ces machines, Scilab génère un message d'erreur concernant la non détection du compilateur Lcc win32.

Je n'ai pas pensé à une installation réseau, car sur le forum je n'ai rien lu à ce sujet et de plus je ne le gère pas et j'étais acculé .
Y a-t-il une procédure particulière pour une install réseau.


Il y en a autant que de configurations du réseau et de l'hébergement des comptes utilisateurs (seulement en local ou en réseau).
Une des forces de Scilab est qu'il est possible de copier son dossier d'installation là où bon nous semble. Y compris sur un serveur réseau. La copie est alors lançable en l'état (sous réserve de compatibilité entre l'architecture de l'ordinateur "client" et du Scilab lancé, évidemment).
Il peut ensuite y avoir un peu de travail afin que les variables d'environnement de l'OS utilisés par Scilab au démarrage soient bien prises en compte, en particulier pour que SCIHOME ait la valeur souhaitée, ce qui sous Windows peut requérir un lancement via un fichier batch, qui préparera l'environnement de lancement avant de lancer. Quand des applications tierces sont requises et non incluses dans Windows (comme un compilateur), il est normal que des tests et ajustements supplémentaires soient requis. Mais après cela, la vie devient N fois plus simple. Si vous voulez ajouter un module pour tout le monde, vous l'ajoutez sur l'installation réseau et c'est réglé. etc.

Mes ordis sont sous seven sp1 et j'ai respecté la procédure d'installation préconisée :
installation de scilab-5.5.. dans c:\scilab
installation de lccwin32.exe dans c:\scilab\lcc
installation des atoms : lcc-windows/cpge/coselica/simm et arduino

Depuis une session Scilab ouverte sur un compte non admin, vous pouvez utiliser
-->atomsGetLoaded
 ans  =
 
!lcc_windows  0.5-1  allusers  SCI\contrib\lcc_windows\0.5-1  I  !
La liste a autant de lignes que de modules ATOMS chargés.
La ligne  lcc_windows apparait-elle ?
Est-elle en mode allusers ?

Le dossier d'installation de Scilab est-il vraiment le dossier d'installation proposé par défaut pour LCC ?

Les pages ATOMS des versions 0.4.1. et 0.5 de LCC_Win incluent plusieurs témoignages, remarques et références relatifs à des problèmes de détection :
http://atoms.scilab.org/toolboxes/lcc_windows/0.4.1#comments
http://atoms.scilab.org/toolboxes/lcc_windows/0.5#comments

Il y a dans Scilab différentes fonctions de détection "automatique" de compilateur, très compliquées (voir leur code), dont l'efficacité n'est pas systématique.
Il serait sans doute préférable de remplacer toutes celles-ci par une déclaration explicite du compilateur à utiliser, dans les Préférences.
Voir http://bugzilla.scilab.org/show_bug.cgi?id=12355 : N'hésitez-pas à ajouter en commentaire une référence à la présente discussion.

Bon courage
Cordialement
Samuel

PS : lorsque vous obtenez un message d'erreur et que vous demandez de l'aide, c'est toujours une  bonne idée de poster le message intégral et littéral.




Le 14 décembre 2014 13:15, Samuel Gougeon <[hidden email]> a écrit :
Bonjour,

Le 13/12/2014 18:54, Jacques Manson a écrit :
Bonsoir,

Vous remercie pour votre aide.

Pour le moment, je l'ai installé en local sous Seven sur chaque poste de mon labo à partir d'un compte administrateur local. Et le compilateur n'est détecté qu'avec ce compte. Quand les élèves se connectent sur ces machines, Scilab génère un message d'erreur concernant la non détection du compilateur Lcc win32.

Je n'ai pas pensé à une installation réseau, car sur le forum je n'ai rien lu à ce sujet et de plus je ne le gère pas et j'étais acculé .
Y a-t-il une procédure particulière pour une install réseau.


Il y en a autant que de configurations du réseau et de l'hébergement des comptes utilisateurs (seulement en local ou en réseau).
Une des forces de Scilab est qu'il est possible de copier son dossier d'installation là où bon nous semble. Y compris sur un serveur réseau. La copie est alors lançable en l'état (sous réserve de compatibilité entre l'architecture de l'ordinateur "client" et du Scilab lancé, évidemment).
Il peut ensuite y avoir un peu de travail afin que les variables d'environnement de l'OS utilisés par Scilab au démarrage soient bien prises en compte, en particulier pour que SCIHOME ait la valeur souhaitée, ce qui sous Windows peut requérir un lancement via un fichier batch, qui préparera l'environnement de lancement avant de lancer. Quand des applications tierces sont requises et non incluses dans Windows (comme un compilateur), il est normal que des tests et ajustements supplémentaires soient requis. Mais après cela, la vie devient N fois plus simple. Si vous voulez ajouter un module pour tout le monde, vous l'ajoutez sur l'installation réseau et c'est réglé. etc.

Mes ordis sont sous seven sp1 et j'ai respecté la procédure d'installation préconisée :
installation de scilab-5.5.. dans c:\scilab
installation de lccwin32.exe dans c:\scilab\lcc
installation des atoms : lcc-windows/cpge/coselica/simm et arduino

Depuis une session Scilab ouverte sur un compte non admin, vous pouvez utiliser
-->atomsGetLoaded
 ans  =
 
!lcc_windows  0.5-1  allusers  SCI\contrib\lcc_windows\0.5-1  I  !
La liste a autant de lignes que de modules ATOMS chargés.
La ligne  lcc_windows apparait-elle ?
Est-elle en mode allusers ?

Le dossier d'installation de Scilab est-il vraiment le dossier d'installation proposé par défaut pour LCC ?

Les pages ATOMS des versions 0.4.1. et 0.5 de LCC_Win incluent plusieurs témoignages, remarques et références relatifs à des problèmes de détection :
http://atoms.scilab.org/toolboxes/lcc_windows/0.4.1#comments
http://atoms.scilab.org/toolboxes/lcc_windows/0.5#comments

Il y a dans Scilab différentes fonctions de détection "automatique" de compilateur, très compliquées (voir leur code), dont l'efficacité n'est pas systématique.
Il serait sans doute préférable de remplacer toutes celles-ci par une déclaration explicite du compilateur à utiliser, dans les Préférences.
Voir http://bugzilla.scilab.org/show_bug.cgi?id=12355 : N'hésitez-pas à ajouter en commentaire une référence à la présente discussion.

Bon courage
Cordialement
Samuel

PS : lorsque vous obtenez un message d'erreur et que vous demandez de l'aide, c'est toujours une  bonne idée de poster le message intégral et littéral.


_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr


_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr