[Users-fr] Scilab-6 et iodelay toolbox Erreur de segmentation.

classic Classic list List threaded Threaded
1 message Options
Lucien Povy Lucien Povy
Reply | Threaded
Open this post in threaded view
|

[Users-fr] Scilab-6 et iodelay toolbox Erreur de segmentation.

Bonjour à tous,

Il est impossible pour moi d'envoyer un courrier sur le site Atoms.

Je teste une nouvelle boîte à outil utilisant "iodelay toolbox". Avec
Scilab 5.5.2 pas de problêmes mais avec Scilab-6, en testant l'exemple
du fichier help de "iodelay" j'ai le droit à une fermeture de scilab-6
avec dans le terminal X :

./bin/scilab : ligne 957 : 19285 Erreur de segmentation  (core
dumped)"$SCILABBIN" "$@" . Je suis sur Linux opensuse 42.3 . Cela vient
de l'instruction bode, mais avec black ou nyquist c'est la même chose.

Par la même occasion je voudrais souligner que l'on peut avoir un
décalage de 360° avec bode et black, j'ai l'explication : il ne faut
pas, dans certain cas, passer par l'instruction repfreq  ou repfreqrd
pour les tracés des lieux précédents, mais construire une factorisation
de Bode du système (gain statique, intégrations, premier et/ou second
ordre pour avoir les bons lieux, travailler directement en gain et
phase). Avec des systèmes retardés ou même sans retard on a ce décalage
quelquefois mais pas de discontinuités sur la phase comme Matlab.

Bien cordialement à tous.

Lucien Povy



_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr