[Users-fr] problème avec lincos

classic Classic list List threaded Threaded
2 messages Options
Jean-Christophe Charlaix Jean-Christophe Charlaix
Reply | Threaded
Open this post in threaded view
|

[Users-fr] problème avec lincos

Bonjour,

J’essaie d’extraire la représentation d’état du schéma xcos en pièce jointe pour calculer un correcteur en utilisant hinf.

Dans la première partie du script j’ai défini mes fonctions de pondération en fonction de mes objectifs.

Ensuite en me fondant sur l’exemple de l’aide pour lincos, je cherche le bloc correspondant à mon modèle, pour me faciliter la vie je l’ai appelé plant (comme la forme standard).

Je fournis le résultat de ma recherche à lincos et j’obtiens le message d’erreur :

 

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

à la ligne   262 de la fonction lincos ( C:\Program Files\scilab-6.0.1\modules\scicos\macros\scicos_auto\lincos.sci ligne 284 )

à la ligne    35 du fichier exécuté C:\Users\j.charlaix\Documents\Scilab workspace\4bloc.sce

 

Sous-matrice incorrectement définie.

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

En regardant dans la fonction lincos j’ai l’impression que ma matrice F doit être vide, ce qui fait que l’on ne peut pas la remplir.

J’ai essayé exactement le même script avec un schéma plus simple et je n’ai pas de problème

Est-ce que quelqu’un voit une erreur quelque part ?

 

Pour exécuter le script il suffit de lancer 4bloc.sce

 

Merci d’avance pour votre aide

 

Jean-Christophe


_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr

4bloc.sce (1K) Download Attachment
4bloc.zcos (4K) Download Attachment
Jean-Christophe Charlaix Jean-Christophe Charlaix
Reply | Threaded
Open this post in threaded view
|

Re: problème avec lincos

Bonjour,

Pour info j’ai résolu mon problème, la fonction lincos ne fonctionne pas dès qu’on a plus de 2 entrées et 2 sorties au super bloc.

J’ai contourné le problème en multiplexant mes entrées et sorties et j’obtiens la bonne représentation d’état.

 

JC

 

De : Jean-Christophe Charlaix
Envoyé : vendredi, 19 octobre 2018 17:08
À : '[hidden email]' <[hidden email]>
Objet : problème avec lincos

 

Bonjour,

J’essaie d’extraire la représentation d’état du schéma xcos en pièce jointe pour calculer un correcteur en utilisant hinf.

Dans la première partie du script j’ai défini mes fonctions de pondération en fonction de mes objectifs.

Ensuite en me fondant sur l’exemple de l’aide pour lincos, je cherche le bloc correspondant à mon modèle, pour me faciliter la vie je l’ai appelé plant (comme la forme standard).

Je fournis le résultat de ma recherche à lincos et j’obtiens le message d’erreur :

 

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

à la ligne   262 de la fonction lincos ( C:\Program Files\scilab-6.0.1\modules\scicos\macros\scicos_auto\lincos.sci ligne 284 )

à la ligne    35 du fichier exécuté C:\Users\j.charlaix\Documents\Scilab workspace\4bloc.sce

 

Sous-matrice incorrectement définie.

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

En regardant dans la fonction lincos j’ai l’impression que ma matrice F doit être vide, ce qui fait que l’on ne peut pas la remplir.

J’ai essayé exactement le même script avec un schéma plus simple et je n’ai pas de problème

Est-ce que quelqu’un voit une erreur quelque part ?

 

Pour exécuter le script il suffit de lancer 4bloc.sce

 

Merci d’avance pour votre aide

 

Jean-Christophe


_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr