[Users-fr] scilab 5.5.2 sur Mac OS

classic Classic list List threaded Threaded
5 messages Options
Gael Mahe Gael Mahe
Reply | Threaded
Open this post in threaded view
|

[Users-fr] scilab 5.5.2 sur Mac OS

Bonjour,

J'avais scilab 5.5.2 et 6 sur Mac OS 10.11.6 (El Capitan, je ne peux  
pas upgrader), qui fonctionnaient très bien tous les deux.

Suite à une autre installation de logiciel (qui semble avoir touché à  
l'openjdk), scilab 5.5.2 ne se lance plus. J'ai rechargé  
successivement les deux versions qui figurent sur  
https://www.scilab.org/download/5.5.2 :
- https://www.scilab.org/download/5.5.2/scilab-5.5.2.1-x86_64.dmg ->  
au lancement, une fenêtre me dit que c'est une version pour Mac OS  
10.6 à 10.9...
-  
https://www.scilab.org/download/5.5.2/scilab-5.5.2.1-x86_64_yosemite.dmg -> au  
lancement, rien ne se passe

Une idée ?

Cordialement,

Gaël


----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.
_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|

Re: scilab 5.5.2 sur Mac OS

Bonjour,

Le 01/04/2020 à 13:23, [hidden email] a écrit :

> Bonjour,
>
> J'avais scilab 5.5.2 et 6 sur Mac OS 10.11.6 (El Capitan, je ne peux
> pas upgrader), qui fonctionnaient très bien tous les deux.
>
> Suite à une autre installation de logiciel (qui semble avoir touché à
> l'openjdk), scilab 5.5.2 ne se lance plus. J'ai rechargé
> successivement les deux versions qui figurent sur
> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2 
> :
> -
> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2/scilab-5.5.2.1-x86_64.dmg 
> -> au lancement, une fenêtre me dit que c'est une version pour Mac OS
> 10.6 à 10.9...
> -
> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2/scilab-5.5.2.1-x86_64_yosemite.dmg 
> -> au lancement, rien ne se passe
>
> Une idée ?

oui, essayer de lancer les applications concernées en ligne de commande
pour voir les messages d'erreur. Par exemple dans le terminal, il suffit
de taper

/Applications/scilab-5.5.2.app/Contents/MacOS/bin/scilab

Donne-nous ensuite le message d'erreur obtenu (sûrement une histoire de
librairie incompatible ou autre)

S.

>
> Cordialement,
>
> Gaël
>
>
> ----------------------------------------------------------------
> This message was sent using IMP, the Internet Messaging Program.
> _______________________________________________
> users-fr mailing list
> [hidden email]
> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org/mailman/listinfo/users-fr 
>

--
Stéphane Mottelet
Ingénieur de recherche
EA 4297 Transformations Intégrées de la Matière Renouvelable
Département Génie des Procédés Industriels
Sorbonne Universités - Université de Technologie de Compiègne
CS 60319, 60203 Compiègne cedex
Tel : +33(0)344234688
http://www.utc.fr/~mottelet

_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr
Gael Mahe Gael Mahe
Reply | Threaded
Open this post in threaded view
|

Re: scilab 5.5.2 sur Mac OS

Merci
Voici le message d'erreur :

*******

JavaVM: requested Java version (1.5) not available. Using Java at  
"/Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home"  
instead.
JavaVM: Failed to load JVM:  
/Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home/bundle/Libraries/libserver.dylib
JavaVM FATAL: Failed to load the jvm library.
JavaVM: requested Java version (1.5) not available. Using Java at  
"/Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home"  
instead.
JavaVM: Failed to load JVM:  
/Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home/bundle/Libraries/libserver.dylib
JavaVM FATAL: Failed to load the jvm library.
Erreur lors de la création de la Machine Virtuelle Java : Erreur JNI inconnue
Options :
0: -Djava.library.path=
1:  
-Djava.class.path=/Applications/scilab-5.5.2.app/Contents/MacOS/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar
2:  
-Djava.util.logging.config.file=/Applications/scilab-5.5.2.app/Contents/MacOS/share/scilab/etc/logging.properties
3: -Djava.compiler=JIT
4: -Xmx256m
5: -Xrs
6: -Dapple.laf.useScreenMenuBar=true
7: -Djogamp.gluegen.UseTempJarCache=false

Scilab ne peut pas ouvrir la bibliothèque JVM.

**************


Stéphane Mottelet <[hidden email]> a écrit :

> Bonjour,
>
> Le 01/04/2020 à 13:23, [hidden email] a écrit :
>> Bonjour,
>>
>> J'avais scilab 5.5.2 et 6 sur Mac OS 10.11.6 (El Capitan, je ne  
>> peux pas upgrader), qui fonctionnaient très bien tous les deux.
>>
>> Suite à une autre installation de logiciel (qui semble avoir touché  
>> à l'openjdk), scilab 5.5.2 ne se lance plus. J'ai rechargé  
>> successivement les deux versions qui figurent sur  
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2 
>> :
>> -  
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2/scilab-5.5.2.1-x86_64.dmg -> au lancement, une fenêtre me dit que c'est une version pour Mac OS 10.6 à  
>> 10.9...
>> -  
>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2/scilab-5.5.2.1-x86_64_yosemite.dmg -> au lancement, rien ne se  
>> passe
>>
>> Une idée ?
>
> oui, essayer de lancer les applications concernées en ligne de  
> commande pour voir les messages d'erreur. Par exemple dans le  
> terminal, il suffit de taper
>
> /Applications/scilab-5.5.2.app/Contents/MacOS/bin/scilab
>
> Donne-nous ensuite le message d'erreur obtenu (sûrement une histoire  
> de librairie incompatible ou autre)
>
> S.
>
>>
>> Cordialement,
>>
>> Gaël
>>
>>
>> ----------------------------------------------------------------
>> This message was sent using IMP, the Internet Messaging Program.
>> _______________________________________________
>> users-fr mailing list
>> [hidden email]
>> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org/mailman/listinfo/users-fr
>
> --
> Stéphane Mottelet
> Ingénieur de recherche
> EA 4297 Transformations Intégrées de la Matière Renouvelable
> Département Génie des Procédés Industriels
> Sorbonne Universités - Université de Technologie de Compiègne
> CS 60319, 60203 Compiègne cedex
> Tel : +33(0)344234688
> http://www.utc.fr/~mottelet
>
> _______________________________________________
> users-fr mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users-fr
>



----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.
_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr
mottelet mottelet
Reply | Threaded
Open this post in threaded view
|

Re: scilab 5.5.2 sur Mac OS

Avant d'utiliser une méthode plus drastique, peux-tu taper la commande
suivante

/usr/libexec/java_home -V

pour voir si tu as une autre version de Java que celle du projet
adoptopenjdk ?

S.

Le 01/04/2020 à 17:09, [hidden email] a écrit :

> Merci
> Voici le message d'erreur :
>
> *******
>
> JavaVM: requested Java version (1.5) not available. Using Java at
> "/Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home"
> instead.
> JavaVM: Failed to load JVM:
> /Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home/bundle/Libraries/libserver.dylib
> JavaVM FATAL: Failed to load the jvm library.
> JavaVM: requested Java version (1.5) not available. Using Java at
> "/Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home"
> instead.
> JavaVM: Failed to load JVM:
> /Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home/bundle/Libraries/libserver.dylib
> JavaVM FATAL: Failed to load the jvm library.
> Erreur lors de la création de la Machine Virtuelle Java : Erreur JNI
> inconnue
> Options :
> 0: -Djava.library.path=
> 1:
> -Djava.class.path=/Applications/scilab-5.5.2.app/Contents/MacOS/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar
> 2:
> -Djava.util.logging.config.file=/Applications/scilab-5.5.2.app/Contents/MacOS/share/scilab/etc/logging.properties
> 3: -Djava.compiler=JIT
> 4: -Xmx256m
> 5: -Xrs
> 6: -Dapple.laf.useScreenMenuBar=true
> 7: -Djogamp.gluegen.UseTempJarCache=false
>
> Scilab ne peut pas ouvrir la bibliothèque JVM.
>
> **************
>
>
> Stéphane Mottelet <[hidden email]> a écrit :
>
>> Bonjour,
>>
>> Le 01/04/2020 à 13:23, [hidden email] a écrit :
>>> Bonjour,
>>>
>>> J'avais scilab 5.5.2 et 6 sur Mac OS 10.11.6 (El Capitan, je ne peux
>>> pas upgrader), qui fonctionnaient très bien tous les deux.
>>>
>>> Suite à une autre installation de logiciel (qui semble avoir touché
>>> à l'openjdk), scilab 5.5.2 ne se lance plus. J'ai rechargé
>>> successivement les deux versions qui figurent sur
>>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2 
>>> :
>>> -
>>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2/scilab-5.5.2.1-x86_64.dmg 
>>> -> au lancement, une fenêtre me dit que c'est une version pour Mac
>>> OS 10.6 à 10.9...
>>> -
>>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2/scilab-5.5.2.1-x86_64_yosemite.dmg 
>>> -> au lancement, rien ne se passe
>>>
>>> Une idée ?
>>
>> oui, essayer de lancer les applications concernées en ligne de
>> commande pour voir les messages d'erreur. Par exemple dans le
>> terminal, il suffit de taper
>>
>> /Applications/scilab-5.5.2.app/Contents/MacOS/bin/scilab
>>
>> Donne-nous ensuite le message d'erreur obtenu (sûrement une histoire
>> de librairie incompatible ou autre)
>>
>> S.
>>
>>>
>>> Cordialement,
>>>
>>> Gaël
>>>
>>>
>>> ----------------------------------------------------------------
>>> This message was sent using IMP, the Internet Messaging Program.
>>> _______________________________________________
>>> users-fr mailing list
>>> [hidden email]
>>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org/mailman/listinfo/users-fr 
>>>
>>
>> --
>> Stéphane Mottelet
>> Ingénieur de recherche
>> EA 4297 Transformations Intégrées de la Matière Renouvelable
>> Département Génie des Procédés Industriels
>> Sorbonne Universités - Université de Technologie de Compiègne
>> CS 60319, 60203 Compiègne cedex
>> Tel : +33(0)344234688
>> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.utc.fr/~mottelet 
>>
>>
>> _______________________________________________
>> users-fr mailing list
>> [hidden email]
>> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org/mailman/listinfo/users-fr 
>>
>>
>
>
>
> ----------------------------------------------------------------
> This message was sent using IMP, the Internet Messaging Program.
> _______________________________________________
> users-fr mailing list
> [hidden email]
> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org/mailman/listinfo/users-fr 
>

--
Stéphane Mottelet
Ingénieur de recherche
EA 4297 Transformations Intégrées de la Matière Renouvelable
Département Génie des Procédés Industriels
Sorbonne Universités - Université de Technologie de Compiègne
CS 60319, 60203 Compiègne cedex
Tel : +33(0)344234688
http://www.utc.fr/~mottelet

_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr
Gael Mahe Gael Mahe
Reply | Threaded
Open this post in threaded view
|

Re: scilab 5.5.2 sur Mac OS

Voici le résultat :

Matching Java Virtual Machines (5):
     13.0.1, x86_64: "OpenJDK  
13.0.1" /Library/Java/JavaVirtualMachines/adoptopenjdk-13.0.1.jdk/Contents/Home
     11.0.5, x86_64: "OpenJDK  
11.0.5" /Library/Java/JavaVirtualMachines/openjdk11/Contents/Home
     1.8.0_242, x86_64: "AdoptOpenJDK  
8" /Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home
     1.6.0_65-b14-468, x86_64: "Java SE  
6" /Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
     1.6.0_65-b14-468, i386: "Java SE  
6" /Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

/Library/Java/JavaVirtualMachines/adoptopenjdk-13.0.1.jdk/Contents/Home


Stéphane Mottelet <[hidden email]> a écrit :

> Avant d'utiliser une méthode plus drastique, peux-tu taper la  
> commande suivante
>
> /usr/libexec/java_home -V
>
> pour voir si tu as une autre version de Java que celle du projet  
> adoptopenjdk ?
>
> S.
>
> Le 01/04/2020 à 17:09, [hidden email] a écrit :
>> Merci
>> Voici le message d'erreur :
>>
>> *******
>>
>> JavaVM: requested Java version (1.5) not available. Using Java at  
>> "/Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home"  
>> instead.
>> JavaVM: Failed to load JVM:  
>> /Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home/bundle/Libraries/libserver.dylib
>> JavaVM FATAL: Failed to load the jvm library.
>> JavaVM: requested Java version (1.5) not available. Using Java at  
>> "/Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home"  
>> instead.
>> JavaVM: Failed to load JVM:  
>> /Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home/bundle/Libraries/libserver.dylib
>> JavaVM FATAL: Failed to load the jvm library.
>> Erreur lors de la création de la Machine Virtuelle Java : Erreur  
>> JNI inconnue
>> Options :
>> 0: -Djava.library.path=
>> 1:  
>> -Djava.class.path=/Applications/scilab-5.5.2.app/Contents/MacOS/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar
>> 2:  
>> -Djava.util.logging.config.file=/Applications/scilab-5.5.2.app/Contents/MacOS/share/scilab/etc/logging.properties
>> 3: -Djava.compiler=JIT
>> 4: -Xmx256m
>> 5: -Xrs
>> 6: -Dapple.laf.useScreenMenuBar=true
>> 7: -Djogamp.gluegen.UseTempJarCache=false
>>
>> Scilab ne peut pas ouvrir la bibliothèque JVM.
>>
>> **************
>>
>>
>> Stéphane Mottelet <[hidden email]> a écrit :
>>
>>> Bonjour,
>>>
>>> Le 01/04/2020 à 13:23, [hidden email] a écrit :
>>>> Bonjour,
>>>>
>>>> J'avais scilab 5.5.2 et 6 sur Mac OS 10.11.6 (El Capitan, je ne  
>>>> peux pas upgrader), qui fonctionnaient très bien tous les deux.
>>>>
>>>> Suite à une autre installation de logiciel (qui semble avoir  
>>>> touché à l'openjdk), scilab 5.5.2 ne se lance plus. J'ai rechargé  
>>>> successivement les deux versions qui figurent sur  
>>>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2 
>>>> :
>>>> -  
>>>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2/scilab-5.5.2.1-x86_64.dmg -> au lancement, une fenêtre me dit que c'est une version pour Mac OS 10.6 à  
>>>> 10.9...
>>>> -  
>>>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.scilab.org/download/5.5.2/scilab-5.5.2.1-x86_64_yosemite.dmg -> au lancement, rien ne se  
>>>> passe
>>>>
>>>> Une idée ?
>>>
>>> oui, essayer de lancer les applications concernées en ligne de  
>>> commande pour voir les messages d'erreur. Par exemple dans le  
>>> terminal, il suffit de taper
>>>
>>> /Applications/scilab-5.5.2.app/Contents/MacOS/bin/scilab
>>>
>>> Donne-nous ensuite le message d'erreur obtenu (sûrement une  
>>> histoire de librairie incompatible ou autre)
>>>
>>> S.
>>>
>>>>
>>>> Cordialement,
>>>>
>>>> Gaël
>>>>
>>>>
>>>> ----------------------------------------------------------------
>>>> This message was sent using IMP, the Internet Messaging Program.
>>>> _______________________________________________
>>>> users-fr mailing list
>>>> [hidden email]
>>>> https://antispam.utc.fr/proxy/2/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org/mailman/listinfo/users-fr
>>>
>>> --
>>> Stéphane Mottelet
>>> Ingénieur de recherche
>>> EA 4297 Transformations Intégrées de la Matière Renouvelable
>>> Département Génie des Procédés Industriels
>>> Sorbonne Universités - Université de Technologie de Compiègne
>>> CS 60319, 60203 Compiègne cedex
>>> Tel : +33(0)344234688
>>> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/www.utc.fr/~mottelet 
>>> _______________________________________________
>>> users-fr mailing list
>>> [hidden email]
>>> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org/mailman/listinfo/users-fr
>>
>>
>>
>> ----------------------------------------------------------------
>> This message was sent using IMP, the Internet Messaging Program.
>> _______________________________________________
>> users-fr mailing list
>> [hidden email]
>> https://antispam.utc.fr/proxy/1/c3RlcGhhbmUubW90dGVsZXRAdXRjLmZy/lists.scilab.org/mailman/listinfo/users-fr
>
> --
> Stéphane Mottelet
> Ingénieur de recherche
> EA 4297 Transformations Intégrées de la Matière Renouvelable
> Département Génie des Procédés Industriels
> Sorbonne Universités - Université de Technologie de Compiègne
> CS 60319, 60203 Compiègne cedex
> Tel : +33(0)344234688
> http://www.utc.fr/~mottelet
>
> _______________________________________________
> users-fr mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users-fr
>



----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.
_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr