[Users-fr] sivp atom

classic Classic list List threaded Threaded
2 messages Options
Stéphane Paris-3 Stéphane Paris-3
Reply | Threaded
Open this post in threaded view
|

[Users-fr] sivp atom

Bjr,

J'utilise le module sivp sous scialb avec ubuntu 13.10.
À l'intialisation de SciLab j'obtiens déjà une erreur  avec SIVP :
SIVP - Scilab Image and Video Processing Toolbox
    Load macros
    Load gateways
atomsLoad : Une erreur est survenue au cours du chargement de 'SIVP-0.5.3.1-2':
    link : La bibliothèque partagée n'a pas été chargée: libtiff.so.4: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
Je fais donc le chargement de SIVP manuellement et alors tout se passe bien. Ensuite je tape les commandes suivantes :
I=imread(uigetfile());
et j'obtiens l'erreur suivante :
                      !--error 42
Oups. Une erreur fatale a été détectée par Scilab.
Votre session va probablement se fermer.
Veuillez signaler un bug sur http://bugzilla.scilab.org/ avec :
* Un exemple de code qui reproduit le problème
* Le résultat de [a, b] = getdebuginfo()
* Les informations suivantes :
[paris-HP-EliteBook-Folio-9470m:14983] Signal: Abandon (6)
[paris-HP-EliteBook-Folio-9470m:14983] Signal code:  (-6)
 
Pile d'appel :
   1: 0x424    <__kernel_vsyscall>              ()
   2: 0x2eaff  <gsignal>                        (/lib/i386-linux-gnu/libc.so.6)
   3: 0x32083  <abort>                          (/lib/i386-linux-gnu/libc.so.6)
   4: 0x4c605  <__gnu_cxx::__verbose_terminate_handler()> (/usr/lib/i386-linux-gnu/libstdc++.so.6)
   5: 0x4a273  < >                              (/usr/lib/i386-linux-gnu/libstdc++.so.6)
   6: 0x4a2af  < >                              (/usr/lib/i386-linux-gnu/libstdc++.so.6)
   7: 0x4a50e  < >                              (/usr/lib/i386-linux-gnu/libstdc++.so.6)
   8: 0xa9a33  <cv::error(cv::Exception const&)> (/usr/lib/libopencv_core.so)
   9: 0x1931f2 <cv::Mat::copySize(cv::Mat const&)> (/usr/lib/libopencv_core.so)
  10: 0x16d54  < >                              (/usr/lib/libopencv_highgui.so)
  11: 0x16f97  <cvLoadImage>                    (/usr/lib/libopencv_highgui.so)
  12: 0x9926   <int_imread>                     (/usr/lib/scilab-sivp/sci_gateway/cpp//libgw_sivp.so)
  13: 0x5e47d  <sci_gateway>                    (/usr/lib/scilab/libscilab-cli.so.0)
  14: 0xb4fe   <libgw_sivp_>                    (/usr/lib/scilab-sivp/sci_gateway/cpp//libgw_sivp.so)
  15: 0x3860c3 <userlk_>                        (/usr/lib/scilab/libscilab-cli.so.0)
  16: 0x163698 <callinterf_>                    (/usr/lib/scilab/libscilab-cli.so.0)
  17: 0x169667 <scirun_>                        (/usr/lib/scilab/libscilab-cli.so.0)
  18: 0x14373d <realmain>                       (/usr/lib/scilab/libscilab-cli.so.0)
  19: 0x1141   < >                              (/usr/bin/scilab-bin)
  20: 0x19905  <__libc_start_main>              (/lib/i386-linux-gnu/libc.so.6)
  21: 0x156d   < >                              (/usr/bin/scilab-bin)
Fin de la pile
                      !--error 999
Abandon du calcul en cours

Si quelqu'un pouvait m'aider à réparer ces erreurs, ça serait sympa.
Stéfane


_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr
manuk7 manuk7
Reply | Threaded
Open this post in threaded view
|

Re: sivp atom

Le 20/02/2014 17:25, Stéphane Paris a écrit :

> Bjr,
>
> J'utilise le module sivp sous scialb avec ubuntu 13.10.
> À l'intialisation de SciLab j'obtiens déjà une erreur  avec SIVP :
>
>     SIVP - Scilab Image and Video Processing Toolbox
>         Load macros
>         Load gateways
>     atomsLoad : Une erreur est survenue au cours du chargement de
>     'SIVP-0.5.3.1-2':
>         link : La bibliothèque partagée n'a pas été chargée:
>     libtiff.so.4: Ne peut ouvrir le fichier d'objet partagé: Aucun
>     fichier ou dossier de ce type
>
> Je fais donc le chargement de SIVP manuellement et alors tout se passe
> bien. Ensuite je tape les commandes suivantes :
>
>     I=imread(uigetfile());
>
> et j'obtiens l'erreur suivante :
>
>                           !--error 42
>     Oups. Une erreur fatale a été détectée par Scilab.
>     Votre session va probablement se fermer.
>     Veuillez signaler un bug sur http://bugzilla.scilab.org/ avec :
>     * Un exemple de code qui reproduit le problème
>     * Le résultat de [a, b] = getdebuginfo()
>     * Les informations suivantes :
>     [paris-HP-EliteBook-Folio-9470m:14983] Signal: Abandon (6)
>     [paris-HP-EliteBook-Folio-9470m:14983] Signal code:  (-6)
>      
>     Pile d'appel :
>        1: 0x424    <__kernel_vsyscall>              ()
>        2: 0x2eaff  <gsignal>                      
>     (/lib/i386-linux-gnu/libc.so.6)
>        3: 0x32083  <abort>                        
>     (/lib/i386-linux-gnu/libc.so.6)
>        4: 0x4c605  <__gnu_cxx::__verbose_terminate_handler()>
>     (/usr/lib/i386-linux-gnu/libstdc++.so.6)
>        5: 0x4a273  < >                            
>     (/usr/lib/i386-linux-gnu/libstdc++.so.6)
>        6: 0x4a2af  < >                            
>     (/usr/lib/i386-linux-gnu/libstdc++.so.6)
>        7: 0x4a50e  < >                            
>     (/usr/lib/i386-linux-gnu/libstdc++.so.6)
>        8: 0xa9a33  <cv::error(cv::Exception const&)>
>     (/usr/lib/libopencv_core.so)
>        9: 0x1931f2 <cv::Mat::copySize(cv::Mat const&)>
>     (/usr/lib/libopencv_core.so)
>       10: 0x16d54  < >                            
>     (/usr/lib/libopencv_highgui.so)
>       11: 0x16f97  <cvLoadImage>                  
>     (/usr/lib/libopencv_highgui.so)
>       12: 0x9926   <int_imread>                    
>     (/usr/lib/scilab-sivp/sci_gateway/cpp//libgw_sivp.so)
>       13: 0x5e47d  <sci_gateway>                  
>     (/usr/lib/scilab/libscilab-cli.so.0)
>       14: 0xb4fe   <libgw_sivp_>                  
>     (/usr/lib/scilab-sivp/sci_gateway/cpp//libgw_sivp.so)
>       15: 0x3860c3 <userlk_>                      
>     (/usr/lib/scilab/libscilab-cli.so.0)
>       16: 0x163698 <callinterf_>                  
>     (/usr/lib/scilab/libscilab-cli.so.0)
>       17: 0x169667 <scirun_>                      
>     (/usr/lib/scilab/libscilab-cli.so.0)
>       18: 0x14373d <realmain>                      
>     (/usr/lib/scilab/libscilab-cli.so.0)
>       19: 0x1141   < >                              (/usr/bin/scilab-bin)
>       20: 0x19905  <__libc_start_main>            
>     (/lib/i386-linux-gnu/libc.so.6)
>       21: 0x156d   < >                              (/usr/bin/scilab-bin)
>     Fin de la pile
>                           !--error 999
>     Abandon du calcul en cours
>
> Si quelqu'un pouvait m'aider à réparer ces erreurs, ça serait sympa.
> Stéfane
>
>
>
> _______________________________________________
> users-fr mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users-fr
>

Bonjour,

Une piste par rapport à la première erreur : est-ce que le paquet
libtiff4 est installé ?
Il est étrange que l'erreur disparaisse en faisant le chargement du
module à la main.
Chez moi il me manquait la 'libjpeg62'; une fois installé le module
fonctionne correctement.

Est-ce que l'erreur apparait après avoir choisi une image ou dès la
validation de la commande ? Quelle est votre version de Scilab ?

Cordialement,

_______________________________________________
users-fr mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users-fr