problème fonction CL_deg2rad

classic Classic list List threaded Threaded
5 messages Options
sdeligny sdeligny
Reply | Threaded
Open this post in threaded view
|

problème fonction CL_deg2rad

Bonjour,
Je commence à utiliser le module celestlab pour un projet nano-satellite, et j'ai rencontré un problème lors de l’exécution de la fonction CL_deg2rad. Celle-ci fonctionne normalement lorsqu'elle est employée de la manière suivante : x_rad = CL_deg2rad(x_deg).

Mais avec l'écriture x_rad = x_deg * %CL_deg2rad, la console me renvoie :

"error 4 - Variable non définie : %CL_deg2rad"

Une visite de l'aide m'indique pourtant que l'utilisation de cette écriture est possible...

Je ne comprends pas, cela vient-il d'un problème de version ?

Merci de votre réponse,

Bien Cordialement,

Simon DELIGNY,
élève-ingénieur Centrale Marseille

Frederic Jourdin Frederic Jourdin
Reply | Threaded
Open this post in threaded view
|

Re: problème fonction CL_deg2rad

There is a special Scilab mailing list for French language.
(je me rappelle plus l'adresse...)
Fred


Le 04/12/2012 20:07, sdeligny a écrit :

> Bonjour,
> Je commence à utiliser le module celestlab pour un projet nano-satellite, et
> j'ai rencontré un problème lors de l’exécution de la fonction CL_deg2rad.
> Celle-ci fonctionne normalement lorsqu'elle est employée de la manière
> suivante : x_rad = CL_deg2rad(x_deg).
>
> Mais avec l'écriture x_rad = x_deg * %CL_deg2rad, la console me renvoie :
>
> "error 4 - Variable non définie : %CL_deg2rad"
>
> Une visite de l'aide m'indique pourtant que l'utilisation de cette écriture
> est possible...
>
> Je ne comprends pas, cela vient-il d'un problème de version ?
>
> Merci de votre réponse,
>
> Bien Cordialement,
>
> Simon DELIGNY,
> élève-ingénieur Centrale Marseille
>
>
>
>
>
> --
> View this message in context: http://mailinglists.scilab.org/probleme-fonction-CL-deg2rad-tp4025429.html
> Sent from the Scilab users - Mailing Lists Archives mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users
>    

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Sylvestre Ledru-4 Sylvestre Ledru-4
Reply | Threaded
Open this post in threaded view
|

Re: problème fonction CL_deg2rad

You can subscribe by sending an email to:
[hidden email]

and the archives are here:
http://mailinglists.scilab.org/CelestLab-f3653733.html

Sylvestre

On 05/12/2012 09:47, Frederic Jourdin wrote:

> There is a special Scilab mailing list for French language.
> (je me rappelle plus l'adresse...)
> Fred
>
>
> Le 04/12/2012 20:07, sdeligny a écrit :
>> Bonjour,
>> Je commence à utiliser le module celestlab pour un projet
>> nano-satellite, et
>> j'ai rencontré un problème lors de l’exécution de la fonction CL_deg2rad.
>> Celle-ci fonctionne normalement lorsqu'elle est employée de la manière
>> suivante : x_rad = CL_deg2rad(x_deg).
>>
>> Mais avec l'écriture x_rad = x_deg * %CL_deg2rad, la console me renvoie :
>>
>> "error 4 - Variable non définie : %CL_deg2rad"
>>
>> Une visite de l'aide m'indique pourtant que l'utilisation de cette
>> écriture
>> est possible...
>>
>> Je ne comprends pas, cela vient-il d'un problème de version ?
>>
>> Merci de votre réponse,
>>
>> Bien Cordialement,
>>
>> Simon DELIGNY,
>> élève-ingénieur Centrale Marseille
>>
>>
>>
>>
>>
>> --
>> View this message in context:
>> http://mailinglists.scilab.org/probleme-fonction-CL-deg2rad-tp4025429.html
>>
>> Sent from the Scilab users - Mailing Lists Archives mailing list
>> archive at Nabble.com.
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.scilab.org/mailman/listinfo/users
>>    
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
Alain LAMY Alain LAMY
Reply | Threaded
Open this post in threaded view
|

Re: problème fonction CL_deg2rad

Hi,

About the initial question :

The solution is probably: CL_init()
which creates various local variables including %CL_deg2rad.

You can also add the line "CL_init();" in the "scilab.ini" file
so that the variables exist each time you start Scilab.
(type "SCIHOME" for the directory where this file is)

Alain


-----Message d'origine-----
De : [hidden email] [mailto:[hidden email]] De la part de Sylvestre Ledru
Envoyé : mercredi 5 décembre 2012 09:50
À : [hidden email]
Objet : Re: [Scilab-users] problème fonction CL_deg2rad

You can subscribe by sending an email to:
[hidden email]

and the archives are here:
http://mailinglists.scilab.org/CelestLab-f3653733.html

Sylvestre

On 05/12/2012 09:47, Frederic Jourdin wrote:

> There is a special Scilab mailing list for French language.
> (je me rappelle plus l'adresse...)
> Fred
>
>
> Le 04/12/2012 20:07, sdeligny a écrit :
>> Bonjour,
>> Je commence à utiliser le module celestlab pour un projet
>> nano-satellite, et
>> j'ai rencontré un problème lors de l’exécution de la fonction CL_deg2rad.
>> Celle-ci fonctionne normalement lorsqu'elle est employée de la manière
>> suivante : x_rad = CL_deg2rad(x_deg).
>>
>> Mais avec l'écriture x_rad = x_deg * %CL_deg2rad, la console me renvoie :
>>
>> "error 4 - Variable non définie : %CL_deg2rad"
>>
>> Une visite de l'aide m'indique pourtant que l'utilisation de cette
>> écriture
>> est possible...
>>
>> Je ne comprends pas, cela vient-il d'un problème de version ?
>>
>> Merci de votre réponse,
>>
>> Bien Cordialement,
>>
>> Simon DELIGNY,
>> élève-ingénieur Centrale Marseille
>>
>>
>>
>>
>>
>> --
>> View this message in context:
>> http://mailinglists.scilab.org/probleme-fonction-CL-deg2rad-tp4025429.html
>>
>> Sent from the Scilab users - Mailing Lists Archives mailing list
>> archive at Nabble.com.
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.scilab.org/mailman/listinfo/users
>>    
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
sdeligny sdeligny
Reply | Threaded
Open this post in threaded view
|

Re: problème fonction CL_deg2rad

Thank you very much Alain ! It works perfectly with cl_init(). Plus it was written into the readme file... I'm sorry for my mistake, i didn't really understand where i had to post my message.

Le 12 déc. 2012 10:10, "Alain LAMY [via Scilab / Xcos - Mailing Lists Archives]" <[hidden email]> a écrit :
Hi,

About the initial question :

The solution is probably: CL_init()
which creates various local variables including %CL_deg2rad.

You can also add the line "CL_init();" in the "scilab.ini" file
so that the variables exist each time you start Scilab.
(type "SCIHOME" for the directory where this file is)

Alain


-----Message d'origine-----
De : [hidden email] [mailto:[hidden email]] De la part de Sylvestre Ledru
Envoyé : mercredi 5 décembre 2012 09:50
À : [hidden email]
Objet : Re: [Scilab-users] problème fonction CL_deg2rad

You can subscribe by sending an email to:
[hidden email]

and the archives are here:
http://mailinglists.scilab.org/CelestLab-f3653733.html

Sylvestre

On 05/12/2012 09:47, Frederic Jourdin wrote:

> There is a special Scilab mailing list for French language.
> (je me rappelle plus l'adresse...)
> Fred
>
>
> Le 04/12/2012 20:07, sdeligny a écrit :
>> Bonjour,
>> Je commence à utiliser le module celestlab pour un projet
>> nano-satellite, et
>> j'ai rencontré un problème lors de l’exécution de la fonction CL_deg2rad.
>> Celle-ci fonctionne normalement lorsqu'elle est employée de la manière
>> suivante : x_rad = CL_deg2rad(x_deg).
>>
>> Mais avec l'écriture x_rad = x_deg * %CL_deg2rad, la console me renvoie :
>>
>> "error 4 - Variable non définie : %CL_deg2rad"
>>
>> Une visite de l'aide m'indique pourtant que l'utilisation de cette
>> écriture
>> est possible...
>>
>> Je ne comprends pas, cela vient-il d'un problème de version ?
>>
>> Merci de votre réponse,
>>
>> Bien Cordialement,
>>
>> Simon DELIGNY,
>> élève-ingénieur Centrale Marseille
>>
>>
>>
>>
>>
>> --
>> View this message in context:
>> http://mailinglists.scilab.org/probleme-fonction-CL-deg2rad-tp4025429.html
>>

>> Sent from the Scilab users - Mailing Lists Archives mailing list
>> archive at Nabble.com.
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.scilab.org/mailman/listinfo/users
>>    
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.scilab.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.scilab.org/mailman/listinfo/users



If you reply to this email, your message will be added to the discussion below:
http://mailinglists.scilab.org/probleme-fonction-CL-deg2rad-tp4025429p4025467.html
To unsubscribe from problème fonction CL_deg2rad, click here.
NAML