xcos failure

classic Classic list List threaded Threaded
5 messages Options
e-letter e-letter
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

xcos failure

Readers,

Tried to activate xcos but failure occurred:

Undefined variable: Xcos



if with_module("xcos") then xcos(); else disp(gettext("Please install xcos m
                                   !--error 999
xcos: Unable to load the hdf5-java (jhdf5) library.
Expecting version [1, 8, 4] ; Getting version [0, 0, 0] .
while executing a callback

How to solve please?

scilab53
openjdk16022
sylvestre sylvestre
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: xcos failure

Le vendredi 04 novembre 2011 à 09:46 +0000, e-letter a écrit :

> Readers,
>
> Tried to activate xcos but failure occurred:
>
> Undefined variable: Xcos
>
>
>
> if with_module("xcos") then xcos(); else disp(gettext("Please install xcos m
>                                    !--error 999
> xcos: Unable to load the hdf5-java (jhdf5) library.
> Expecting version [1, 8, 4] ; Getting version [0, 0, 0] .
> while executing a callback
>
> How to solve please?
It is the same issue you reported in the previous email...
http://mailinglists.scilab.org/scilab-java-td3479658.html

Sylvestre


e-letter e-letter
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: xcos failure

On 04/11/2011, Sylvestre Ledru <[hidden email]> wrote:

> Le vendredi 04 novembre 2011 à 09:46 +0000, e-letter a écrit :
>> Readers,
>>
>> Tried to activate xcos but failure occurred:
>>
>> Undefined variable: Xcos
>>
>>
>>
>> if with_module("xcos") then xcos(); else disp(gettext("Please install xcos
>> m
>>                                    !--error 999
>> xcos: Unable to load the hdf5-java (jhdf5) library.
>> Expecting version [1, 8, 4] ; Getting version [0, 0, 0] .
>> while executing a callback
>>
>> How to solve please?
> It is the same issue you reported in the previous email...
> http://mailinglists.scilab.org/scilab-java-td3479658.html
>

jdhf5 files were installed and contains:

fits-2.6.1.jar, fits.jar, jhdf5-2.6.1.jar, jhdf5.jar,
jhdf5obj-2.6.1.jar, jhdf5obj.jar, jhdfobj-2.6.1.jar, jhdfobj.jar,
jhdfview-2.6.1.jar, jhdfview.jar, junit-2.6.1.jar, junit.jar,
netcdf-2.6.1.jar, netcdf.jar

After installation and start of scilab, the following error is reported:

 ___________________________________________
                     scilab-branch-5.3

                Consortium Scilab (DIGITEO)
              Copyright (c) 1989-2011 (INRIA)
              Copyright (c) 1989-2007 (ENPC)
        ___________________________________________


Startup execution:
  loading initial environment

if with_module("xcos") then xcos(); else disp(gettext("Please install xcos m
                                   !--error 999
xcos: Unable to load the hdf5-java (jhdf5) library.
Expecting version [1, 8, 4] ; Getting version [1, 8, 2] .
while executing a callback
Clément David-2 Clément David-2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: xcos failure

Hello,

Important part :
> xcos: Unable to load the hdf5-java (jhdf5) library.
> Expecting version [1, 8, 4] ; Getting version [1, 8, 2] .

Update hdf5 and jhdf5 versions as 1.8.2 has some major issues and we do
not support it anymore.

--
Clément

Le vendredi 04 novembre 2011 à 10:16 +0000, e-letter a écrit :

> On 04/11/2011, Sylvestre Ledru <[hidden email]> wrote:
> > Le vendredi 04 novembre 2011 à 09:46 +0000, e-letter a écrit :
> >> Readers,
> >>
> >> Tried to activate xcos but failure occurred:
> >>
> >> Undefined variable: Xcos
> >>
> >>
> >>
> >> if with_module("xcos") then xcos(); else disp(gettext("Please install xcos
> >> m
> >>                                    !--error 999
> >> xcos: Unable to load the hdf5-java (jhdf5) library.
> >> Expecting version [1, 8, 4] ; Getting version [0, 0, 0] .
> >> while executing a callback
> >>
> >> How to solve please?
> > It is the same issue you reported in the previous email...
> > http://mailinglists.scilab.org/scilab-java-td3479658.html
> >
>
> jdhf5 files were installed and contains:
>
> fits-2.6.1.jar, fits.jar, jhdf5-2.6.1.jar, jhdf5.jar,
> jhdf5obj-2.6.1.jar, jhdf5obj.jar, jhdfobj-2.6.1.jar, jhdfobj.jar,
> jhdfview-2.6.1.jar, jhdfview.jar, junit-2.6.1.jar, junit.jar,
> netcdf-2.6.1.jar, netcdf.jar
>
> After installation and start of scilab, the following error is reported:
>
>  ___________________________________________
>                      scilab-branch-5.3
>
>                 Consortium Scilab (DIGITEO)
>               Copyright (c) 1989-2011 (INRIA)
>               Copyright (c) 1989-2007 (ENPC)
>         ___________________________________________
>
>
> Startup execution:
>   loading initial environment
>
> if with_module("xcos") then xcos(); else disp(gettext("Please install xcos m
>                                    !--error 999
> xcos: Unable to load the hdf5-java (jhdf5) library.
> Expecting version [1, 8, 4] ; Getting version [1, 8, 2] .
> while executing a callback

--
Clément David <[hidden email]>
Scilab Enterprises

e-letter e-letter
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: xcos failure

On 04/11/2011, Clément David <[hidden email]> wrote:
> Hello,
>
> Important part :
>> xcos: Unable to load the hdf5-java (jhdf5) library.
>> Expecting version [1, 8, 4] ; Getting version [1, 8, 2] .
>
> Update hdf5 and jhdf5 versions as 1.8.2 has some major issues and we do
> not support it anymore.
>

Command terminal errors indicate a conflict in requirements.

rpm -i libhdf5-0-1.8.2-2.2.i586.rpm
warning: libhdf5-0-1.8.2-2.2.i586.rpm: Header V3 DSA/SHA1 Signature,
key ID bd432934: NOKEY
        package libhdf5-0-1.8.7-1.6.i586 (which is newer than
libhdf5-0-1.8.2-2.2.i586) is already installed

So version 187 was removed and installation of scilab attempted

rpm -i -a scilab-5.3.1-13.7.i586.rpm
error: Failed dependencies:
        libhdf5.so.6 is needed by scilab-5.3.1-13.7.i586

And the original xcos error occurs! The upgrade of hdf breaks
dependency with earlier version.
Loading...